From: Sibi Sankar <sibis@codeaurora.org>
To: Viresh Kumar <viresh.kumar@linaro.org>
Cc: robh+dt@kernel.org, andy.gross@linaro.org,
myungjoo.ham@samsung.com, kyungmin.park@samsung.com,
rjw@rjwysocki.net, nm@ti.com, sboyd@kernel.org,
georgi.djakov@linaro.org, bjorn.andersson@linaro.org,
david.brown@linaro.org, mark.rutland@arm.com,
linux-kernel@vger.kernel.org,
linux-arm-msm-owner@vger.kernel.org, devicetree@vger.kernel.org,
rnayak@codeaurora.org, cw00.choi@samsung.com,
linux-pm@vger.kernel.org, evgreen@chromium.org,
daidavid1@codeaurora.org, dianders@chromium.org
Subject: Re: [PATCH RFC 6/9] OPP: Add and export helper to update voltage
Date: Wed, 10 Apr 2019 16:38:22 +0530 [thread overview]
Message-ID: <bccbe28d586be4304122e3fba27e7d67@codeaurora.org> (raw)
In-Reply-To: <20190410102429.r6j6brm5kspmqxc3@vireshk-i7>
Hey Viresh,
Thanks for the review!
On 2019-04-10 15:54, Viresh Kumar wrote:
> On 28-03-19, 20:58, Sibi Sankar wrote:
>> Add and export 'dev_pm_opp_update_voltage' to find and update voltage
>> of an opp for a given frequency. This will be useful to update the
>> opps
>> with voltages read back from firmware.
>>
>> Signed-off-by: Sibi Sankar <sibis@codeaurora.org>
>> ---
>> drivers/opp/core.c | 62
>> ++++++++++++++++++++++++++++++++++++++++++
>> include/linux/pm_opp.h | 10 +++++++
>> 2 files changed, 72 insertions(+)
>>
>> diff --git a/drivers/opp/core.c b/drivers/opp/core.c
>> index addaf7aae9ae..c066cd120a33 100644
>> --- a/drivers/opp/core.c
>> +++ b/drivers/opp/core.c
>> @@ -2090,6 +2090,68 @@ int dev_pm_opp_disable(struct device *dev,
>> unsigned long freq)
>> }
>> EXPORT_SYMBOL_GPL(dev_pm_opp_disable);
>>
>> +static int _opp_update_voltage(struct device *dev, unsigned long
>> freq,
>> + unsigned long u_volt)
>> +{
>> + struct opp_table *opp_table;
>> + struct dev_pm_opp *tmp_opp, *opp = ERR_PTR(-ENODEV);
>> + int r = 0;
>
> s/r/ret/
>
>> +
>> + /* Find the opp_table */
>> + opp_table = _find_opp_table(dev);
>> + if (IS_ERR(opp_table)) {
>> + r = PTR_ERR(opp_table);
>> + dev_warn(dev, "%s: Device OPP not found (%d)\n", __func__, r);
>
> Why dev_warn instead of dev_err which is normally used in this file ?
> And you
> weren't searching for OPP but opp_table. Put out the correct error
> message
> please.
yeah I'll use dev_err (I'll fix the same in
_opp_set_availability too)
>
>> + return r;
>> + }
>> +
>> + mutex_lock(&opp_table->lock);
>> +
>> + /* Do we have the frequency? */
>> + list_for_each_entry(tmp_opp, &opp_table->opp_list, node) {
>> + if (tmp_opp->rate == freq) {
>> + opp = tmp_opp;
>> + break;
>> + }
>> + }
>> +
>> + if (IS_ERR(opp)) {
>> + r = PTR_ERR(opp);
>> + goto unlock;
>> + }
>> +
>> + /* update only if the opp is disabled */
>> + if (opp->available)
>> + goto unlock;
>> +
>
> What about reusing dev_pm_opp_find_freq_exact() instead of the above
> code in
> this routine ?
yes I'll use that
>
>> + opp->supplies[0].u_volt = u_volt;
>> +
>> +unlock:
>> + mutex_unlock(&opp_table->lock);
>> + dev_pm_opp_put_opp_table(opp_table);
>> + return r;
>> +}
>> +
>> +/**
>> + * dev_pm_opp_update_voltage() - find and update voltage of an opp
>> + * for a given frequency
>> + * @dev: device for which we do this operation
>> + * @freq: OPP frequency to update voltage
>> + * @u_volt: voltage requested for this opp
>> + *
>> + * This is useful only for devices with single power supply.
>> + *
>> + * Return: -EINVAL for bad pointers, -ENOMEM if no memory available
>> for the
>> + * copy operation, returns 0 if no modification was done OR
>> modification was
>> + * successful.
>> + */
>> +int dev_pm_opp_update_voltage(struct device *dev, unsigned long freq,
>> + unsigned long u_volt)
>> +{
>> + return _opp_update_voltage(dev, freq, u_volt);
>
> Remove the unnecessary wrapper and open code this routine here. While
> at it, you
> should updated min/max/target and not just target voltage.
will fix this in the next-respin
>
>> +}
>> +EXPORT_SYMBOL_GPL(dev_pm_opp_update_voltage);
>> +
>> /**
>> * dev_pm_opp_register_notifier() - Register OPP notifier for the
>> device
>> * @dev: Device for which notifier needs to be registered
>> diff --git a/include/linux/pm_opp.h b/include/linux/pm_opp.h
>> index d7cb0e65c4f0..58490f6839ce 100644
>> --- a/include/linux/pm_opp.h
>> +++ b/include/linux/pm_opp.h
>> @@ -130,6 +130,9 @@ int dev_pm_opp_enable(struct device *dev, unsigned
>> long freq);
>>
>> int dev_pm_opp_disable(struct device *dev, unsigned long freq);
>>
>> +int dev_pm_opp_update_voltage(struct device *dev, unsigned long freq,
>> + unsigned long u_volt);
>> +
>> int dev_pm_opp_register_notifier(struct device *dev, struct
>> notifier_block *nb);
>> int dev_pm_opp_unregister_notifier(struct device *dev, struct
>> notifier_block *nb);
>>
>> @@ -265,6 +268,13 @@ static inline int dev_pm_opp_disable(struct
>> device *dev, unsigned long freq)
>> return 0;
>> }
>>
>> +static inline int dev_pm_opp_update_voltage(struct device *dev,
>> + unsigned long freq,
>> + unsigned long u_volt)
>> +{
>> + return 0;
>> +}
>> +
>> static inline int dev_pm_opp_register_notifier(struct device *dev,
>> struct notifier_block *nb)
>> {
>> return -ENOTSUPP;
>> --
>> The Qualcomm Innovation Center, Inc. is a member of the Code Aurora
>> Forum,
>> a Linux Foundation Collaborative Project
--
-- Sibi Sankar --
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
a Linux Foundation Collaborative Project.
next prev parent reply other threads:[~2019-04-10 11:08 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-03-28 15:28 [PATCH RFC 0/9] Add CPU based scaling support to Passive governor Sibi Sankar
2019-03-28 15:28 ` [PATCH RFC 1/9] OPP: Add and export helpers to get avg/peak bw Sibi Sankar
2019-03-28 15:28 ` [PATCH RFC 2/9] OPP: Export a number of helpers to prevent code duplication Sibi Sankar
2019-07-08 3:28 ` Hsin-Yi Wang
2019-07-10 8:01 ` Sibi Sankar
2019-03-28 15:28 ` [PATCH RFC 3/9] PM / devfreq: Add cpu based scaling support to passive_governor Sibi Sankar
2019-04-12 7:39 ` Chanwoo Choi
2019-05-27 8:23 ` Sibi Sankar
2019-05-28 1:27 ` Chanwoo Choi
2019-03-28 15:28 ` [PATCH RFC 4/9] dt-bindings: devfreq: Add bindings for devfreq dev-icbw driver Sibi Sankar
2019-03-28 15:28 ` [PATCH RFC 5/9] PM / devfreq: Add devfreq driver for interconnect bandwidth voting Sibi Sankar
2019-03-28 15:28 ` [PATCH RFC 6/9] OPP: Add and export helper to update voltage Sibi Sankar
2019-04-10 10:24 ` Viresh Kumar
2019-04-10 11:08 ` Sibi Sankar [this message]
2019-03-28 15:28 ` [PATCH RFC 7/9] cpufreq: qcom: Add support to update cpu node's OPP tables Sibi Sankar
2019-04-10 10:33 ` Viresh Kumar
2019-04-10 11:16 ` Sibi Sankar
2019-04-10 11:25 ` Viresh Kumar
2019-03-28 15:28 ` [PATCH RFC 8/9] arm64: dts: qcom: sdm845: Add cpu " Sibi Sankar
2019-03-28 15:28 ` [PATCH RFC 9/9] arm64: dts: qcom: sdm845: Add nodes for icbw driver and opp tables Sibi Sankar
2019-04-11 7:02 ` [PATCH RFC 0/9] Add CPU based scaling support to Passive governor Sibi Sankar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=bccbe28d586be4304122e3fba27e7d67@codeaurora.org \
--to=sibis@codeaurora.org \
--cc=andy.gross@linaro.org \
--cc=bjorn.andersson@linaro.org \
--cc=cw00.choi@samsung.com \
--cc=daidavid1@codeaurora.org \
--cc=david.brown@linaro.org \
--cc=devicetree@vger.kernel.org \
--cc=dianders@chromium.org \
--cc=evgreen@chromium.org \
--cc=georgi.djakov@linaro.org \
--cc=kyungmin.park@samsung.com \
--cc=linux-arm-msm-owner@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=myungjoo.ham@samsung.com \
--cc=nm@ti.com \
--cc=rjw@rjwysocki.net \
--cc=rnayak@codeaurora.org \
--cc=robh+dt@kernel.org \
--cc=sboyd@kernel.org \
--cc=viresh.kumar@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).