linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Andrey Konovalov <andreyknvl@google.com>
To: Andrey Ryabinin <aryabinin@virtuozzo.com>,
	Alexander Potapenko <glider@google.com>,
	Dmitry Vyukov <dvyukov@google.com>,
	Catalin Marinas <catalin.marinas@arm.com>,
	Will Deacon <will.deacon@arm.com>,
	Christoph Lameter <cl@linux.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Mark Rutland <mark.rutland@arm.com>,
	Nick Desaulniers <ndesaulniers@google.com>,
	Marc Zyngier <marc.zyngier@arm.com>,
	Dave Martin <dave.martin@arm.com>,
	Ard Biesheuvel <ard.biesheuvel@linaro.org>,
	"Eric W . Biederman" <ebiederm@xmission.com>,
	Ingo Molnar <mingo@kernel.org>,
	Paul Lawrence <paullawrence@google.com>,
	Geert Uytterhoeven <geert@linux-m68k.org>,
	Arnd Bergmann <arnd@arndb.de>,
	"Kirill A . Shutemov" <kirill.shutemov@linux.intel.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Kate Stewart <kstewart@linuxfoundation.org>,
	Mike Rapoport <rppt@linux.vnet.ibm.com>,
	kasan-dev@googlegroups.com, linux-doc@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org,
	linux-sparse@vger.kernel.org, linux-mm@kvack.org,
	linux-kbuild@vger.kernel.org
Cc: Kostya Serebryany <kcc@google.com>,
	Evgeniy Stepanov <eugenis@google.com>,
	Lee Smith <Lee.Smith@arm.com>,
	Ramana Radhakrishnan <Ramana.Radhakrishnan@arm.com>,
	Jacob Bramley <Jacob.Bramley@arm.com>,
	Ruben Ayrapetyan <Ruben.Ayrapetyan@arm.com>,
	Jann Horn <jannh@google.com>, Mark Brand <markbrand@google.com>,
	Chintan Pandya <cpandya@codeaurora.org>,
	Vishwath Mohan <vishwath@google.com>,
	Andrey Konovalov <andreyknvl@google.com>
Subject: [PATCH v10 11/22] mm: move obj_to_index to include/linux/slab_def.h
Date: Tue,  6 Nov 2018 18:30:26 +0100	[thread overview]
Message-ID: <c4424b4917e92007a20170909460aac91710f1df.1541525354.git.andreyknvl@google.com> (raw)
In-Reply-To: <cover.1541525354.git.andreyknvl@google.com>

While with SLUB we can actually preassign tags for caches with contructors
and store them in pointers in the freelist, SLAB doesn't allow that since
the freelist is stored as an array of indexes, so there are no pointers to
store the tags.

Instead we compute the tag twice, once when a slab is created before
calling the constructor and then again each time when an object is
allocated with kmalloc. Tag is computed simply by taking the lowest byte of
the index that corresponds to the object. However in kasan_kmalloc we only
have access to the objects pointer, so we need a way to find out which
index this object corresponds to.

This patch moves obj_to_index from slab.c to include/linux/slab_def.h to
be reused by KASAN.

Acked-by: Christoph Lameter <cl@linux.com>
Reviewed-by: Andrey Ryabinin <aryabinin@virtuozzo.com>
Reviewed-by: Dmitry Vyukov <dvyukov@google.com>
Signed-off-by: Andrey Konovalov <andreyknvl@google.com>
---
 include/linux/slab_def.h | 13 +++++++++++++
 mm/slab.c                | 13 -------------
 2 files changed, 13 insertions(+), 13 deletions(-)

diff --git a/include/linux/slab_def.h b/include/linux/slab_def.h
index 3485c58cfd1c..9a5eafb7145b 100644
--- a/include/linux/slab_def.h
+++ b/include/linux/slab_def.h
@@ -104,4 +104,17 @@ static inline void *nearest_obj(struct kmem_cache *cache, struct page *page,
 		return object;
 }
 
+/*
+ * We want to avoid an expensive divide : (offset / cache->size)
+ *   Using the fact that size is a constant for a particular cache,
+ *   we can replace (offset / cache->size) by
+ *   reciprocal_divide(offset, cache->reciprocal_buffer_size)
+ */
+static inline unsigned int obj_to_index(const struct kmem_cache *cache,
+					const struct page *page, void *obj)
+{
+	u32 offset = (obj - page->s_mem);
+	return reciprocal_divide(offset, cache->reciprocal_buffer_size);
+}
+
 #endif	/* _LINUX_SLAB_DEF_H */
diff --git a/mm/slab.c b/mm/slab.c
index 27859fb39889..d2f827316dfc 100644
--- a/mm/slab.c
+++ b/mm/slab.c
@@ -406,19 +406,6 @@ static inline void *index_to_obj(struct kmem_cache *cache, struct page *page,
 	return page->s_mem + cache->size * idx;
 }
 
-/*
- * We want to avoid an expensive divide : (offset / cache->size)
- *   Using the fact that size is a constant for a particular cache,
- *   we can replace (offset / cache->size) by
- *   reciprocal_divide(offset, cache->reciprocal_buffer_size)
- */
-static inline unsigned int obj_to_index(const struct kmem_cache *cache,
-					const struct page *page, void *obj)
-{
-	u32 offset = (obj - page->s_mem);
-	return reciprocal_divide(offset, cache->reciprocal_buffer_size);
-}
-
 #define BOOT_CPUCACHE_ENTRIES	1
 /* internal cache of cache description objs */
 static struct kmem_cache kmem_cache_boot = {
-- 
2.19.1.930.g4563a0d9d0-goog


  parent reply	other threads:[~2018-11-06 17:31 UTC|newest]

Thread overview: 49+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-11-06 17:30 [PATCH v10 00/22] kasan: add software tag-based mode for arm64 Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 01/22] kasan, mm: change hooks signatures Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 02/22] kasan, slub: handle pointer tags in early_kmem_cache_node_alloc Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 03/22] kasan: move common generic and tag-based code to common.c Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 04/22] kasan: rename source files to reflect the new naming scheme Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 05/22] kasan: add CONFIG_KASAN_GENERIC and CONFIG_KASAN_SW_TAGS Andrey Konovalov
2018-11-07 17:04   ` Mark Rutland
2018-11-12 18:21     ` Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 06/22] kasan, arm64: adjust shadow size for tag-based mode Andrey Konovalov
2018-11-07 16:54   ` Mark Rutland
2018-11-12 17:50     ` Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 07/22] kasan: initialize shadow to 0xff " Andrey Konovalov
2018-11-07 17:08   ` Mark Rutland
2018-11-13 14:13     ` Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 08/22] kasan, arm64: untag address in __kimg_to_phys and _virt_addr_is_linear Andrey Konovalov
2018-11-07 16:52   ` Mark Rutland
2018-11-14 19:23     ` Andrey Konovalov
2018-11-15 13:43       ` Andrey Konovalov
2018-11-07 18:10   ` Catalin Marinas
2018-11-14 19:52     ` Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 09/22] kasan: add tag related helper functions Andrey Konovalov
2018-11-07 17:23   ` Mark Rutland
2018-11-14 19:19     ` Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 10/22] kasan: preassign tags to objects with ctors or SLAB_TYPESAFE_BY_RCU Andrey Konovalov
2018-11-06 17:30 ` Andrey Konovalov [this message]
2018-11-06 17:30 ` [PATCH v10 12/22] kasan, arm64: fix up fault handling logic Andrey Konovalov
2018-11-07 18:26   ` Catalin Marinas
2018-11-08 12:22   ` Mark Rutland
2018-11-13 15:01     ` Andrey Konovalov
2018-11-13 22:07       ` Mark Rutland
2018-11-14 20:06         ` Andrey Konovalov
2018-11-14 20:17           ` Mark Rutland
2018-11-15 13:33             ` Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 13/22] kasan, arm64: enable top byte ignore for the kernel Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 14/22] kasan, mm: perform untagged pointers comparison in krealloc Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 15/22] kasan: split out generic_report.c from report.c Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 16/22] kasan: add bug reporting routines for tag-based mode Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 17/22] kasan: add hooks implementation " Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 18/22] kasan, arm64: add brk handler for inline instrumentation Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 19/22] kasan, mm, arm64: tag non slab memory allocated via pagealloc Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 20/22] kasan: add __must_check annotations to kasan hooks Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 21/22] kasan: update documentation Andrey Konovalov
2018-11-06 17:30 ` [PATCH v10 22/22] kasan: add SPDX-License-Identifier mark to source files Andrey Konovalov
2018-11-07 14:56 ` [PATCH v10 00/22] kasan: add software tag-based mode for arm64 Andrey Konovalov
2018-11-07 14:59   ` Will Deacon
2018-11-07 15:11     ` Andrey Konovalov
2018-11-07 15:34       ` Will Deacon
2018-11-07 15:54         ` Andrey Konovalov
2018-11-07 15:56         ` Andrey Konovalov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=c4424b4917e92007a20170909460aac91710f1df.1541525354.git.andreyknvl@google.com \
    --to=andreyknvl@google.com \
    --cc=Jacob.Bramley@arm.com \
    --cc=Lee.Smith@arm.com \
    --cc=Ramana.Radhakrishnan@arm.com \
    --cc=Ruben.Ayrapetyan@arm.com \
    --cc=akpm@linux-foundation.org \
    --cc=ard.biesheuvel@linaro.org \
    --cc=arnd@arndb.de \
    --cc=aryabinin@virtuozzo.com \
    --cc=catalin.marinas@arm.com \
    --cc=cl@linux.com \
    --cc=cpandya@codeaurora.org \
    --cc=dave.martin@arm.com \
    --cc=dvyukov@google.com \
    --cc=ebiederm@xmission.com \
    --cc=eugenis@google.com \
    --cc=geert@linux-m68k.org \
    --cc=glider@google.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jannh@google.com \
    --cc=kasan-dev@googlegroups.com \
    --cc=kcc@google.com \
    --cc=kirill.shutemov@linux.intel.com \
    --cc=kstewart@linuxfoundation.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kbuild@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-sparse@vger.kernel.org \
    --cc=marc.zyngier@arm.com \
    --cc=mark.rutland@arm.com \
    --cc=markbrand@google.com \
    --cc=mingo@kernel.org \
    --cc=ndesaulniers@google.com \
    --cc=paullawrence@google.com \
    --cc=rppt@linux.vnet.ibm.com \
    --cc=vishwath@google.com \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).