linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Dmitry Osipenko <digetx@gmail.com>
To: Thierry Reding <thierry.reding@gmail.com>
Cc: Jonathan Hunter <jonathanh@nvidia.com>,
	Peter De Schrijver <pdeschrijver@nvidia.com>,
	"Rafael J. Wysocki" <rjw@rjwysocki.net>,
	Daniel Lezcano <daniel.lezcano@linaro.org>,
	linux-pm@vger.kernel.org, linux-tegra@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5 00/14] Consolidate and improve NVIDIA Tegra CPUIDLE driver(s)
Date: Mon, 30 Sep 2019 21:32:51 +0300	[thread overview]
Message-ID: <cf27855a-eb85-1a38-3d04-95e7efe06ebf@gmail.com> (raw)
In-Reply-To: <20190930082645.GF1518582@ulmo>

30.09.2019 11:26, Thierry Reding пишет:
> On Sun, Sep 29, 2019 at 08:59:38PM +0300, Dmitry Osipenko wrote:
>> Hello,
>>
>> This series does the following:
>>
>>   1. Unifies Tegra20/30/114 drivers into a single driver and moves it out
>>      into common drivers/cpuidle/ directory.
>>
>>   2. Enables CPU cluster power-down idling state on Tegra30.
>>
>> In the end there is a quite nice clean up of the Tegra CPUIDLE drivers
>> and of the Tegra's arch code in general. Please review, thanks!
> 
> I generally like this series and it looks really good from a diffstat
> point of view. However, removing existing drivers completely and then
> incrementally add a new one make this impossible to review.
> 
> If you think about it, it also makes it really difficult to find what
> went wrong if at any point in the future we find a regression caused by
> the new driver. A bisection will always point at the commit that removes
> the old driver because between that and the point where you add the new
> driver, CPU idle just doesn't work at all anymore.
> 
> While I understand that it's very convenient to just throw away old code
> and rewrite it from scratch, it's also impractical (and a little rude).
> It's not how we do things in the kernel. Unless maybe under specific
> circumstances.
> 
> Can you please try and make this a little more iterative? At the very
> least I'd expect a series where you do all the preliminary work in
> preparatory patches and then replace the old driver by the new driver in
> a single patch. That way at least there will be an unambiguous commit in
> a bisection.
> 
> Ideally, you'd also break up that last conversion patch into smaller
> incremental patches to make it easier for people to review. Remember
> that your chances to attract reviewers increases if you make the patches
> easy to review, which means your patches should be small, logical
> changes that (ideally) are obviously correct.

Thanks for the detailed explanation, probably this is the same what Jon
was asking to do. Now I see what you're are asking for.

      reply	other threads:[~2019-09-30 21:01 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-09-29 17:59 [PATCH v5 00/14] Consolidate and improve NVIDIA Tegra CPUIDLE driver(s) Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 01/14] ARM: tegra: Remove cpuidle drivers to replace them with a new driver Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 02/14] ARM: tegra: Change tegra_set_cpu_in_lp2() type to void Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 03/14] ARM: tegra: Propagate error from tegra_idle_lp2_last() Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 04/14] ARM: tegra: Compile sleep-tegra20/30.S unconditionally Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 05/14] ARM: tegra: Expose PM functions required for new cpuidle driver Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 06/14] ARM: tegra: Rename some of the newly exposed PM functions Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 07/14] ARM: tegra: Add tegra_pm_park_secondary_cpu() Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 08/14] ARM: tegra: Make outer_disable() open-coded Dmitry Osipenko
2019-09-30  8:05   ` Thierry Reding
2019-09-30 14:29     ` Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 09/14] clk: tegra: Add missing stubs for the case of !CONFIG_PM_SLEEP Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 10/14] cpuidle: Introduce unified driver for NVIDIA Tegra SoCs Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 11/14] cpuidle: tegra: Support CPU cluster power-down state on Tegra30 Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 12/14] ARM: tegra: Create simple platform device for cpuidle driver Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 13/14] ARM: multi_v7_defconfig: Enable Tegra " Dmitry Osipenko
2019-09-29 17:59 ` [PATCH v5 14/14] ARM: tegra: Enable Tegra cpuidle driver in tegra_defconfig Dmitry Osipenko
2019-09-30  8:26 ` [PATCH v5 00/14] Consolidate and improve NVIDIA Tegra CPUIDLE driver(s) Thierry Reding
2019-09-30 18:32   ` Dmitry Osipenko [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cf27855a-eb85-1a38-3d04-95e7efe06ebf@gmail.com \
    --to=digetx@gmail.com \
    --cc=daniel.lezcano@linaro.org \
    --cc=jonathanh@nvidia.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=linux-tegra@vger.kernel.org \
    --cc=pdeschrijver@nvidia.com \
    --cc=rjw@rjwysocki.net \
    --cc=thierry.reding@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).