linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Kefeng Wang <wangkefeng.wang@huawei.com>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: Arnd Bergmann <arnd@arndb.de>, <linux-arch@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>, Ingo Molnar <mingo@redhat.com>,
	"David S. Miller" <davem@davemloft.net>
Subject: Re: [PATCH 3/9] sections: Move and rename core_kernel_data() to is_kernel_data()
Date: Tue, 29 Jun 2021 14:36:26 +0800	[thread overview]
Message-ID: <dc64df91-f89c-8e48-de9a-f5c864cdce12@huawei.com> (raw)
In-Reply-To: <20210628210538.0fdded1c@oasis.local.home>


On 2021/6/29 9:05, Steven Rostedt wrote:
> On Sat, 26 Jun 2021 15:34:33 +0800
> Kefeng Wang <wangkefeng.wang@huawei.com> wrote:
>
>> Move core_kernel_data() into sections.h and rename it to
>> is_kernel_data(), also make it return bool value, then
>> update all the callers.
> Removing the "core" part of "core_kernel_data()" is misleading. As
> modules can have kernel data, but this will return false on module data
> (as it should). This is similar to core_kernel_text() which this series
> doesn't seem to touch.

Yes, The series only collect and move the basic part(aka, the 'core' 
part, which only

contains the start/end address check of sections) into 
include/asm-generic/sections.h,

the core_kernel_text() contains system_state validation, it's not 
inappropriate into sections.h,

so it won't be modified and moved.

>
> I'd like to keep the "core" in the name which makes it obvious this is
> not about module data, and if someone were to make it about module
> data, it will break ftrace synchronization.

After this series, we have 5 APIs, only use core_kernel_data() is a 
little strange,

  * is_kernel_data()       --- come from core_kernel_data() in kernel.h
  * is_kernel_rodata()    --- already in sections.h
  * is_kernel_text()        --- come from kallsyms.h
  * is_kernel_inittext()   --- come from kernel.h and kallsyms.h
  * is_kernel()                --- come from kallsyms.h

Could we rename is_kernel_data() to is_kernel_core_data(), and add some 
comment your mentioned,

or any better naming, thanks.

>
> -- Steve
> .
>

  reply	other threads:[~2021-06-29  6:36 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-26  7:34 [PATCH 0/9] sections: Unify kernel sections range check and use Kefeng Wang
2021-06-26  7:34 ` [PATCH 1/9] kallsyms: Remove arch specific text and data check Kefeng Wang
2021-06-26  7:34 ` [PATCH 2/9] kallsyms: Fix address-checks for kernel related range Kefeng Wang
2021-07-05  3:35   ` Sergey Senozhatsky
2021-07-07 12:43   ` Petr Mladek
2021-06-26  7:34 ` [PATCH 3/9] sections: Move and rename core_kernel_data() to is_kernel_data() Kefeng Wang
2021-06-29  1:05   ` Steven Rostedt
2021-06-29  6:36     ` Kefeng Wang [this message]
2021-06-26  7:34 ` [PATCH 4/9] sections: Move is_kernel_inittext() into sections.h Kefeng Wang
2021-06-26  7:34 ` [PATCH 5/9] kallsyms: Rename is_kernel() and is_kernel_text() Kefeng Wang
2021-06-26  7:34 ` [PATCH 6/9] sections: Add new " Kefeng Wang
2021-06-26  7:34 ` [PATCH 7/9] s390: kprobes: Use is_kernel() helper Kefeng Wang
2021-06-28 10:02   ` Heiko Carstens
2021-06-28 11:09     ` Kefeng Wang
2021-06-26  7:34 ` [PATCH 8/9] powerpc/mm: Use is_kernel_text() and is_kernel_inittext() helper Kefeng Wang
2021-06-26  7:34 ` [PATCH 9/9] dma-debug: Use memory_intersects() directly Kefeng Wang
2021-06-28  6:11   ` Christoph Hellwig
2021-06-28  6:29     ` Kefeng Wang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=dc64df91-f89c-8e48-de9a-f5c864cdce12@huawei.com \
    --to=wangkefeng.wang@huawei.com \
    --cc=arnd@arndb.de \
    --cc=davem@davemloft.net \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=rostedt@goodmis.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).