linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Thorsten Leemhuis <regressions@leemhuis.info>
To: Heikki Krogerus <heikki.krogerus@linux.intel.com>
Cc: Mattia Orlandi <mattia.orlandi21@gmail.com>,
	"regressions@lists.linux.dev" <regressions@lists.linux.dev>,
	LKML <linux-kernel@vger.kernel.org>,
	Hans de Goede <hdegoede@redhat.com>,
	"linux-usb@vger.kernel.org" <linux-usb@vger.kernel.org>
Subject: [regression] Bug 216426 - USB-C port is incorrectly reporting that it's powered when Dell XPS 15-9500 is unplugged
Date: Thu, 1 Sep 2022 11:07:33 +0200	[thread overview]
Message-ID: <f28e3bdf-2add-574a-cf0a-5d0253ea708a@leemhuis.info> (raw)

Hi, this is your Linux kernel regression tracker speaking.

I noticed a regression report in bugzilla.kernel.org. As many (most?)
kernel developer don't keep an eye on it, I decided to forward it:

https://bugzilla.kernel.org/show_bug.cgi?id=216426

>  Mattia Orlandi 2022-08-29 17:04:21 UTC
> 
> System
> ------
> - Dell XPS 15 9500
> - 5.19.4 kernel
> 
> Problem description
> -------------------
> Whenever I plug and then unplug my laptop from AC power using the USB-C port, the system thinks it is still plugged in (i.e., the KDE applet reports "Plugged in but still discharging").
> If I check in Dell's BIOS, it correctly reports when the power supply is plugged/unplugged; `acpi -V` also correctly shows `Adapter 0: off-line`.
> 
> On the other hand, `upower -d` incorrectly reports `/org/freedesktop/UPower/devices/line_power_ucsi_source_psy_USBC000o002` as `online: yes`.
> Moreover, `journalctl` reports `ucsi_acpi USBC000:00: ucsi_handle_connector_change: GET_CONNECTOR_STATUS failed (-110)`.
> 
> I'm testing the LTS kernel (5.15.63) and the issue does not occur, so I assume it's a regression bug, possibly introduced in kernel 5.18 (I tried downgrading the kernel to version 5.18.16 and the issue was already present).

See the ticket for more details. Apologies if I forwarded it to the
wrong folks, I cover a lot of ground and thus sometimes get things
wrong. :-/

BTW, I'd also like to add the report to the list of tracked regressions
to ensure it's doesn't fall through the cracks in the end:

#regzbot introduced: v5.15..v5.18
https://bugzilla.kernel.org/show_bug.cgi?id=216426
#regzbot ignore-activity

Ciao, Thorsten (wearing his 'the Linux kernel's regression tracker' hat)

P.S.: As the Linux kernel's regression tracker I deal with a lot of
reports and sometimes miss something important when writing mails like
this. If that's the case here, don't hesitate to tell me in a public
reply, it's in everyone's interest to set the public record straight.

             reply	other threads:[~2022-09-01  9:09 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-09-01  9:07 Thorsten Leemhuis [this message]
2022-09-26 14:25 ` [regression] Bug 216426 - USB-C port is incorrectly reporting that it's powered when Dell XPS 15-9500 is unplugged Thorsten Leemhuis
2022-09-30 11:20   ` [regression] Bug 216426 - USB-C port is incorrectly reporting that it's powered when Dell XPS 15-9500 is unplugged #forregzbot Thorsten Leemhuis
2022-10-27 10:37     ` Thorsten Leemhuis

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f28e3bdf-2add-574a-cf0a-5d0253ea708a@leemhuis.info \
    --to=regressions@leemhuis.info \
    --cc=hdegoede@redhat.com \
    --cc=heikki.krogerus@linux.intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=mattia.orlandi21@gmail.com \
    --cc=regressions@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).