archive mirror
 help / color / mirror / Atom feed
From: Guenter Roeck <>
To: Marcelo Roberto Jimenez <>,
	Linus Torvalds <>
Cc: Thierry Reding <>,
	Linus Walleij <>,
	Vidya Sagar <>,
	Edmond Chung <>,
	Andrew Chant <>,
	Will McVicker <>,
	Linux Kernel Mailing List <>,
	Bartosz Golaszewski <>
Subject: Re: Linux 5.17-rc8
Date: Mon, 14 Mar 2022 18:13:18 -0700	[thread overview]
Message-ID: <> (raw)
In-Reply-To: <>

On 3/14/22 17:45, Marcelo Roberto Jimenez wrote:
> Hi Linus,
> I am the author of the "gpio: Revert regression..." patch.
> On Mon, Mar 14, 2022 at 5:14 PM Linus Torvalds
> <> wrote:
>> [ Adding more people to the cc, since this last change was triggered
>> by earlier changes.
>> On Mon, Mar 14, 2022 at 12:25 PM Guenter Roeck <> wrote:
>>> Build results:
>>>          total: 155 pass: 155 fail: 0
>>> Qemu test results:
>>>          total: 488 pass: 484 fail: 4
>> Uhhuh. We got all the previous problems sorted out, but a new one instead.
>>> This is a new problem. It bisects to commit fc328a7d1fcc ("gpio: Revert
>>> regression in sysfs-gpio (gpiolib.c)"). The network connection fails
>>> in the affected tests. Reverting the offending commit (ie reverting the
>>> revert) fixes the problem.
>> Hmm. Looking at the changes since 5.16, that commit fc328a7d1fcc looks
>> somewhat suspicious.
>> It claims to "revert" things, but the behavior it reverts goes
>> basically all the way back to v5.7 (with one of the patches going into
>> 5.10).
>> And it clearly breaks things that used to work much more recently (ie
>> this worked in rc7, but it was also the state in every release since
>> 5.10).
>> So unless somebody can find the _real_ issue here, I suspect very
>> strongly that that "fix" that came in last week was just wrong.
>> It is also very non-specific "Some GPIO lines have stopped working"
>> with no pointer to actual reports.
> The original message in which I posted the patch also had a small
> report. I listed the board in which the problem appeared and a small
> test script to show the error, which I have used to bisect the issue.
> The whole thread is here, the test is in the first message:
>> LinusW? Thierry? Bartoz? Anybody?
>> Yes, there;s something bad going on here, but we can't randomly "fix"
>> things in an rc8 that have worked for several releases by now.
> The original patch just reverted the patch that introduced the problem
> I found. But if the reversion introduces problems at this point, then
> the sane thing to do is to revert the reversion.
> At a certain point, I tried Thorsten's suggestion to add a gpio-ranges
> property in a way similar to another patch, but the kernel went into
> an EPROBE_DEFER deadlock. Thierry Reding made some comments about this
> in the sequence.
> Following Linus Walleij's suggestion, we are moving the code from the
> sysfs interface to the character device. But in the meantime, we are
> using this "revert patch" in a 5.10.80 kernel, so maybe someone could
> point me to details of the network misbehaviour so that I can also
> check it?

for logs.

There are two problem with your patch:
- The Ethernet interface on imx25's qemu emulation does not come online.
- The mmc does not come online (I just noticed this one)

Looking into the devicetree file, my guess is that the gpio
lines attached to the Ethernet PHY and the sdhci controller
don't report pin status changes. I did not try to confirm this,

Your patch may work for you on top of v5.10.y, but it doesn't
work there for imx25 either.


  reply	other threads:[~2022-03-15  1:13 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-03-13 20:43 Linux 5.17-rc8 Linus Torvalds
2022-03-14  7:55 ` Build regressions/improvements in v5.17-rc8 Geert Uytterhoeven
2022-03-14 19:25 ` Linux 5.17-rc8 Guenter Roeck
2022-03-14 20:13   ` Linus Torvalds
2022-03-15  0:45     ` Marcelo Roberto Jimenez
2022-03-15  1:13       ` Guenter Roeck [this message]
2022-03-15  1:47       ` Linus Torvalds
2022-03-15  5:42         ` Thorsten Leemhuis
2022-03-15 16:48         ` Bartosz Golaszewski
2022-03-15  9:05     ` Geert Uytterhoeven

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \ \ \ \ \ \ \ \ \ \ \ \ \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).