archive mirror
 help / color / mirror / Atom feed
From: Ahmad Fatoum <>
To: Tokunori Ikegami <>,
	Thorsten Leemhuis <>,,,,,,
	"" <>
Cc: Chris Packham <>,
	Brian Norris <>,
	David Woodhouse <>,,,
	"" <>,
	Pengutronix Kernel Team <>,
Subject: Re: [BUG] mtd: cfi_cmdset_0002: write regression since v4.17-rc1
Date: Fri, 4 Mar 2022 12:11:32 +0100	[thread overview]
Message-ID: <> (raw)
In-Reply-To: <>

Hello Tokunori-san,

On 20.02.22 13:22, Tokunori Ikegami wrote:
> Hi Ahmad-san,
> Could you please try the version 2 patch attached for the error case?
> This version is to check the DQ true data 0xFF by chip_good().

I had a similar patch locally as well at first. I just tested yours
and I can't reproduce the issue.

> But I am not sure if this works or not since the error is possible to be caused by Hi-Z 0xff on floating bus or etc.

That it works for me could be because of Hi-Z 0xff, which is why
decided against it.

>>>>> What seems to work for me is checking if chip_good or chip_ready
>>>>> and map_word is equal to 0xFF. I can't justify why this is ok though.
>>>>> (Worst case bus is floating at this point of time and Hi-Z is read
>>>>> as 0xff on CPU data lines...)
>>>> Sorry I am not sure about this.
>>>> I thought the chip_ready() itself is correct as implemented as the data sheet in the past.
>>>> But it did not work correctly so changed to use chip_good() instead as it is also correct.
>>> What exactly in the datasheet makes you believe chip_good is not appropriate?
>> I just mentioned about the actual issue behaviors as not worked chip_good() on S29GL964N and not worked chip_ready() on MX29GL512FHT2I-11G before etc.
>> Anyway let me recheck the data sheet details as just checked it again quickly but needed more investigation to understand.
> As far as I checked still both chip_good() and chip_ready() seem correct but still the root cause is unknown.
> If as you mentioned the issue was cased by the DQ true data 0xFF I am not sure why the read work without any error after the write operation.
> Also if the error was caused by the Hi-Z 0xff on floating bus as mentioned I am not sure why the read work without any error after the write operation with chip_ready().
> Sorry anyway the root cause is also unknown when the write operation was changed to use chip_good() instead of chip_ready().

I've be ok with v1 then. Restores working behavior for me and shouldn't break others.

Cheers and thanks again,

> Regards,
> Ikegami
>> Regards,
>> Ikegami
>>> Cheers,
>>> Ahmad

Pengutronix e.K.                           |                             |
Steuerwalder Str. 21                       |  |
31137 Hildesheim, Germany                  | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

  reply	other threads:[~2022-03-04 11:12 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-12-13 13:24 [BUG] mtd: cfi_cmdset_0002: write regression since v4.17-rc1 Ahmad Fatoum
2021-12-14  7:23 ` Thorsten Leemhuis
2021-12-15 17:34   ` Tokunori Ikegami
2022-01-20 13:00     ` Thorsten Leemhuis
2022-01-28 12:55     ` Ahmad Fatoum
2022-01-29 18:01       ` Tokunori Ikegami
2022-02-07 14:28         ` Ahmad Fatoum
2022-02-13 16:47           ` Tokunori Ikegami
2022-02-14 16:22             ` Ahmad Fatoum
2022-02-14 18:46               ` Tokunori Ikegami
2022-02-20 12:22                 ` Tokunori Ikegami
2022-03-04 11:11                   ` Ahmad Fatoum [this message]
2022-03-06 15:49                     ` Tokunori Ikegami
2022-03-08  9:44                       ` Ahmad Fatoum
2022-03-08 16:13                         ` Tokunori Ikegami
2022-03-08 16:23                           ` Ahmad Fatoum
2022-03-08 16:40                             ` Tokunori Ikegami

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \ \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).