linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] serial: Remove duplicated macro definition of port type
@ 2020-05-07 12:03 Tiezhu Yang
  2020-05-11  6:40 ` Jiri Slaby
  0 siblings, 1 reply; 4+ messages in thread
From: Tiezhu Yang @ 2020-05-07 12:03 UTC (permalink / raw)
  To: Greg Kroah-Hartman, Jiri Slaby; +Cc: linux-kernel, Xuefeng Li

There exists the same macro definition of port type from 0 to 13
in include/uapi/linux/serial.h, remove these duplicated code in
include/uapi/linux/serial_core.h which includes the former header.

Signed-off-by: Tiezhu Yang <yangtiezhu@loongson.cn>
---
 include/uapi/linux/serial_core.h | 14 --------------
 1 file changed, 14 deletions(-)

diff --git a/include/uapi/linux/serial_core.h b/include/uapi/linux/serial_core.h
index 8ec3dd7..851b982 100644
--- a/include/uapi/linux/serial_core.h
+++ b/include/uapi/linux/serial_core.h
@@ -26,20 +26,6 @@
 /*
  * The type definitions.  These are from Ted Ts'o's serial.h
  */
-#define PORT_UNKNOWN	0
-#define PORT_8250	1
-#define PORT_16450	2
-#define PORT_16550	3
-#define PORT_16550A	4
-#define PORT_CIRRUS	5
-#define PORT_16650	6
-#define PORT_16650V2	7
-#define PORT_16750	8
-#define PORT_STARTECH	9
-#define PORT_16C950	10
-#define PORT_16654	11
-#define PORT_16850	12
-#define PORT_RSA	13
 #define PORT_NS16550A	14
 #define PORT_XSCALE	15
 #define PORT_RM9000	16	/* PMC-Sierra RM9xxx internal UART */
-- 
2.1.0


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] serial: Remove duplicated macro definition of port type
  2020-05-07 12:03 [PATCH] serial: Remove duplicated macro definition of port type Tiezhu Yang
@ 2020-05-11  6:40 ` Jiri Slaby
  2020-07-06  9:01   ` Tiezhu Yang
  0 siblings, 1 reply; 4+ messages in thread
From: Jiri Slaby @ 2020-05-11  6:40 UTC (permalink / raw)
  To: Tiezhu Yang, Greg Kroah-Hartman; +Cc: linux-kernel, Xuefeng Li

On 07. 05. 20, 14:03, Tiezhu Yang wrote:
> There exists the same macro definition of port type from 0 to 13
> in include/uapi/linux/serial.h, remove these duplicated code in
> include/uapi/linux/serial_core.h which includes the former header.
> 
> Signed-off-by: Tiezhu Yang <yangtiezhu@loongson.cn>

Acked-by: Jiri Slaby <jslaby@suse.cz>

> ---
>  include/uapi/linux/serial_core.h | 14 --------------
>  1 file changed, 14 deletions(-)
> 
> diff --git a/include/uapi/linux/serial_core.h b/include/uapi/linux/serial_core.h
> index 8ec3dd7..851b982 100644
> --- a/include/uapi/linux/serial_core.h
> +++ b/include/uapi/linux/serial_core.h
> @@ -26,20 +26,6 @@
>  /*
>   * The type definitions.  These are from Ted Ts'o's serial.h
>   */
> -#define PORT_UNKNOWN	0
> -#define PORT_8250	1
> -#define PORT_16450	2
> -#define PORT_16550	3
> -#define PORT_16550A	4
> -#define PORT_CIRRUS	5
> -#define PORT_16650	6
> -#define PORT_16650V2	7
> -#define PORT_16750	8
> -#define PORT_STARTECH	9
> -#define PORT_16C950	10
> -#define PORT_16654	11
> -#define PORT_16850	12
> -#define PORT_RSA	13
>  #define PORT_NS16550A	14
>  #define PORT_XSCALE	15
>  #define PORT_RM9000	16	/* PMC-Sierra RM9xxx internal UART */
> 

thanks,
-- 
js
suse labs

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] serial: Remove duplicated macro definition of port type
  2020-05-11  6:40 ` Jiri Slaby
@ 2020-07-06  9:01   ` Tiezhu Yang
  2020-07-06 12:03     ` Greg Kroah-Hartman
  0 siblings, 1 reply; 4+ messages in thread
From: Tiezhu Yang @ 2020-07-06  9:01 UTC (permalink / raw)
  To: Jiri Slaby, Greg Kroah-Hartman; +Cc: linux-kernel, Xuefeng Li

On 05/11/2020 02:40 PM, Jiri Slaby wrote:
> On 07. 05. 20, 14:03, Tiezhu Yang wrote:
>> There exists the same macro definition of port type from 0 to 13
>> in include/uapi/linux/serial.h, remove these duplicated code in
>> include/uapi/linux/serial_core.h which includes the former header.
>>
>> Signed-off-by: Tiezhu Yang <yangtiezhu@loongson.cn>
> Acked-by: Jiri Slaby <jslaby@suse.cz>

Hi,

Could you please apply this patch?

Thanks,
Tiezhu

>
>> ---
>>   include/uapi/linux/serial_core.h | 14 --------------
>>   1 file changed, 14 deletions(-)
>>
>> diff --git a/include/uapi/linux/serial_core.h b/include/uapi/linux/serial_core.h
>> index 8ec3dd7..851b982 100644
>> --- a/include/uapi/linux/serial_core.h
>> +++ b/include/uapi/linux/serial_core.h
>> @@ -26,20 +26,6 @@
>>   /*
>>    * The type definitions.  These are from Ted Ts'o's serial.h
>>    */
>> -#define PORT_UNKNOWN	0
>> -#define PORT_8250	1
>> -#define PORT_16450	2
>> -#define PORT_16550	3
>> -#define PORT_16550A	4
>> -#define PORT_CIRRUS	5
>> -#define PORT_16650	6
>> -#define PORT_16650V2	7
>> -#define PORT_16750	8
>> -#define PORT_STARTECH	9
>> -#define PORT_16C950	10
>> -#define PORT_16654	11
>> -#define PORT_16850	12
>> -#define PORT_RSA	13
>>   #define PORT_NS16550A	14
>>   #define PORT_XSCALE	15
>>   #define PORT_RM9000	16	/* PMC-Sierra RM9xxx internal UART */
>>
> thanks,


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] serial: Remove duplicated macro definition of port type
  2020-07-06  9:01   ` Tiezhu Yang
@ 2020-07-06 12:03     ` Greg Kroah-Hartman
  0 siblings, 0 replies; 4+ messages in thread
From: Greg Kroah-Hartman @ 2020-07-06 12:03 UTC (permalink / raw)
  To: Tiezhu Yang; +Cc: Jiri Slaby, linux-kernel, Xuefeng Li

On Mon, Jul 06, 2020 at 05:01:12PM +0800, Tiezhu Yang wrote:
> On 05/11/2020 02:40 PM, Jiri Slaby wrote:
> > On 07. 05. 20, 14:03, Tiezhu Yang wrote:
> > > There exists the same macro definition of port type from 0 to 13
> > > in include/uapi/linux/serial.h, remove these duplicated code in
> > > include/uapi/linux/serial_core.h which includes the former header.
> > > 
> > > Signed-off-by: Tiezhu Yang <yangtiezhu@loongson.cn>
> > Acked-by: Jiri Slaby <jslaby@suse.cz>
> 
> Hi,
> 
> Could you please apply this patch?

Odd, I can't find this anywhere in my archives, sorry about that, will
grab it from lore.kernel.org.

greg k-h


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2020-07-06 12:03 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-07 12:03 [PATCH] serial: Remove duplicated macro definition of port type Tiezhu Yang
2020-05-11  6:40 ` Jiri Slaby
2020-07-06  9:01   ` Tiezhu Yang
2020-07-06 12:03     ` Greg Kroah-Hartman

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).