linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "An, Tedd" <tedd.an@intel.com>
To: "kai.heng.feng@canonical.com" <kai.heng.feng@canonical.com>,
	"andypalmadi@gmail.com" <andypalmadi@gmail.com>,
	"marcel@holtmann.org" <marcel@holtmann.org>,
	"linux-bluetooth@vger.kernel.org"
	<linux-bluetooth@vger.kernel.org>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"regressions@lists.linux.dev" <regressions@lists.linux.dev>
Subject: Re: [REGRESSION] Bluetooth not working on 5.15+ since "Bluetooth: Move shutdown callback before flushing tx and rx queue"
Date: Fri, 10 Dec 2021 01:10:38 +0000	[thread overview]
Message-ID: <fbc36e8ebdd9222f84322d54d9114f58c225547e.camel@intel.com> (raw)
In-Reply-To: <CAJvGw+AJ5dHSb50RtJHnjbhMVQa+rJgYznFV4t-iaO0qx+W-jw@mail.gmail.com>

Hi,

On Fri, 2021-12-10 at 01:36 +0200, coldolt wrote:
> After a restart, bluetooth doesn't work since commit 0ea53674d07f
> "Bluetooth: Move shutdown callback before flushing tx and rx queue"
> 
> bluetoothctl doesn't list any controllers and I get the following in
> dmesg | grep -i bluetooth
> 
> [    2.634812] Bluetooth: Core ver 2.22
> [    2.634843] NET: Registered PF_BLUETOOTH protocol family
> [    2.634845] Bluetooth: HCI device and connection manager initialized
> [    2.634850] Bluetooth: HCI socket layer initialized
> [    2.634853] Bluetooth: L2CAP socket layer initialized
> [    2.634858] Bluetooth: SCO socket layer initialized
> [    4.077788] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
> [    4.077794] Bluetooth: BNEP filters: protocol multicast
> [    4.077799] Bluetooth: BNEP socket layer initialized
> [    4.078219] random: bluetoothd: uninitialized urandom read (4 bytes read)
> [    4.852835] Bluetooth: hci0: Reading Intel version command failed (-110)
> [    4.852838] Bluetooth: hci0: command 0xfc05 tx timeout
> 
> However, it works after a cold start or after putting the computer to sleep.
> 
> Before 83f2dafe2a62 "Bluetooth: btintel: Refactoring setup routine for
> legacy ROM sku", it always works after a restart, but from that commit
> up until before 0ea53674d07f it either works or doesn't work after a
> restart depending on if before restart it was working or not, meaning
> it stays working or stays not working.
> 
> Also on the first restart from before 83f2dafe2a62 into 0ea53674d07f
> or later it works, but then restarting again into 0ea53674d07f or
> later it no longer works. So it seems that 0ea53674d07f and later puts
> the bluetooth in a nonworking state if you restart from it, but before
> 83f2dafe2a62 it puts it back into a working state at startup, and in
> between it doesn't do either, i.e. it stays the way it was.
> 
> I have a Dell Latitude E5550 laptop with an Intel 7265 wifi/bluetooth
> card REV=0x210 firmware version 29.4063824552.0 7265D-29. I'm on Arch
> Linux, the problem is still there on 5.16-rc4.
> 
> Here is a thread on the Arch Linux forums with several people with the
> same problem, for some of them it got fixed with a kernel update or by
> reloading modules, but not for everybody, including me
> https://bbs.archlinux.org/viewtopic.php?id=271459
> 
> #regzbot introduced 0ea53674d07f

This issue is under investigation to find the root cause and proper solution.
The downloaded firmware breaks the behavior though, we need to investigate
further to see if it can be fixed in firmware or fix in the driver.

Regards,
Tedd


  reply	other threads:[~2021-12-10  1:10 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-12-09 23:36 coldolt
2021-12-10  1:10 ` An, Tedd [this message]
2021-12-10  9:16   ` Thorsten Leemhuis
2022-01-20 13:08     ` Thorsten Leemhuis
2022-01-23  9:28       ` Thorsten Leemhuis
2022-01-23 20:11         ` coldolt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=fbc36e8ebdd9222f84322d54d9114f58c225547e.camel@intel.com \
    --to=tedd.an@intel.com \
    --cc=andypalmadi@gmail.com \
    --cc=kai.heng.feng@canonical.com \
    --cc=linux-bluetooth@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marcel@holtmann.org \
    --cc=regressions@lists.linux.dev \
    --subject='Re: [REGRESSION] Bluetooth not working on 5.15+ since "Bluetooth: Move shutdown callback before flushing tx and rx queue"' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).