linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Palmer Dabbelt <palmer@sifive.com>
To: mark.rutland@arm.com
Cc: linux-kernel@vger.kernel.org, mark.rutland@arm.com,
	boqun.feng@gmail.com, Will Deacon <will.deacon@arm.com>
Subject: Re: [PATCHv2 01/16] atomics/treewide: s/__atomic_add_unless/atomic_fetch_add_unless/
Date: Mon, 04 Jun 2018 16:24:44 -0700 (PDT)	[thread overview]
Message-ID: <mhng-5a3b251f-49f3-4e9e-8aa3-d9286c9cc8e5@palmer-si-x1c4> (raw)
In-Reply-To: <20180529154346.3168-2-mark.rutland@arm.com>

On Tue, 29 May 2018 08:43:31 PDT (-0700), mark.rutland@arm.com wrote:
> While __atomic_add_unless was originally intended as a building-block
> for atomic_add_unless, it's now used in a number of places around the
> kernel. It's the only common atomic operation named __atomic*(), rather
> than atomic_*(), and for consistency it would be better named
> atomic_fetch_add_unless().
>
> This lack of consistency is slightly confusing, and gets in the way of
> scripting atomics. Given that, let's clean things up and promote it to
> an offical part of the atomics API, in the form of
> atomic_fetch_add_unless().
>
> This patch converts definitions and uses over to the new name, including
> the instrumented version, using the following script:
>
> ----
> git grep -w __atomic_add_unless | while read line; do
> sed -i '{s/\<__atomic_add_unless\>/atomic_fetch_add_unless/}' "${line%%:*}";
> done
> git grep -w __arch_atomic_add_unless | while read line; do
> sed -i '{s/\<__arch_atomic_add_unless\>/arch_atomic_fetch_add_unless/}' "${line%%:*}";
> done
> ----
>
> Note that we do not have atomic{64,_long}_fetch_add_unless(), which will
> be introduced by later patches.
>
> There should be no functional change as a result of this patch.
>
> Signed-off-by: Mark Rutland <mark.rutland@arm.com>
> Acked-by: Geert Uytterhoeven <geert@linux-m68k.org>
> Acked-by: Peter Zijlstra (Intel) <peterz@infradead.org>
> Cc: Boqun Feng <boqun.feng@gmail.com>
> Cc: Will Deacon <will.deacon@arm.com>
> ---
>  arch/alpha/include/asm/atomic.h           | 4 ++--
>  arch/arc/include/asm/atomic.h             | 4 ++--
>  arch/arm/include/asm/atomic.h             | 4 ++--
>  arch/arm64/include/asm/atomic.h           | 2 +-
>  arch/h8300/include/asm/atomic.h           | 2 +-
>  arch/hexagon/include/asm/atomic.h         | 4 ++--
>  arch/ia64/include/asm/atomic.h            | 2 +-
>  arch/m68k/include/asm/atomic.h            | 2 +-
>  arch/mips/include/asm/atomic.h            | 4 ++--
>  arch/openrisc/include/asm/atomic.h        | 4 ++--
>  arch/parisc/include/asm/atomic.h          | 4 ++--
>  arch/powerpc/include/asm/atomic.h         | 8 ++++----
>  arch/riscv/include/asm/atomic.h           | 4 ++--
>  arch/s390/include/asm/atomic.h            | 2 +-
>  arch/sh/include/asm/atomic.h              | 4 ++--
>  arch/sparc/include/asm/atomic_32.h        | 2 +-
>  arch/sparc/include/asm/atomic_64.h        | 2 +-
>  arch/sparc/lib/atomic32.c                 | 4 ++--
>  arch/x86/include/asm/atomic.h             | 4 ++--
>  arch/xtensa/include/asm/atomic.h          | 4 ++--
>  drivers/block/rbd.c                       | 2 +-
>  drivers/infiniband/core/rdma_core.c       | 2 +-
>  fs/afs/rxrpc.c                            | 2 +-
>  include/asm-generic/atomic-instrumented.h | 4 ++--
>  include/asm-generic/atomic.h              | 4 ++--
>  include/linux/atomic.h                    | 2 +-
>  kernel/bpf/syscall.c                      | 4 ++--
>  net/rxrpc/call_object.c                   | 2 +-
>  net/rxrpc/conn_object.c                   | 4 ++--
>  net/rxrpc/local_object.c                  | 2 +-
>  net/rxrpc/peer_object.c                   | 2 +-
>  31 files changed, 50 insertions(+), 50 deletions(-)
> [...]
> diff --git a/arch/riscv/include/asm/atomic.h b/arch/riscv/include/asm/atomic.h
> index 855115ace98c..739e810c857e 100644
> --- a/arch/riscv/include/asm/atomic.h
> +++ b/arch/riscv/include/asm/atomic.h
> @@ -332,7 +332,7 @@ ATOMIC_OP(dec_and_test, dec, ==, 0, 64)
>  #undef ATOMIC_OP
>
>  /* This is required to provide a full barrier on success. */
> -static __always_inline int __atomic_add_unless(atomic_t *v, int a, int u)
> +static __always_inline int atomic_fetch_add_unless(atomic_t *v, int a, int u)
>  {
>         int prev, rc;
>
> @@ -381,7 +381,7 @@ static __always_inline int atomic64_add_unless(atomic64_t *v, long a, long u)
>   */
>  static __always_inline int atomic_inc_not_zero(atomic_t *v)
>  {
> -        return __atomic_add_unless(v, 1, 0);
> +        return atomic_fetch_add_unless(v, 1, 0);
>  }
>
>  #ifndef CONFIG_GENERIC_ATOMIC64
> diff --git a/arch/s390/include/asm/atomic.h b/arch/s390/include/asm/atomic.h
> index 4b55532f15c4..c2858cdd8c29 100644
> --- a/arch/s390/include/asm/atomic.h
> +++ b/arch/s390/include/asm/atomic.h
> @@ -90,7 +90,7 @@ static inline int atomic_cmpxchg(atomic_t *v, int old, int new)
>  	return __atomic_cmpxchg(&v->counter, old, new);
>  }
>
> -static inline int __atomic_add_unless(atomic_t *v, int a, int u)
> +static inline int atomic_fetch_add_unless(atomic_t *v, int a, int u)
>  {
>  	int c, old;
>  	c = atomic_read(v);

Acked-by: Palmer Dabbelt <palmer@sifive.com>

Thanks!

  reply	other threads:[~2018-06-04 23:24 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-05-29 15:43 [PATCHv2 00/16] atomics: API cleanups Mark Rutland
2018-05-29 15:43 ` [PATCHv2 01/16] atomics/treewide: s/__atomic_add_unless/atomic_fetch_add_unless/ Mark Rutland
2018-06-04 23:24   ` Palmer Dabbelt [this message]
2018-05-29 15:43 ` [PATCHv2 02/16] atomics/treewide: remove redundant atomic_inc_not_zero() definitions Mark Rutland
2018-06-04 23:24   ` Palmer Dabbelt
2018-05-29 15:43 ` [PATCHv2 03/16] atomics/treewide: make atomic64_inc_not_zero() optional Mark Rutland
2018-06-04 23:17   ` Palmer Dabbelt
2018-06-05  5:34     ` Mark Rutland
2018-05-29 15:43 ` [PATCHv2 04/16] atomics/treewide: make atomic_fetch_add_unless() optional Mark Rutland
2018-06-04 23:24   ` Palmer Dabbelt
2018-05-29 15:43 ` [PATCHv2 05/16] atomics: prepare for atomic64_fetch_add_unless() Mark Rutland
2018-06-05  9:26   ` Peter Zijlstra
2018-06-05  9:53     ` Mark Rutland
2018-06-05 10:54       ` Michael Ellerman
2018-06-05 11:08         ` Mark Rutland
2018-06-06  8:57           ` Michael Ellerman
2018-05-29 15:43 ` [PATCHv2 06/16] atomics/generic: define atomic64_fetch_add_unless() Mark Rutland
2018-05-29 15:43 ` [PATCHv2 07/16] atomics/alpha: " Mark Rutland
2018-05-29 15:43 ` [PATCHv2 08/16] atomics/arc: " Mark Rutland
2018-05-29 15:43 ` [PATCHv2 09/16] atomics/arm: " Mark Rutland
2018-05-29 15:43 ` [PATCHv2 10/16] atomics/powerpc: " Mark Rutland
2018-05-29 15:43 ` [PATCHv2 11/16] atomics/riscv: " Mark Rutland
2018-06-04 23:17   ` Palmer Dabbelt
2018-05-29 15:43 ` [PATCHv2 12/16] atomics/treewide: make atomic64_fetch_add_unless() optional Mark Rutland
2018-05-29 15:43 ` [PATCHv2 13/16] atomics/treewide: make test ops optional Mark Rutland
2018-06-04 23:17   ` Palmer Dabbelt
2018-05-29 15:43 ` [PATCHv2 14/16] atomics/treewide: remove atomic_inc_not_zero_hint() Mark Rutland
2018-05-29 15:43 ` [PATCHv2 15/16] atomics/treewide: make unconditional inc/dec ops optional Mark Rutland
2018-06-04 23:17   ` Palmer Dabbelt
2018-05-29 15:43 ` [PATCHv2 16/16] atomics/treewide: make conditional " Mark Rutland
2018-05-30 11:23 ` [PATCHv2 00/16] atomics: API cleanups Mark Rutland
2018-05-30 13:34   ` Mark Rutland
2018-06-05  9:43 ` Peter Zijlstra

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=mhng-5a3b251f-49f3-4e9e-8aa3-d9286c9cc8e5@palmer-si-x1c4 \
    --to=palmer@sifive.com \
    --cc=boqun.feng@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).