linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv
@ 2018-12-10 16:52 Daniel Lezcano
  2018-12-10 16:52 ` [PATCH 2/5] clocksource/drivers/rockchip: Change name rockchip_timer to timer-rockchip Daniel Lezcano
                   ` (4 more replies)
  0 siblings, 5 replies; 6+ messages in thread
From: Daniel Lezcano @ 2018-12-10 16:52 UTC (permalink / raw)
  To: tglx, daniel.lezcano
  Cc: Palmer Dabbelt, Albert Ou, open list:CLOCKSOURCE,
	CLOCKEVENT DRIVERS, open list:RISC-V ARCHITECTURE

In order to unify the names in this directory, let's rename the driver to be
prefixed with timer-*

Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
---
 drivers/clocksource/Makefile                         | 2 +-
 drivers/clocksource/{riscv_timer.c => timer-riscv.c} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/clocksource/{riscv_timer.c => timer-riscv.c} (100%)

diff --git a/drivers/clocksource/Makefile b/drivers/clocksource/Makefile
index dd9138104568..ddf697b29df9 100644
--- a/drivers/clocksource/Makefile
+++ b/drivers/clocksource/Makefile
@@ -78,6 +78,6 @@ obj-$(CONFIG_H8300_TPU)			+= h8300_tpu.o
 obj-$(CONFIG_CLKSRC_ST_LPC)		+= clksrc_st_lpc.o
 obj-$(CONFIG_X86_NUMACHIP)		+= numachip.o
 obj-$(CONFIG_ATCPIT100_TIMER)		+= timer-atcpit100.o
-obj-$(CONFIG_RISCV_TIMER)		+= riscv_timer.o
+obj-$(CONFIG_RISCV_TIMER)		+= timer-riscv.o
 obj-$(CONFIG_CSKY_MP_TIMER)		+= timer-mp-csky.o
 obj-$(CONFIG_GX6605S_TIMER)		+= timer-gx6605s.o
diff --git a/drivers/clocksource/riscv_timer.c b/drivers/clocksource/timer-riscv.c
similarity index 100%
rename from drivers/clocksource/riscv_timer.c
rename to drivers/clocksource/timer-riscv.c
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH 2/5] clocksource/drivers/rockchip: Change name rockchip_timer to timer-rockchip
  2018-12-10 16:52 [PATCH 1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv Daniel Lezcano
@ 2018-12-10 16:52 ` Daniel Lezcano
  2018-12-10 16:52 ` [PATCH 3/5] clocksource/drivers/tegra20: Change name tegra20_timer to timer-tegra20 Daniel Lezcano
                   ` (3 subsequent siblings)
  4 siblings, 0 replies; 6+ messages in thread
From: Daniel Lezcano @ 2018-12-10 16:52 UTC (permalink / raw)
  To: tglx, daniel.lezcano; +Cc: open list:CLOCKSOURCE, CLOCKEVENT DRIVERS

In order to unify the names in this directory, let's rename the driver to be
prefixed with timer-*

Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
---
 drivers/clocksource/Makefile                               | 2 +-
 drivers/clocksource/{rockchip_timer.c => timer-rockchip.c} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/clocksource/{rockchip_timer.c => timer-rockchip.c} (100%)

diff --git a/drivers/clocksource/Makefile b/drivers/clocksource/Makefile
index ddf697b29df9..9d0c0fa0d69b 100644
--- a/drivers/clocksource/Makefile
+++ b/drivers/clocksource/Makefile
@@ -20,7 +20,7 @@ obj-$(CONFIG_OMAP_DM_TIMER)	+= timer-ti-dm.o
 obj-$(CONFIG_DW_APB_TIMER)	+= dw_apb_timer.o
 obj-$(CONFIG_DW_APB_TIMER_OF)	+= dw_apb_timer_of.o
 obj-$(CONFIG_FTTMR010_TIMER)	+= timer-fttmr010.o
-obj-$(CONFIG_ROCKCHIP_TIMER)      += rockchip_timer.o
+obj-$(CONFIG_ROCKCHIP_TIMER)      += timer-rockchip.o
 obj-$(CONFIG_CLKSRC_NOMADIK_MTU)	+= nomadik-mtu.o
 obj-$(CONFIG_CLKSRC_DBX500_PRCMU)	+= clksrc-dbx500-prcmu.o
 obj-$(CONFIG_ARMADA_370_XP_TIMER)	+= timer-armada-370-xp.o
diff --git a/drivers/clocksource/rockchip_timer.c b/drivers/clocksource/timer-rockchip.c
similarity index 100%
rename from drivers/clocksource/rockchip_timer.c
rename to drivers/clocksource/timer-rockchip.c
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH 3/5] clocksource/drivers/tegra20: Change name tegra20_timer to timer-tegra20
  2018-12-10 16:52 [PATCH 1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv Daniel Lezcano
  2018-12-10 16:52 ` [PATCH 2/5] clocksource/drivers/rockchip: Change name rockchip_timer to timer-rockchip Daniel Lezcano
@ 2018-12-10 16:52 ` Daniel Lezcano
  2018-12-10 16:52 ` [PATCH 4/5] clocksource/drivers/sun4i: Change name sun4i_timer to timer-sun4i Daniel Lezcano
                   ` (2 subsequent siblings)
  4 siblings, 0 replies; 6+ messages in thread
From: Daniel Lezcano @ 2018-12-10 16:52 UTC (permalink / raw)
  To: tglx, daniel.lezcano; +Cc: open list:CLOCKSOURCE, CLOCKEVENT DRIVERS

In order to unify the names in this directory, let's rename the driver to be
prefixed with timer-*

Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
---
 drivers/clocksource/Makefile                             | 2 +-
 drivers/clocksource/{tegra20_timer.c => timer-tegra20.c} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/clocksource/{tegra20_timer.c => timer-tegra20.c} (100%)

diff --git a/drivers/clocksource/Makefile b/drivers/clocksource/Makefile
index 9d0c0fa0d69b..e02c1af0c716 100644
--- a/drivers/clocksource/Makefile
+++ b/drivers/clocksource/Makefile
@@ -35,7 +35,7 @@ obj-$(CONFIG_U300_TIMER)	+= timer-u300.o
 obj-$(CONFIG_SUN4I_TIMER)	+= sun4i_timer.o
 obj-$(CONFIG_SUN5I_HSTIMER)	+= timer-sun5i.o
 obj-$(CONFIG_MESON6_TIMER)	+= meson6_timer.o
-obj-$(CONFIG_TEGRA_TIMER)	+= tegra20_timer.o
+obj-$(CONFIG_TEGRA_TIMER)	+= timer-tegra20.o
 obj-$(CONFIG_VT8500_TIMER)	+= timer-vt8500.o
 obj-$(CONFIG_NSPIRE_TIMER)	+= timer-zevio.o
 obj-$(CONFIG_BCM_KONA_TIMER)	+= bcm_kona_timer.o
diff --git a/drivers/clocksource/tegra20_timer.c b/drivers/clocksource/timer-tegra20.c
similarity index 100%
rename from drivers/clocksource/tegra20_timer.c
rename to drivers/clocksource/timer-tegra20.c
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH 4/5] clocksource/drivers/sun4i: Change name sun4i_timer to timer-sun4i
  2018-12-10 16:52 [PATCH 1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv Daniel Lezcano
  2018-12-10 16:52 ` [PATCH 2/5] clocksource/drivers/rockchip: Change name rockchip_timer to timer-rockchip Daniel Lezcano
  2018-12-10 16:52 ` [PATCH 3/5] clocksource/drivers/tegra20: Change name tegra20_timer to timer-tegra20 Daniel Lezcano
@ 2018-12-10 16:52 ` Daniel Lezcano
  2018-12-10 16:52 ` [PATCH 5/5] clocksource/drivers/meson6: Change name meson6_timer timer-meson6 Daniel Lezcano
  2018-12-10 17:45 ` [PATCH 1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv Palmer Dabbelt
  4 siblings, 0 replies; 6+ messages in thread
From: Daniel Lezcano @ 2018-12-10 16:52 UTC (permalink / raw)
  To: tglx, daniel.lezcano; +Cc: open list:CLOCKSOURCE, CLOCKEVENT DRIVERS

In order to unify the names in this directory, let's rename the driver to be
prefixed with timer-*

Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
---
 drivers/clocksource/Makefile                         | 2 +-
 drivers/clocksource/{sun4i_timer.c => timer-sun4i.c} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/clocksource/{sun4i_timer.c => timer-sun4i.c} (100%)

diff --git a/drivers/clocksource/Makefile b/drivers/clocksource/Makefile
index e02c1af0c716..37732cb5710c 100644
--- a/drivers/clocksource/Makefile
+++ b/drivers/clocksource/Makefile
@@ -32,7 +32,7 @@ obj-$(CONFIG_MXS_TIMER)		+= mxs_timer.o
 obj-$(CONFIG_CLKSRC_PXA)	+= pxa_timer.o
 obj-$(CONFIG_PRIMA2_TIMER)	+= timer-prima2.o
 obj-$(CONFIG_U300_TIMER)	+= timer-u300.o
-obj-$(CONFIG_SUN4I_TIMER)	+= sun4i_timer.o
+obj-$(CONFIG_SUN4I_TIMER)	+= timer-sun4i.o
 obj-$(CONFIG_SUN5I_HSTIMER)	+= timer-sun5i.o
 obj-$(CONFIG_MESON6_TIMER)	+= meson6_timer.o
 obj-$(CONFIG_TEGRA_TIMER)	+= timer-tegra20.o
diff --git a/drivers/clocksource/sun4i_timer.c b/drivers/clocksource/timer-sun4i.c
similarity index 100%
rename from drivers/clocksource/sun4i_timer.c
rename to drivers/clocksource/timer-sun4i.c
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH 5/5] clocksource/drivers/meson6: Change name meson6_timer timer-meson6
  2018-12-10 16:52 [PATCH 1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv Daniel Lezcano
                   ` (2 preceding siblings ...)
  2018-12-10 16:52 ` [PATCH 4/5] clocksource/drivers/sun4i: Change name sun4i_timer to timer-sun4i Daniel Lezcano
@ 2018-12-10 16:52 ` Daniel Lezcano
  2018-12-10 17:45 ` [PATCH 1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv Palmer Dabbelt
  4 siblings, 0 replies; 6+ messages in thread
From: Daniel Lezcano @ 2018-12-10 16:52 UTC (permalink / raw)
  To: tglx, daniel.lezcano; +Cc: open list:CLOCKSOURCE, CLOCKEVENT DRIVERS

In order to unify the names in this directory, let's rename the driver to be
prefixed with timer-*

Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
---
 drivers/clocksource/Makefile                           | 2 +-
 drivers/clocksource/{meson6_timer.c => timer-meson6.c} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/clocksource/{meson6_timer.c => timer-meson6.c} (100%)

diff --git a/drivers/clocksource/Makefile b/drivers/clocksource/Makefile
index 37732cb5710c..f475927d5140 100644
--- a/drivers/clocksource/Makefile
+++ b/drivers/clocksource/Makefile
@@ -34,7 +34,7 @@ obj-$(CONFIG_PRIMA2_TIMER)	+= timer-prima2.o
 obj-$(CONFIG_U300_TIMER)	+= timer-u300.o
 obj-$(CONFIG_SUN4I_TIMER)	+= timer-sun4i.o
 obj-$(CONFIG_SUN5I_HSTIMER)	+= timer-sun5i.o
-obj-$(CONFIG_MESON6_TIMER)	+= meson6_timer.o
+obj-$(CONFIG_MESON6_TIMER)	+= timer-meson6.o
 obj-$(CONFIG_TEGRA_TIMER)	+= timer-tegra20.o
 obj-$(CONFIG_VT8500_TIMER)	+= timer-vt8500.o
 obj-$(CONFIG_NSPIRE_TIMER)	+= timer-zevio.o
diff --git a/drivers/clocksource/meson6_timer.c b/drivers/clocksource/timer-meson6.c
similarity index 100%
rename from drivers/clocksource/meson6_timer.c
rename to drivers/clocksource/timer-meson6.c
-- 
2.17.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH 1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv
  2018-12-10 16:52 [PATCH 1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv Daniel Lezcano
                   ` (3 preceding siblings ...)
  2018-12-10 16:52 ` [PATCH 5/5] clocksource/drivers/meson6: Change name meson6_timer timer-meson6 Daniel Lezcano
@ 2018-12-10 17:45 ` Palmer Dabbelt
  4 siblings, 0 replies; 6+ messages in thread
From: Palmer Dabbelt @ 2018-12-10 17:45 UTC (permalink / raw)
  To: daniel.lezcano; +Cc: tglx, daniel.lezcano, aou, linux-kernel, linux-riscv

On Mon, 10 Dec 2018 08:52:38 PST (-0800), daniel.lezcano@linaro.org wrote:
> In order to unify the names in this directory, let's rename the driver to be
> prefixed with timer-*
>
> Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
> ---
>  drivers/clocksource/Makefile                         | 2 +-
>  drivers/clocksource/{riscv_timer.c => timer-riscv.c} | 0
>  2 files changed, 1 insertion(+), 1 deletion(-)
>  rename drivers/clocksource/{riscv_timer.c => timer-riscv.c} (100%)
>
> diff --git a/drivers/clocksource/Makefile b/drivers/clocksource/Makefile
> index dd9138104568..ddf697b29df9 100644
> --- a/drivers/clocksource/Makefile
> +++ b/drivers/clocksource/Makefile
> @@ -78,6 +78,6 @@ obj-$(CONFIG_H8300_TPU)			+= h8300_tpu.o
>  obj-$(CONFIG_CLKSRC_ST_LPC)		+= clksrc_st_lpc.o
>  obj-$(CONFIG_X86_NUMACHIP)		+= numachip.o
>  obj-$(CONFIG_ATCPIT100_TIMER)		+= timer-atcpit100.o
> -obj-$(CONFIG_RISCV_TIMER)		+= riscv_timer.o
> +obj-$(CONFIG_RISCV_TIMER)		+= timer-riscv.o
>  obj-$(CONFIG_CSKY_MP_TIMER)		+= timer-mp-csky.o
>  obj-$(CONFIG_GX6605S_TIMER)		+= timer-gx6605s.o
> diff --git a/drivers/clocksource/riscv_timer.c b/drivers/clocksource/timer-riscv.c
> similarity index 100%
> rename from drivers/clocksource/riscv_timer.c
> rename to drivers/clocksource/timer-riscv.c

Reviewed-by: Palmer Dabbelt <palmer@sifive.com>

Thanks!

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2018-12-10 17:45 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-12-10 16:52 [PATCH 1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv Daniel Lezcano
2018-12-10 16:52 ` [PATCH 2/5] clocksource/drivers/rockchip: Change name rockchip_timer to timer-rockchip Daniel Lezcano
2018-12-10 16:52 ` [PATCH 3/5] clocksource/drivers/tegra20: Change name tegra20_timer to timer-tegra20 Daniel Lezcano
2018-12-10 16:52 ` [PATCH 4/5] clocksource/drivers/sun4i: Change name sun4i_timer to timer-sun4i Daniel Lezcano
2018-12-10 16:52 ` [PATCH 5/5] clocksource/drivers/meson6: Change name meson6_timer timer-meson6 Daniel Lezcano
2018-12-10 17:45 ` [PATCH 1/5] clocksource/drivers/riscv: Change name riscv_timer to timer-riscv Palmer Dabbelt

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).