From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-8.8 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_PATCH,MAILING_LIST_MULTI,SPF_HELO_NONE, SPF_PASS autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 7BE79C43332 for ; Tue, 2 Mar 2021 09:49:55 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 4B47E64E56 for ; Tue, 2 Mar 2021 09:49:55 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1379078AbhCBJjT (ORCPT ); Tue, 2 Mar 2021 04:39:19 -0500 Received: from mx2.suse.de ([195.135.220.15]:43466 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1837924AbhCBJMd (ORCPT ); Tue, 2 Mar 2021 04:12:33 -0500 X-Virus-Scanned: by amavisd-new at test-mx.suse.de Received: from relay2.suse.de (unknown [195.135.221.27]) by mx2.suse.de (Postfix) with ESMTP id 521C1ABF4; Tue, 2 Mar 2021 09:11:52 +0000 (UTC) Date: Tue, 02 Mar 2021 10:11:52 +0100 Message-ID: From: Takashi Iwai To: Anton Yakovlev Cc: , , , "Michael S. Tsirkin" , Jaroslav Kysela , Takashi Iwai , Subject: Re: [PATCH v6 9/9] ALSA: virtio: introduce device suspend/resume support In-Reply-To: References: <20210227085956.1700687-1-anton.yakovlev@opensynergy.com> <20210227085956.1700687-10-anton.yakovlev@opensynergy.com> <7d4daea0-ed59-e84c-c28a-945c49204c83@opensynergy.com> User-Agent: Wanderlust/2.15.9 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (=?UTF-8?B?R29qxY0=?=) APEL/10.8 Emacs/25.3 (x86_64-suse-linux-gnu) MULE/6.0 (HANACHIRUSATO) MIME-Version: 1.0 (generated by SEMI 1.14.6 - "Maruoka") Content-Type: text/plain; charset=US-ASCII Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, 02 Mar 2021 09:09:33 +0100, Anton Yakovlev wrote: > > On 02.03.2021 07:48, Takashi Iwai wrote: > > On Tue, 02 Mar 2021 07:29:20 +0100, > > Anton Yakovlev wrote: > >> > >> On 28.02.2021 13:05, Takashi Iwai wrote: > >>> On Sat, 27 Feb 2021 09:59:56 +0100, > >>> Anton Yakovlev wrote: > >>>> > >> > >> [snip] > >> > >>>> --- a/sound/virtio/virtio_pcm.c > >>>> +++ b/sound/virtio/virtio_pcm.c > >>>> @@ -109,6 +109,7 @@ static int virtsnd_pcm_build_hw(struct virtio_pcm_substream *vss, > >>>> SNDRV_PCM_INFO_BATCH | > >>>> SNDRV_PCM_INFO_BLOCK_TRANSFER | > >>>> SNDRV_PCM_INFO_INTERLEAVED | > >>>> + SNDRV_PCM_INFO_RESUME | > >>>> SNDRV_PCM_INFO_PAUSE; > >>> > >>> Actually you don't need to set SNDRV_PCM_INFO_RESUME. > >>> This flag means that the driver supports the full resume procedure, > >>> which isn't often the case; with this, the driver is supposed to > >>> resume the stream exactly from the suspended position. > >>> > >>> Most drivers don't set this but implement only the suspend-stop > >>> action. Then the application (or the sound backend) will re-setup the > >>> stream and restart accordingly. > >> > >> I tried to resume driver without SNDRV_PCM_INFO_RESUME, and alsa-lib > >> called only ops->prepare(). It makes sense for a typical hw, but we have > >> "clean" unconfigured device on resume. And we must set hw parameters as > >> a first step. It means, that code should be more or less the same. And > >> maybe it's better to set SNDRV_PCM_INFO_RESUME, since it allows us to > >> resume substream in any situation (regardless of application behavior). > >> I can refactor code to only send requests from trigger(RESUME) path and > >> not to call ops itself. It should make code more straitforward. What do > >> you say? > > > > How about calling hw_params(NULL) conditionally in the prepare? > > Then the question is that condition. When ops->prepare() is called, the > substream is in SUSPENDED state or not? If not then we need to track > this in some additional field (and it will make logic a little bit > clumsy, since that field is needed to be carefully handled in other > places). Yes, you'd need to have a suspend/resume PM callback in the driver that flips the internal flag to invalidate the hw_parmas, and in the prepare callback, just call hw_params(NULL) if that flag is set. > > Doing the full stack work in the trigger callback is bad from the API > > design POV; in general the trigger callback is supposed to be as short > > as possible. > > Yeah, but usually original subsystem design does not take into account > para-virtualized devices, which usually have it's own slightly different > reality. And we need to introduce some tricks. The hardware drivers do a lot of more things in either suspend/resume PM callbacks or prepare callback for re-setup of the hardware. We can follow the similar pattern. Heavy-lifting works in the trigger callbacks is really something to avoid. Takashi