mm-commits.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-05-05 01:33:18 to 2021-05-07 01:04:58 UTC [more...]

incoming
 2021-05-07  1:04 UTC  (57+ messages)
` [patch 01/91] alpha: eliminate old-style function definitions
` [patch 02/91] alpha: csum_partial_copy.c: add function prototypes from <net/checksum.h>
` [patch 03/91] fs/proc/generic.c: fix incorrect pde_is_permanent check
` [patch 04/91] proc: save LOC in __xlate_proc_name()
` [patch 05/91] proc: mandate ->proc_lseek in "struct proc_ops"
` [patch 06/91] proc: delete redundant subset=pid check
` [patch 07/91] selftests: proc: test subset=pid
` [patch 08/91] proc/sysctl: fix function name error in comments
` [patch 09/91] include: remove pagemap.h from blkdev.h
` [patch 10/91] kernel.h: drop inclusion in bitmap.h
` [patch 11/91] linux/profile.h: remove unnecessary declaration
` [patch 12/91] kernel/async.c: fix pr_debug statement
` [patch 13/91] kernel/cred.c: make init_groups static
` [patch 14/91] tools: disable -Wno-type-limits
` [patch 15/91] tools: bitmap: sync function declarations with the kernel
` [patch 16/91] tools: sync BITMAP_LAST_WORD_MASK() macro "
` [patch 17/91] arch: rearrange headers inclusion order in asm/bitops for m68k, sh and h8300
` [patch 18/91] lib: extend the scope of small_const_nbits() macro
` [patch 19/91] tools: sync small_const_nbits() macro with the kernel
` [patch 20/91] lib: inline _find_next_bit() wrappers
` [patch 21/91] tools: sync find_next_bit implementation
` [patch 22/91] lib: add fast path for find_next_*_bit()
` [patch 23/91] lib: add fast path for find_first_*_bit() and find_last_bit()
` [patch 24/91] tools: sync lib/find_bit implementation
` [patch 25/91] MAINTAINERS: add entry for the bitmap API
` [patch 26/91] lib/bch.c: fix a typo in the file bch.c
` [patch 27/91] lib: fix inconsistent indenting in process_bit1()
` [patch 28/91] lib/list_sort.c: fix typo in function description
` [patch 29/91] lib/genalloc.c: fix a typo
` [patch 30/91] lib: crc8: pointer to data block should be const
` [patch 31/91] lib: stackdepot: turn depot_lock spinlock to raw_spinlock
` [patch 32/91] lib/percpu_counter: tame kernel-doc compile warning
` [patch 33/91] lib/genalloc: add parameter description to fix doc "
` [patch 34/91] lib: parser: clean up kernel-doc
` [patch 35/91] include/linux/compat.h: remove unneeded declaration from COMPAT_SYSCALL_DEFINEx()
` [patch 36/91] checkpatch: warn when missing newline in return sysfs_emit() formats
` [patch 37/91] checkpatch: exclude four preprocessor sub-expressions from MACRO_ARG_REUSE
` [patch 38/91] checkpatch: improve ALLOC_ARRAY_ARGS test
` [patch 39/91] kselftest: introduce new epoll test case
` [patch 40/91] fs/epoll: restore waking from ep_done_scan()
` [patch 41/91] isofs: fix fall-through warnings for Clang
` [patch 42/91] fs/nilfs2: fix misspellings using codespell tool
` [patch 43/91] nilfs2: fix typos in comments
` [patch 44/91] hpfs: replace one-element array with flexible-array member
` [patch 45/91] do_wait: make PIDTYPE_PID case O(1) instead of O(n)
` [patch 46/91] kernel/fork.c: simplify copy_mm()
` [patch 47/91] kernel/fork.c: fix typos
` [patch 48/91] kernel/crash_core: add crashkernel=auto for vmcore creation
` [patch 49/91] kexec: add kexec reboot string
` [patch 50/91] kernel: kexec_file: fix error return code of kexec_calculate_store_digests()
` [patch 51/91] kexec: dump kmessage before machine_kexec
` [patch 52/91] gcov: combine common code
` [patch 53/91] gcov: simplify buffer allocation
` [patch 54/91] gcov: use kvmalloc()
` [patch 55/91] gcov: clang: drop support for clang-10 and older
` [patch 56/91] smp: kernel/panic.c - silence warnings

[folded-merged] kernel-resource-allow-region_intersects-users-to-hold-resource_lock-fix.patch removed from -mm tree
 2021-05-07  0:10 UTC 

[folded-merged] gcov-use-kvmalloc-fix.patch removed from -mm tree
 2021-05-07  0:09 UTC 

[folded-merged] arch-rearrange-headers-inclusion-order-in-asm-bitops-for-m68k-and-sh-fix.patch removed from -mm tree
 2021-05-07  0:07 UTC 

[folded-merged] proc-mandate-proc_lseek-in-struct-proc_ops-fix.patch removed from -mm tree
 2021-05-07  0:07 UTC 

incoming
 2021-05-06  3:19 UTC  (139+ messages)
` [patch 008/143] mm/hugetlb: move flush_hugetlb_tlb_range() into hugetlb.h
` [patch 009/143] hugetlb/userfaultfd: unshare all pmds for hugetlbfs when register wp
` [patch 010/143] mm/hugetlb: remove redundant reservation check condition in alloc_huge_page()
` [patch 011/143] mm: generalize HUGETLB_PAGE_SIZE_VARIABLE
` [patch 012/143] mm/hugetlb: use some helper functions to cleanup code
` [patch 013/143] mm/hugetlb: optimize the surplus state transfer code in move_hugetlb_state()
` [patch 014/143] mm/hugetlb_cgroup: remove unnecessary VM_BUG_ON_PAGE in hugetlb_cgroup_migrate()
` [patch 015/143] mm/hugetlb: simplify the code when alloc_huge_page() failed in hugetlb_no_page()
` [patch 016/143] mm/hugetlb: avoid calculating fault_mutex_hash in truncate_op case
` [patch 017/143] khugepaged: remove unneeded return value of khugepaged_collapse_pte_mapped_thps()
` [patch 018/143] khugepaged: reuse the smp_wmb() inside __SetPageUptodate()
` [patch 019/143] khugepaged: use helper khugepaged_test_exit() in __khugepaged_enter()
` [patch 020/143] khugepaged: fix wrong result value for trace_mm_collapse_huge_page_isolate()
` [patch 021/143] mm/huge_memory.c: remove unnecessary local variable ret2
` [patch 022/143] mm/huge_memory.c: rework the function vma_adjust_trans_huge()
` [patch 023/143] mm/huge_memory.c: make get_huge_zero_page() return bool
` [patch 024/143] mm/huge_memory.c: rework the function do_huge_pmd_numa_page() slightly
` [patch 025/143] mm/huge_memory.c: remove redundant PageCompound() check
` [patch 026/143] mm/huge_memory.c: remove unused macro TRANSPARENT_HUGEPAGE_DEBUG_COW_FLAG
` [patch 027/143] mm/huge_memory.c: use helper function migration_entry_to_page()
` [patch 028/143] mm/khugepaged.c: replace barrier() with READ_ONCE() for a selective variable
` [patch 029/143] khugepaged: use helper function range_in_vma() in collapse_pte_mapped_thp()
` [patch 030/143] khugepaged: remove unnecessary out label in collapse_huge_page()
` [patch 031/143] khugepaged: remove meaningless !pte_present() check in khugepaged_scan_pmd()
` [patch 032/143] mm: huge_memory: a new debugfs interface for splitting THP tests
` [patch 033/143] mm: huge_memory: debugfs for file-backed THP split
` [patch 034/143] mm/hugeltb: remove redundant VM_BUG_ON() in region_add()
` [patch 035/143] mm/hugeltb: simplify the return code of __vma_reservation_common()
` [patch 036/143] mm/hugeltb: clarify (chg - freed) won't go negative in hugetlb_unreserve_pages()
` [patch 037/143] mm/hugeltb: handle the error case in hugetlb_fix_reserve_counts()
` [patch 038/143] mm/hugetlb: remove unused variable pseudo_vma in remove_inode_hugepages()
` [patch 039/143] mm/cma: change cma mutex to irq safe spinlock
` [patch 040/143] hugetlb: no need to drop hugetlb_lock to call cma_release
` [patch 041/143] hugetlb: add per-hstate mutex to synchronize user adjustments
` [patch 042/143] hugetlb: create remove_hugetlb_page() to separate functionality
` [patch 043/143] hugetlb: call update_and_free_page without hugetlb_lock
` [patch 044/143] hugetlb: change free_pool_huge_page to remove_pool_huge_page
` [patch 045/143] hugetlb: make free_huge_page irq safe
` [patch 046/143] hugetlb: add lockdep_assert_held() calls for hugetlb_lock
` [patch 047/143] mm,page_alloc: bail out earlier on -ENOMEM in alloc_contig_migrate_range
` [patch 048/143] mm,compaction: let isolate_migratepages_{range,block} return error codes
` [patch 049/143] mm,hugetlb: drop clearing of flag from prep_new_huge_page
` [patch 050/143] mm,hugetlb: split prep_new_huge_page functionality
` [patch 051/143] mm: make alloc_contig_range handle free hugetlb pages
` [patch 052/143] mm: make alloc_contig_range handle in-use "
` [patch 053/143] mm,page_alloc: drop unnecessary checks from pfn_range_valid_contig
` [patch 054/143] userfaultfd: add minor fault registration mode
` [patch 055/143] userfaultfd: disable huge PMD sharing for MINOR registered VMAs
` [patch 056/143] userfaultfd: hugetlbfs: only compile UFFD helpers if config enabled
` [patch 057/143] userfaultfd: add UFFDIO_CONTINUE ioctl
` [patch 058/143] userfaultfd: update documentation to describe minor fault handling
` [patch 059/143] userfaultfd/selftests: add test exercising "
` [patch 060/143] mm/vmscan: move RECLAIM* bits to uapi header
` [patch 061/143] mm/vmscan: replace implicit RECLAIM_ZONE checks with explicit checks
` [patch 062/143] mm: vmscan: use nid from shrink_control for tracepoint
` [patch 063/143] mm: vmscan: consolidate shrinker_maps handling code
` [patch 064/143] mm: vmscan: use shrinker_rwsem to protect shrinker_maps allocation
` [patch 065/143] mm: vmscan: remove memcg_shrinker_map_size
` [patch 066/143] mm: vmscan: use kvfree_rcu instead of call_rcu
` [patch 067/143] mm: memcontrol: rename shrinker_map to shrinker_info
` [patch 068/143] mm: vmscan: add shrinker_info_protected() helper
` [patch 069/143] mm: vmscan: use a new flag to indicate shrinker is registered
` [patch 070/143] mm: vmscan: add per memcg shrinker nr_deferred
` [patch 071/143] mm: vmscan: use per memcg nr_deferred of shrinker
` [patch 072/143] mm: vmscan: don't need allocate shrinker->nr_deferred for memcg aware shrinkers
` [patch 073/143] mm: memcontrol: reparent nr_deferred when memcg offline
` [patch 074/143] mm: vmscan: shrink deferred objects proportional to priority
` [patch 075/143] mm/compaction: remove unused variable sysctl_compact_memory
` [patch 076/143] mm: compaction: update the COMPACT[STALL|FAIL] events properly
` [patch 077/143] mm: disable LRU pagevec during the migration temporarily
` [patch 078/143] mm: replace migrate_[prep|finish] with lru_cache_[disable|enable]
` [patch 079/143] mm: fs: invalidate BH LRU during page migration
` [patch 080/143] mm/migrate.c: make putback_movable_page() static
` [patch 081/143] mm/migrate.c: remove unnecessary rc != MIGRATEPAGE_SUCCESS check in 'else' case
` [patch 082/143] mm/migrate.c: fix potential indeterminate pte entry in migrate_vma_insert_page()
` [patch 083/143] mm/migrate.c: use helper migrate_vma_collect_skip() in migrate_vma_collect_hole()
` [patch 084/143] Revert "mm: migrate: skip shared exec THP for NUMA balancing"
` [patch 085/143] mm: vmstat: add cma statistics
` [patch 086/143] mm: cma: use pr_err_ratelimited for CMA warning
` [patch 087/143] mm: cma: add trace events for CMA alloc perf testing
` [patch 088/143] mm: cma: support sysfs
` [patch 089/143] mm: cma: add the CMA instance name to cma trace events
` [patch 090/143] mm: use proper type for cma_[alloc|release]
` [patch 091/143] ksm: remove redundant VM_BUG_ON_PAGE() on stable_tree_search()
` [patch 092/143] ksm: use GET_KSM_PAGE_NOLOCK to get ksm page in remove_rmap_item_from_tree()
` [patch 093/143] ksm: remove dedicated macro KSM_FLAG_MASK
` [patch 094/143] ksm: fix potential missing rmap_item for stable_node
` [patch 095/143] mm/ksm: remove unused parameter from remove_trailing_rmap_items()
` [patch 096/143] mm: restore node stat checking in /proc/sys/vm/stat_refresh
` [patch 097/143] mm: no more EINVAL from /proc/sys/vm/stat_refresh
` [patch 098/143] mm: /proc/sys/vm/stat_refresh skip checking known negative stats
` [patch 099/143] mm: /proc/sys/vm/stat_refresh stop checking monotonic numa stats
` [patch 100/143] x86/mm: track linear mapping split events
` [patch 101/143] mm/mmap.c: don't unlock VMAs in remap_file_pages()
` [patch 102/143] mm: generalize ARCH_HAS_CACHE_LINE_SIZE
` [patch 104/143] mm: generalize ARCH_ENABLE_MEMORY_[HOTPLUG|HOTREMOVE]
` [patch 105/143] mm: drop redundant ARCH_ENABLE_[HUGEPAGE|THP]_MIGRATION
` [patch 108/143] mm/util.c: reduce mem_dump_obj() object size
` [patch 109/143] mm/util.c: fix typo
` [patch 110/143] mm/gup: don't pin migrated cma pages in movable zone
` [patch 111/143] mm/gup: check every subpage of a compound page during isolation
` [patch 112/143] mm/gup: return an error on migration failure
` [patch 113/143] mm/gup: check for isolation errors
` [patch 114/143] mm cma: rename PF_MEMALLOC_NOCMA to PF_MEMALLOC_PIN
` [patch 115/143] mm: apply per-task gfp constraints in fast path
` [patch 116/143] mm: honor PF_MEMALLOC_PIN for all movable pages
` [patch 117/143] mm/gup: do not migrate zero page
` [patch 118/143] mm/gup: migrate pinned pages out of movable zone
` [patch 119/143] memory-hotplug.rst: add a note about ZONE_MOVABLE and page pinning
` [patch 120/143] mm/gup: change index type to long as it counts pages
` [patch 121/143] mm/gup: longterm pin migration cleanup
` [patch 122/143] selftests/vm: gup_test: fix test flag
` [patch 123/143] selftests/vm: gup_test: test faulting in kernel, and verify pinnable pages
` [patch 124/143] mm/memory_hotplug: remove broken locking of zone PCP structures during hot remove
` [patch 125/143] drivers/base/memory: introduce memory_block_{online,offline}
` [patch 126/143] mm,memory_hotplug: relax fully spanned sections check
` [patch 127/143] mm,memory_hotplug: factor out adjusting present pages into adjust_present_page_count()
` [patch 128/143] mm,memory_hotplug: allocate memmap from the added memory range
` [patch 129/143] acpi,memhotplug: enable MHP_MEMMAP_ON_MEMORY when supported
` [patch 130/143] mm,memory_hotplug: add kernel boot option to enable memmap_on_memory
` [patch 131/143] x86/Kconfig: introduce ARCH_MHP_MEMMAP_ON_MEMORY_ENABLE
` [patch 132/143] arm64/Kconfig: "
` [patch 133/143] mm/zswap.c: switch from strlcpy to strscpy
` [patch 134/143] mm/zsmalloc: use BUG_ON instead of if condition followed by BUG
` [patch 135/143] iov_iter: lift memzero_page() to highmem.h
` [patch 136/143] btrfs: use memzero_page() instead of open coded kmap pattern
` [patch 137/143] mm/highmem.c: fix coding style issue
` [patch 138/143] mm/mempool: minor coding style tweaks
` [patch 139/143] mm/process_vm_access.c: remove duplicate include
` [patch 140/143] kfence: zero guard page after out-of-bounds access
` [patch 141/143] kfence: await for allocation using wait_event
` [patch 142/143] kfence: maximize allocation wait timeout duration
` [patch 143/143] kfence: use power-efficient work queue to run delayed work

+ revert-mm-gup-check-page-posion-status-for-coredump.patch added to -mm tree
 2021-05-05 20:21 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).