mm-commits.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2022-01-14 22:03:46 to 2022-01-20 21:21:11 UTC [more...]

[obsolete] linux-next-git-rejects.patch removed from -mm tree
 2022-01-20 21:21 UTC 

[obsolete] linux-next-rejects.patch removed from -mm tree
 2022-01-20 21:21 UTC 

[GIT PULL] Bitmap patches for 5.17-rc1
 2022-01-20 15:53 UTC  (2+ messages)

incoming
 2022-01-20  2:10 UTC  (56+ messages)
` [patch 01/55] mm: percpu: generalize percpu related config
` [patch 02/55] mm: percpu: add pcpu_fc_cpu_to_node_fn_t typedef
` [patch 03/55] mm: percpu: add generic pcpu_fc_alloc/free funciton
` [patch 04/55] mm: percpu: add generic pcpu_populate_pte() function
` [patch 05/55] proc/vmcore: don't fake reading zeroes on surprise vmcore_cb unregistration
` [patch 06/55] proc: make the proc_create[_data]() stubs static inlines
` [patch 07/55] proc: convert the return type of proc_fd_access_allowed() to be boolean
` [patch 08/55] sysctl: fix duplicate path separator in printed entries
` [patch 09/55] sysctl: remove redundant ret assignment
` [patch 10/55] include/linux/unaligned: replace kernel.h with the necessary inclusions
` [patch 11/55] kernel.h: include a note to discourage people from including it in headers
` [patch 12/55] fs/exec: replace strlcpy with strscpy_pad in __set_task_comm
` [patch 13/55] fs/exec: replace strncpy with strscpy_pad in __get_task_comm
` [patch 14/55] drivers/infiniband: replace open-coded string copy with get_task_comm
` [patch 15/55] fs/binfmt_elf: "
` [patch 16/55] samples/bpf/test_overhead_kprobe_kern: replace bpf_probe_read_kernel with bpf_probe_read_kernel_str to get task comm
` [patch 17/55] tools/bpf/bpftool/skeleton: "
` [patch 18/55] tools/testing/selftests/bpf: replace open-coded 16 with TASK_COMM_LEN
` [patch 19/55] kthread: dynamically allocate memory to store kthread's full name
` [patch 20/55] kernel/sys.c: only take tasklist_lock for get/setpriority(PRIO_PGRP)
` [patch 21/55] get_maintainer: don't remind about no git repo when --nogit is used
` [patch 22/55] kstrtox: uninline everything
` [patch 23/55] list: introduce list_is_head() helper and re-use it in list.h
` [patch 24/55] lib/list_debug.c: print more list debugging context in __list_del_entry_valid()
` [patch 25/55] hash.h: remove unused define directive
` [patch 26/55] test_hash.c: split test_int_hash into arch-specific functions
` [patch 27/55] test_hash.c: split test_hash_init
` [patch 28/55] lib/Kconfig.debug: properly split hash test kernel entries
` [patch 29/55] test_hash.c: refactor into kunit
` [patch 30/55] kunit: replace kernel.h with the necessary inclusions
` [patch 31/55] uuid: discourage people from using UAPI header in new code
` [patch 32/55] uuid: remove licence boilerplate text from the header
` [patch 33/55] lib/test_meminit: destroy cache in kmem_cache_alloc_bulk() test
` [patch 34/55] checkpatch: relax regexp for COMMIT_LOG_LONG_LINE
` [patch 35/55] checkpatch: improve Kconfig help test
` [patch 36/55] const_structs.checkpatch: add frequently used ops structs
` [patch 37/55] fs/binfmt_elf: use PT_LOAD p_align values for static PIE
` [patch 38/55] nilfs2: remove redundant pointer sbufs
` [patch 39/55] hfsplus: use struct_group_attr() for memcpy() region
` [patch 40/55] FAT: use io_schedule_timeout() instead of congestion_wait()
` [patch 41/55] fs/adfs: remove unneeded variable make code cleaner
` [patch 42/55] panic: use error_report_end tracepoint on warnings
` [patch 43/55] panic: remove oops_id
` [patch 44/55] delayacct: support swapin delay accounting for swapping without blkio
` [patch 45/55] delayacct: fix incomplete disable operation when switch enable to disable
` [patch 46/55] delayacct: cleanup flags in struct task_delay_info and functions use it
` [patch 47/55] Documentation/accounting/delay-accounting.rst: add thrashing page cache and direct compact
` [patch 48/55] delayacct: track delays from memory compact
` [patch 49/55] configs: introduce debug.config for CI-like setup
` [patch 50/55] arch/Kconfig: split PAGE_SIZE_LESS_THAN_256KB from PAGE_SIZE_LESS_THAN_64KB
` [patch 51/55] btrfs: use generic Kconfig option for 256kB page size limit
` [patch 52/55] lib/Kconfig.debug: make TEST_KMOD depend on PAGE_SIZE_LESS_THAN_256KB
` [patch 53/55] kcov: fix generic Kconfig dependencies if ARCH_WANTS_NO_INSTR
` [patch 54/55] ubsan: remove CONFIG_UBSAN_OBJECT_SIZE
` [patch 55/55] lib: remove redundant assignment to variable ret

[folded-merged] panic-use-error_report_end-tracepoint-on-warnings-fix.patch removed from -mm tree
 2022-01-20  1:53 UTC 

[folded-merged] hashh-remove-unused-define-directive-fix.patch removed from -mm tree
 2022-01-20  1:52 UTC 

[folded-merged] kernel-sys-only-take-tasklist_lock-for-get-setpriorityprio_pgrp-checkpatch-fixes.patch removed from -mm tree
 2022-01-20  1:52 UTC 

[folded-merged] proc-make-the-proc_create-stubs-static-inlines-fix2.patch removed from -mm tree
 2022-01-20  1:51 UTC 

[folded-merged] proc-make-the-proc_create-stubs-static-inlines-fix2-fix.patch removed from -mm tree
 2022-01-20  1:51 UTC 

[folded-merged] proc-make-the-proc_create-stubs-static-inlines-fix.patch removed from -mm tree
 2022-01-20  1:51 UTC 

incoming
 2022-01-18 16:34 UTC  (136+ messages)
` [patch 002/146] RDMA/siw: make use of the helper function kthread_run_on_cpu()
` [patch 016/146] ocfs2: use default_groups in kobj_type
` [patch 017/146] ocfs2: remove redundant assignment to pointer root_bh
` [patch 018/146] ocfs2: cluster: use default_groups in kobj_type
` [patch 019/146] ocfs2: remove redundant assignment to variable free_space
` [patch 020/146] fs/ioctl: remove unnecessary __user annotation
` [patch 021/146] mm/slab_common: use WARN() if cache still has objects on destroy
` [patch 022/146] mm: slab: make slab iterator functions static
` [patch 023/146] kmemleak: fix kmemleak false positive report with HW tag-based kasan enable
` [patch 024/146] mm: kmemleak: alloc gray object for reserved region with direct map
` [patch 025/146] mm: defer kmemleak object creation of module_alloc()
` [patch 026/146] mm/page_alloc: split prep_compound_page into head and tail subparts
` [patch 027/146] mm/page_alloc: refactor memmap_init_zone_device() page init
` [patch 028/146] mm/memremap: add ZONE_DEVICE support for compound pages
` [patch 029/146] device-dax: use ALIGN() for determining pgoff
` [patch 030/146] device-dax: use struct_size()
` [patch 031/146] device-dax: ensure dev_dax->pgmap is valid for dynamic devices
` [patch 032/146] device-dax: factor out page mapping initialization
` [patch 033/146] device-dax: set mapping prior to vmf_insert_pfn{,_pmd,pud}()
` [patch 034/146] device-dax: remove pfn from __dev_dax_{pte,pmd,pud}_fault()
` [patch 035/146] device-dax: compound devmap support
` [patch 036/146] kasan: test: add globals left-out-of-bounds test
` [patch 037/146] kasan: add ability to detect double-kmem_cache_destroy()
` [patch 038/146] kasan: test: add test case for double-kmem_cache_destroy()
` [patch 039/146] kasan: fix quarantine conflicting with init_on_free
` [patch 040/146] mm,fs: split dump_mapping() out from dump_page()
` [patch 041/146] mm/debug_vm_pgtable: update comments regarding migration swap entries
` [patch 042/146] mm/truncate.c: remove unneeded variable
` [patch 043/146] gup: avoid multiple user access locking/unlocking in fault_in_{read/write}able
` [patch 044/146] mm/gup.c: stricter check on THP migration entry during follow_pmd_mask
` [patch 045/146] mm: shmem: don't truncate page if memory failure happens
` [patch 046/146] shmem: fix a race between shmem_unused_huge_shrink and shmem_evict_inode
` [patch 047/146] mm/frontswap.c: use non-atomic '__set_bit()' when possible
` [patch 048/146] mm: memcontrol: make cgroup_memory_nokmem static
` [patch 049/146] mm/page_counter: remove an incorrect call to propagate_protected_usage()
` [patch 050/146] mm/memcg: add oom_group_kill memory event
` [patch 051/146] memcg: better bounds on the memcg stats updates
` [patch 052/146] mm/memcg: use struct_size() helper in kzalloc()
` [patch 053/146] memcg: add per-memcg vmalloc stat
` [patch 054/146] tools/testing/selftests/vm/userfaultfd.c: use swap() to make code cleaner
` [patch 055/146] mm: remove redundant check about FAULT_FLAG_ALLOW_RETRY bit
` [patch 056/146] mm: rearrange madvise code to allow for reuse
` [patch 057/146] mm: add a field to store names for private anonymous memory
` [patch 058/146] mm: add anonymous vma name refcounting
` [patch 059/146] mm: move anon_vma declarations to linux/mm_inline.h
` [patch 060/146] mm: move tlb_flush_pending inline helpers to mm_inline.h
` [patch 061/146] mm: protect free_pgtables with mmap_lock write lock in exit_mmap
` [patch 062/146] mm: document locking restrictions for vm_operations_struct::close
` [patch 063/146] mm/oom_kill: allow process_mrelease to run under mmap_lock protection
` [patch 064/146] docs/vm: add vmalloced-kernel-stacks document
` [patch 065/146] mm: change page type prior to adding page table entry
` [patch 066/146] mm: ptep_clear() page table helper
` [patch 067/146] mm: page table check
` [patch 068/146] x86: mm: add x86_64 support for "
` [patch 069/146] mm: remove last argument of reuse_swap_page()
` [patch 070/146] mm: remove the total_mapcount argument from page_trans_huge_map_swapcount()
` [patch 071/146] mm: remove the total_mapcount argument from page_trans_huge_mapcount()
` [patch 072/146] mm/dmapool.c: revert "make dma pool to use kmalloc_node"
` [patch 073/146] mm/vmalloc: alloc GFP_NO{FS,IO} for vmalloc
` [patch 074/146] mm/vmalloc: add support for __GFP_NOFAIL
` [patch 075/146] mm/vmalloc: be more explicit about supported gfp flags
` [patch 076/146] mm: allow !GFP_KERNEL allocations for kvmalloc
` [patch 077/146] mm: make slab and vmalloc allocators __GFP_NOLOCKDEP aware
` [patch 078/146] mm: introduce memalloc_retry_wait()
` [patch 079/146] mm/pagealloc: sysctl: change watermark_scale_factor max limit to 30%
` [patch 080/146] mm: fix boolreturn.cocci warning
` [patch 081/146] mm: page_alloc: fix building error on -Werror=array-compare
` [patch 082/146] mm: drop node from alloc_pages_vma
` [patch 083/146] include/linux/gfp.h: further document GFP_DMA32
` [patch 084/146] mm/page_alloc.c: modify the comment section for alloc_contig_pages()
` [patch 085/146] mm_zone: add function to check if managed dma zone exists
` [patch 086/146] dma/pool: create dma atomic pool only if dma zone has managed pages
` [patch 087/146] mm/page_alloc.c: do not warn allocation failure on zone DMA if no "
` [patch 088/146] hugetlb: add hugetlb.*.numa_stat file
` [patch 089/146] mm, hugepages: make memory size variable in hugepage-mremap selftest
` [patch 090/146] mm/vmstat: add events for THP max_ptes_* exceeds
` [patch 091/146] selftests/vm: make charge_reserved_hugetlb.sh work with existing cgroup setting
` [patch 092/146] selftests/uffd: allow EINTR/EAGAIN
` [patch 093/146] userfaultfd/selftests: clean up hugetlb allocation code
` [patch 094/146] vmscan: make drop_slab_node static
` [patch 095/146] mm/page_isolation: unset migratetype directly for non Buddy page
` [patch 096/146] mm/mempolicy: use policy_node helper with MPOL_PREFERRED_MANY
` [patch 097/146] mm/mempolicy: add set_mempolicy_home_node syscall
` [patch 098/146] mm/mempolicy: wire up syscall set_mempolicy_home_node
` [patch 099/146] mm/mempolicy: fix all kernel-doc warnings
` [patch 100/146] mm, oom: OOM sysrq should always kill a process
` [patch 101/146] hugetlbfs: fix off-by-one error in hugetlb_vmdelete_list()
` [patch 102/146] mm: migrate: fix the return value of migrate_pages()
` [patch 103/146] mm: migrate: correct the hugetlb migration stats
` [patch 104/146] mm: compaction: fix the migration stats in trace_mm_compaction_migratepages()
` [patch 105/146] mm: migrate: support multiple target nodes demotion
` [patch 106/146] mm: migrate: add more comments for selecting target node randomly
` [patch 107/146] mm/migrate: move node demotion code to near its user
` [patch 108/146] mm/migrate: remove redundant variables used in a for-loop
` [patch 109/146] mm/thp: drop unused trace events hugepage_[invalidate|splitting]
` [patch 110/146] mm: ksm: fix use-after-free kasan report in ksm_might_need_to_copy
` [patch 111/146] mm/hwpoison: mf_mutex for soft offline and unpoison
` [patch 112/146] mm/hwpoison: remove MF_MSG_BUDDY_2ND and MF_MSG_POISONED_HUGE
` [patch 113/146] mm/hwpoison: fix unpoison_memory()
` [patch 114/146] mm: memcg/percpu: account extra objcg space to memory cgroups
` [patch 115/146] mm/rmap: fix potential batched TLB flush race
` [patch 116/146] zpool: remove the list of pools_head
` [patch 117/146] zram: use ATTRIBUTE_GROUPS
` [patch 118/146] mm: fix some comment errors
` [patch 119/146] mm: make some vars and functions static or __init
` [patch 120/146] mm/hmm.c: allow VM_MIXEDMAP to work with hmm_range_fault
` [patch 121/146] mm/damon: unified access_check function naming rules
` [patch 122/146] mm/damon: add 'age' of region tracepoint support
` [patch 123/146] mm/damon/core: use abs() instead of diff_of()
` [patch 124/146] mm/damon: remove some unneeded function definitions in damon.h
` [patch 125/146] mm/damon/vaddr: remove swap_ranges() and replace it with swap()
` [patch 126/146] mm/damon/schemes: add the validity judgment of thresholds
` [patch 127/146] mm/damon: move damon_rand() definition into damon.h
` [patch 128/146] mm/damon: modify damon_rand() macro to static inline function
` [patch 129/146] mm/damon: convert macro functions to static inline functions
` [patch 130/146] Docs/admin-guide/mm/damon/usage: update for scheme quotas and watermarks
` [patch 131/146] Docs/admin-guide/mm/damon/usage: remove redundant information
` [patch 132/146] Docs/admin-guide/mm/damon/usage: mention tracepoint at the beginning
` [patch 133/146] Docs/admin-guide/mm/damon/usage: update for kdamond_pid and (mk|rm)_contexts
` [patch 134/146] mm/damon: remove a mistakenly added comment for a future feature
` [patch 135/146] mm/damon/schemes: account scheme actions that successfully applied
` [patch 136/146] mm/damon/schemes: account how many times quota limit has exceeded
` [patch 137/146] mm/damon/reclaim: provide reclamation statistics
` [patch 138/146] Docs/admin-guide/mm/damon/reclaim: document statistics parameters
` [patch 139/146] mm/damon/dbgfs: support all DAMOS stats
` [patch 140/146] Docs/admin-guide/mm/damon/usage: update for schemes statistics
` [patch 141/146] mm/damon: add access checking for hugetlb pages
` [patch 142/146] mm/damon: move the implementation of damon_insert_region to damon.h
` [patch 143/146] mm/damon/dbgfs: remove an unnecessary variable
` [patch 144/146] mm/damon/vaddr: use pr_debug() for damon_va_three_regions() failure logging
` [patch 145/146] mm/damon/vaddr: hide kernel pointer from damon_va_three_regions() failure log
` [patch 146/146] mm/damon: hide kernel pointer from tracepoint event


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).