netdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Ben Hutchings <bhutchings@solarflare.com>
To: Kyle Moffett <Kyle.D.Moffett@boeing.com>
Cc: linux-kernel@vger.kernel.org, netdev@vger.kernel.org,
	"David S. Miller" <davem@davemloft.net>,
	David Decotigny <decot@google.com>,
	Stephen Hemminger <shemminger@vyatta.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Lucas De Marchi <lucas.demarchi@profusion.mobi>,
	Marc Kleine-Budde <mkl@pengutronix.de>,
	Mike Frysinger <vapier@gentoo.org>
Subject: Re: [RFC PATCH 15/17] phy_device: Add "port" and "transciever" fields
Date: Fri, 21 Oct 2011 00:27:59 +0100	[thread overview]
Message-ID: <1319153279.2918.16.camel@deadeye> (raw)
In-Reply-To: <1319144425-15547-16-git-send-email-Kyle.D.Moffett@boeing.com>

On Thu, 2011-10-20 at 17:00 -0400, Kyle Moffett wrote:
> Some PHYs have multiple software-selectable inputs and outputs,
> including RGMII, SGMII, SerDes, etc.  New fields are added to the
> "struct phy_device" for "port" and "transciever" to allow "ethtool" to
> switch outputs at runtime.  The defaults for the new fields are
> identical to the hardcoded values used previously.
> 
> This should make no functional changes to the PHY layer behavior, but
> it will allow later PHY/ethernet drivers to override those fields.
> 
> Signed-off-by: Kyle Moffett <Kyle.D.Moffett@boeing.com>
> ---
>  drivers/net/phy/phy.c        |    4 ++--
>  drivers/net/phy/phy_device.c |    2 ++
>  include/linux/phy.h          |    4 ++++
>  3 files changed, 8 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/net/phy/phy.c b/drivers/net/phy/phy.c
> index c378f91..5f72055 100644
> --- a/drivers/net/phy/phy.c
> +++ b/drivers/net/phy/phy.c
> @@ -290,9 +290,9 @@ int phy_ethtool_gset(struct phy_device *phydev, struct ethtool_cmd *cmd)
>  
>  	ethtool_cmd_speed_set(cmd, phydev->speed);
>  	cmd->duplex = phydev->duplex;
> -	cmd->port = PORT_MII;
> +	cmd->port = phydev->port;
>  	cmd->phy_address = phydev->addr;
> -	cmd->transceiver = XCVR_EXTERNAL;
> +	cmd->transceiver = phydev->transciever;

'transceiver' is spelt thus.

[...]
> --- a/include/linux/phy.h
> +++ b/include/linux/phy.h
> @@ -308,6 +308,10 @@ struct phy_device {
>  	u32 supported;
>  	u32 advertising;
>  
> +	/* The current port/xcvr info (Copper, Fibre, MII, Direct-Attach) */
> +	u8 port;
> +	u8 transceiver;
> +

And yet you got it right here.

Ben.

>  	int autoneg;
>  
>  	int link_timeout;

-- 
Ben Hutchings, Staff Engineer, Solarflare
Not speaking for my employer; that's the marketing department's job.
They asked us to note that Solarflare product names are trademarked.

  reply	other threads:[~2011-10-20 23:27 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-10-20 21:00 [RFC PATCH 0/17] Miscellaneous generic PHY layer improvements Kyle Moffett
2011-10-20 21:00 ` [RFC PATCH 01/17] et1011c: Replaced PHY driver by a small dm646x board fixup Kyle Moffett
2011-10-20 21:00 ` [RFC PATCH 02/17] of_mdio: Don't phy_scan_fixups() twice Kyle Moffett
2011-10-25  4:56   ` Grant Likely
2011-10-20 21:00 ` [RFC PATCH 03/17] greth: Allow PHYs to override ->read_status Kyle Moffett
2011-10-20 21:00 ` [RFC PATCH 04/17] phy/icplus: Fix read_status/config_aneg error handling Kyle Moffett
2011-10-20 21:00 ` [RFC PATCH 05/17] phy_driver: Make .read_status()/.config_aneg() optional Kyle Moffett
2011-10-20 21:10   ` Mike Frysinger
2011-10-20 21:14     ` Mike Frysinger
2011-10-21  5:13       ` Kyle Moffett
2011-10-25  7:06         ` Mike Frysinger
2011-10-20 21:00 ` [RFC PATCH 06/17] phy_driver: Add and use phy_driver_[un]register_multiple() Kyle Moffett
2011-10-20 21:15   ` Mike Frysinger
2011-10-25  5:00     ` Grant Likely
2011-10-25  5:41       ` Mike Frysinger
2011-11-03 22:46   ` Andy Fleming
2011-10-20 21:00 ` [RFC PATCH 07/17] phy: Unify PHY reset, initialization, and fixup handling Kyle Moffett
2011-10-20 21:00 ` [RFC PATCH 08/17] drivers/net/bfin_mac: Don't unnecessarily reset the PHY Kyle Moffett
2011-10-25  6:59   ` Mike Frysinger
2011-10-25  7:26   ` Zhang, Sonic
2011-10-20 21:00 ` [RFC PATCH 09/17] mv643xx_eth: Use standardized phy_init_hw() for PHY reset Kyle Moffett
2011-10-20 21:00 ` [RFC PATCH 10/17] pxa186_eth: " Kyle Moffett
2011-10-20 21:00 ` [RFC PATCH 11/17] sh_eth: Don't unnecessarily reset the PHY Kyle Moffett
2011-10-25 11:11   ` Yoshihiro Shimoda
2011-10-25 16:00     ` Moffett, Kyle D
2011-10-20 21:00 ` [RFC PATCH 12/17] tc35815: Use standard phy_init_hw() instead of BMCR_RESET bit Kyle Moffett
2011-10-20 21:00 ` [RFC PATCH 13/17] mpc836x: Move board-specific bcm5481 fixup out of the PHY driver Kyle Moffett
2011-10-20 21:00 ` [RFC PATCH 14/17] lxt973: Clean up fixed-mode fiber PHY handling Kyle Moffett
2011-10-20 21:00 ` [RFC PATCH 15/17] phy_device: Add "port" and "transciever" fields Kyle Moffett
2011-10-20 23:27   ` Ben Hutchings [this message]
2011-10-21  7:12     ` Kyle Moffett
2011-10-20 21:00 ` [RFC PATCH 16/17] phy_device: Add phy_setmask helper function Kyle Moffett
2011-10-20 21:00 ` [RFC PATCH 17/17] phy_device: Rename phy_start_aneg() to phy_start_link() Kyle Moffett
2011-11-03 22:51   ` Andy Fleming

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1319153279.2918.16.camel@deadeye \
    --to=bhutchings@solarflare.com \
    --cc=Kyle.D.Moffett@boeing.com \
    --cc=akpm@linux-foundation.org \
    --cc=davem@davemloft.net \
    --cc=decot@google.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lucas.demarchi@profusion.mobi \
    --cc=mkl@pengutronix.de \
    --cc=netdev@vger.kernel.org \
    --cc=shemminger@vyatta.com \
    --cc=vapier@gentoo.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).