Netdev Archive on lore.kernel.org
 help / color / Atom feed
From: Jiri Pirko <jpirko@redhat.com>
To: Ingo Molnar <mingo@elte.hu>
Cc: David Miller <davem@davemloft.net>,
	torvalds@linux-foundation.org, akpm@linux-foundation.org,
	netdev@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [forcedeth bug] Re: [GIT] Networking
Date: Fri, 5 Aug 2011 13:25:58 +0200
Message-ID: <20110805112557.GD1928@minipsycho.orion> (raw)
In-Reply-To: <20110805102903.GF2420@elte.hu>

Fri, Aug 05, 2011 at 12:29:03PM CEST, mingo@elte.hu wrote:
>
>* Jiri Pirko <jpirko@redhat.com> wrote:
>
>> Thu, Aug 04, 2011 at 11:53:54PM CEST, mingo@elte.hu wrote:
>> >
>> >* Ingo Molnar <mingo@elte.hu> wrote:
>> >
>> >>  0891b0e08937: forcedeth: fix vlans
>> >
>> >Hm, forcedeth is still giving me trouble even on latest -git that has 
>> >the above fix included.
>> >
>> >The symptom is a stuck interface, no packets in. There's a frame 
>> >error RX packet:
>> >
>> > [root@mercury ~]# ifconfig eth0
>> > eth0      Link encap:Ethernet  HWaddr 00:13:D4:DC:41:12  
>> >           inet addr:10.0.1.13  Bcast:10.0.1.255  Mask:255.255.255.0
>> >           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>> >           RX packets:0 errors:1 dropped:0 overruns:0 frame:1
>> >           TX packets:531 errors:0 dropped:0 overruns:0 carrier:0
>> >           collisions:0 txqueuelen:1000 
>> >           RX bytes:0 (0.0 b)  TX bytes:34112 (33.3 KiB)
>> >           Interrupt:35 
>> >
>> >Weirdly enough a defconfig x86 bootup works just fine - it's certain 
>> >.config combinations that trigger the bug. I've attached such a 
>> >config.
>> >
>> >Note that at least once i've observed a seemingly good kernel going 
>> >'bad' after a couple of minutes uptime. I've also observed 
>> >intermittent behavior - apparent lost packets and a laggy network.
>> >
>> >I have done 3 failed attempts to bisect it any further - i got to the 
>> >commit that got fixed by:
>> >
>> >  0891b0e08937: forcedeth: fix vlans
>> >
>> >... but that's something we already knew.
>> >
>> >Let me know if there's any data i can provide to help debug this 
>> >problem.
>> >
>> >Thanks,
>> >
>> >	Ingo
>> 
>> Interesting.
>> 
>> Is DEV_HAS_VLAN set in id->driver_data (L5344) ?
>
>How do i tell that without hacking the driver?

look in dmesg for line like:
"forcedeth 0000:00:08.0: highdma csum vlan pwrctl mgmt gbit lnktim msi
desc-v3"

if "vlan" is there, DEV_HAS_VLAN is set

>
>> If so, would you try to disable both rx an tx vlan accel using 
>> ethtool and see if it helps?
>
>Should i do that when the device is in a stuck state and see whether 
>it recovers?

Yes.

>
>Also, please provide the exact ethtool command sequences i should 
>try, this makes it easier for me to test exactly what you want me to 
>test.

ethtool -K eth0 txvlan off rxvlan off


>
>Thanks,
>
>	Ingo

  parent reply index

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-07-22 14:33 David Miller
2011-08-01 15:13 ` Ingo Molnar
2011-08-04 21:53   ` [forcedeth bug] " Ingo Molnar
2011-08-05 10:16     ` [PATCH, REVERT] " Ingo Molnar
2011-08-05 10:19       ` David Miller
2011-08-05 10:26         ` Jiri Pirko
2011-08-05 10:22     ` Jiri Pirko
2011-08-05 10:29       ` Ingo Molnar
2011-08-05 11:12         ` Neil Horman
2011-08-05 11:44           ` Jiri Pirko
2011-08-05 11:25         ` Jiri Pirko [this message]
2011-08-05 12:18           ` Ingo Molnar
2011-08-05 12:31             ` Jiri Pirko
2011-08-05 14:37               ` Jiri Pirko
2011-08-09 13:13                 ` Jiri Pirko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110805112557.GD1928@minipsycho.orion \
    --to=jpirko@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=davem@davemloft.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=netdev@vger.kernel.org \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Netdev Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/netdev/0 netdev/git/0.git
	git clone --mirror https://lore.kernel.org/netdev/1 netdev/git/1.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 netdev netdev/ https://lore.kernel.org/netdev \
		netdev@vger.kernel.org
	public-inbox-index netdev

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.kernel.vger.netdev


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git