netdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Simon Horman <simon.horman@netronome.com>
To: David Miller <davem@davemloft.net>
Cc: sfeldma@gmail.com, netdev@vger.kernel.org, jiri@resnulli.us,
	roopa@cumulusnetworks.com, linux@roeck-us.net,
	f.fainelli@gmail.com, andrew@lunn.ch, joe@perches.com,
	sridhar.samudrala@intel.com, ronen.arad@intel.com
Subject: Re: [PATCH net-next v7 00/24] switchdev: spring cleanup
Date: Thu, 14 May 2015 18:30:47 +0900	[thread overview]
Message-ID: <20150514093044.GA2218@penelope.isobedori.kobe.vergenet.net> (raw)
In-Reply-To: <20150512.184532.1368324454021599990.davem@davemloft.net>

On Tue, May 12, 2015 at 06:45:32PM -0400, David Miller wrote:
> From: sfeldma@gmail.com
> Date: Sun, 10 May 2015 09:47:45 -0700
> 
> > The main theme of this patch set is to cleanup swdev in preparation for
> > new features or fixes to be added soon.  We have a pretty good idea now how
> > to handle stacked drivers in swdev, but there where some loose ends.  For
> > example, if a set failed in the middle of walking the lower devs, we would
> > leave the system in an undefined state...there was no way to recover back to
> > the previous state.  Speaking of sets, also recognize a pattern that most
> > swdev API accesses are gets or sets of port attributes, so go ahead and make
> > port attr get/set the central swdev API, and convert everything that is
> > set-ish/get-ish to this new API.
> > 
> > Features/fixes that should follow from this cleanup:
> > 
> >  - solve the duplicate pkt forwarding issue
> >  - get/set bridge attrs, like ageing_time, from/to device
> >  - get/set more bridge port attrs from/to device
> > 
> > There are some rename cleanups tagging along at the end, to give swdev
> > consistent naming.
> > 
> > And finally, some much needed updates to the switchdev.txt documentation to
> > hopefully capture the state-of-the-art of swdev.  Hopefully, we can do a better
> > job keeping this document up-to-date.
> > 
> > Tested with rocker, of course, to make sure nothing functional broke.  There
> > are a couple minor tweaks to DSA code for getting switch ID and setting STP
> > updates to use new API, but not expecting amy breakage there.
> 
> Ok, this series looks good for the most part so I'll apply it, thanks
> Scott.
> 
> One thing that worries me is that deferral of operations when rtnl
> isn't held.  You've lost the ability there to signal an error back
> to the user, so you just return zero and BUG() if it does actually
> error.
> 
> You'll need to do something better in that situation in my opinion.
> 
> My preference would be to require that RTNL is held on any traversal
> into those code paths.


FWIW I seem to be hitting.


static int rocker_port_attr_set(struct net_device *dev,
				struct switchdev_attr *attr)
{
	struct rocker_port *rocker_port = netdev_priv(dev);
	int err = 0;

	switch (attr->trans) {
	case SWITCHDEV_TRANS_PREPARE:
		BUG_ON(!list_empty(&rocker_port->trans_mem));

It seems that this may be due to outstanding work created by
rocker_wait_create().  I suspect that RTNL is held when the work is created
but not when it is completed.

Or more to the point, I am reliably hitting the BUG_ON() above
and so far my investigations point at rocker_wait_create.

My test case is as follows:

ip link add br0 type bridge
ip addr add 10.0.99.192/24 dev br0
ip link set down dev eth0
ip link set up dev eth0
ip link set dev eth0 master br0


I have observed the above with my "[PATCH v2 net-next 0/2] rocker: unused
parameter and const cleanups" patchset applied but I'm not sure if that is
strictly related.

      reply	other threads:[~2015-05-14  9:31 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-05-10 16:47 [PATCH net-next v7 00/24] switchdev: spring cleanup sfeldma
2015-05-10 16:47 ` [PATCH net-next v7 01/24] switchdev: s/netdev_switch_/switchdev_/ and s/NETDEV_SWITCH_/SWITCHDEV_/ sfeldma
2015-05-10 16:47 ` [PATCH net-next v7 02/24] switchdev: s/swdev_/switchdev_/ sfeldma
2015-05-10 16:47 ` [PATCH net-next v7 03/24] switchdev: introduce get/set attrs ops sfeldma
2015-05-10 16:47 ` [PATCH net-next v7 04/24] switchdev: convert parent_id_get to switchdev attr get sfeldma
2015-05-10 16:47 ` [PATCH net-next v7 05/24] rocker: support prepare-commit transaction model sfeldma
2015-05-10 19:20   ` Jiri Pirko
2015-05-10 16:47 ` [PATCH net-next v7 06/24] switchdev: convert STP update to switchdev attr set sfeldma
2015-05-10 19:29   ` Jiri Pirko
2015-05-10 16:47 ` [PATCH net-next v7 07/24] switchdev: introduce switchdev add/del obj ops sfeldma
2015-05-10 16:47 ` [PATCH net-next v7 08/24] switchdev: add port vlan obj sfeldma
2015-05-10 16:47 ` [PATCH net-next v7 09/24] rocker: use switchdev add/del obj for bridge port vlans sfeldma
2015-05-10 16:47 ` [PATCH net-next v7 10/24] switchdev: add bridge port flags attr sfeldma
2015-05-10 16:47 ` [PATCH net-next v7 11/24] switchdev: add new switchdev bridge setlink sfeldma
2015-05-10 16:47 ` [PATCH net-next v7 12/24] switchdev: cut over to new switchdev_port_bridge_setlink sfeldma
2015-05-10 16:47 ` [PATCH net-next v7 13/24] switchdev: remove old switchdev_port_bridge_setlink sfeldma
2015-05-10 16:47 ` [PATCH net-next v7 14/24] bridge: restore br_setlink back to original sfeldma
2015-05-10 16:48 ` [PATCH net-next v7 15/24] switchdev: add new switchdev_port_bridge_dellink sfeldma
2015-05-10 19:58   ` Jiri Pirko
2015-05-10 16:48 ` [PATCH net-next v7 16/24] switchdev: cut over to " sfeldma
2015-05-10 19:58   ` Jiri Pirko
2015-05-10 16:48 ` [PATCH net-next v7 17/24] switchdev: remove unused switchdev_port_bridge_dellink sfeldma
2015-05-10 19:58   ` Jiri Pirko
2015-05-10 16:48 ` [PATCH net-next v7 18/24] bridge: revert br_dellink change back to original sfeldma
2015-05-10 19:59   ` Jiri Pirko
2015-05-10 16:48 ` [PATCH net-next v7 19/24] switchdev: add new switchdev_port_bridge_getlink sfeldma
2015-05-10 16:48 ` [PATCH net-next v7 20/24] switchdev: cut over to " sfeldma
2015-05-10 16:48 ` [PATCH net-next v7 21/24] switchdev: convert fib_ipv4_add/del over to switchdev_port_obj_add/del sfeldma
2015-05-10 16:48 ` [PATCH net-next v7 22/24] switchdev: remove NETIF_F_HW_SWITCH_OFFLOAD feature flag sfeldma
2015-05-10 16:48 ` [PATCH net-next v7 23/24] rocker: make checkpatch -f clean sfeldma
2015-05-10 20:07   ` Jiri Pirko
2015-05-10 16:48 ` [PATCH net-next v7 24/24] switchdev: bring documentation up-to-date sfeldma
2015-05-11 18:33   ` Jiri Pirko
2015-05-11 21:02   ` Rosen, Rami
2015-05-13  5:37     ` Scott Feldman
2015-05-12 22:45 ` [PATCH net-next v7 00/24] switchdev: spring cleanup David Miller
2015-05-14  9:30   ` Simon Horman [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150514093044.GA2218@penelope.isobedori.kobe.vergenet.net \
    --to=simon.horman@netronome.com \
    --cc=andrew@lunn.ch \
    --cc=davem@davemloft.net \
    --cc=f.fainelli@gmail.com \
    --cc=jiri@resnulli.us \
    --cc=joe@perches.com \
    --cc=linux@roeck-us.net \
    --cc=netdev@vger.kernel.org \
    --cc=ronen.arad@intel.com \
    --cc=roopa@cumulusnetworks.com \
    --cc=sfeldma@gmail.com \
    --cc=sridhar.samudrala@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).