netdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Andrew Lunn <andrew@lunn.ch>
To: Rob Herring <robh@kernel.org>
Cc: Kurt Kanzenbach <kurt@linutronix.de>,
	Vivien Didelot <vivien.didelot@gmail.com>,
	Florian Fainelli <f.fainelli@gmail.com>,
	"David S. Miller" <davem@davemloft.net>,
	Jakub Kicinski <kuba@kernel.org>,
	netdev@vger.kernel.org, devicetree@vger.kernel.org
Subject: Re: [PATCH v1 1/1] dt-bindings: net: dsa: Add DSA yaml binding
Date: Fri, 10 Jul 2020 19:39:36 +0200	[thread overview]
Message-ID: <20200710173936.GF1037260@lunn.ch> (raw)
In-Reply-To: <20200710164500.GA2775934@bogus>

On Fri, Jul 10, 2020 at 10:45:00AM -0600, Rob Herring wrote:
> On Fri, Jul 10, 2020 at 11:06:18AM +0200, Kurt Kanzenbach wrote:
> > For future DSA drivers it makes sense to add a generic DSA yaml binding which
> > can be used then. This was created using the properties from dsa.txt. It
> > includes the ports and the dsa,member property.
> > 
> > Suggested-by: Florian Fainelli <f.fainelli@gmail.com>
> > Signed-off-by: Kurt Kanzenbach <kurt@linutronix.de>
> > ---
> >  .../devicetree/bindings/net/dsa/dsa.yaml      | 80 +++++++++++++++++++
> >  1 file changed, 80 insertions(+)
> >  create mode 100644 Documentation/devicetree/bindings/net/dsa/dsa.yaml
> > 
> > diff --git a/Documentation/devicetree/bindings/net/dsa/dsa.yaml b/Documentation/devicetree/bindings/net/dsa/dsa.yaml
> > new file mode 100644
> > index 000000000000..bec257231bf8
> > --- /dev/null
> > +++ b/Documentation/devicetree/bindings/net/dsa/dsa.yaml
> > @@ -0,0 +1,80 @@
> > +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause)
> > +%YAML 1.2
> > +---
> > +$id: http://devicetree.org/schemas/net/dsa/dsa.yaml#
> > +$schema: http://devicetree.org/meta-schemas/core.yaml#
> > +
> > +title: Distributed Switch Architecture Device Tree Bindings
> 
> DSA is a Linuxism, right?

Hi Rob

Marvell'ism actually. They came up the idea for how you can
interconnect multiple switches to form a distributed switch fabric. So
far, the Marvell driver is the only driver that makes use of D in
DSA. But it seems like some other vendors have similar concepts. And
those which don't allow D in DSA can use a simplified version of the
architecture for a single switch.

> Describe what type of h/w should use this binding.
> 
> > +
> > +properties:
> > +  $nodename:
> > +    pattern: "^switch(@.*)?$"
> > +
> > +  dsa,member:
> > +    minItems: 2
> > +    maxItems: 2
> > +    description:
> > +      A two element list indicates which DSA cluster, and position within the
> > +      cluster a switch takes. <0 0> is cluster 0, switch 0. <0 1> is cluster 0,
> > +      switch 1. <1 0> is cluster 1, switch 0. A switch not part of any cluster
> > +      (single device hanging off a CPU port) must not specify this property
> > +    $ref: /schemas/types.yaml#/definitions/uint32-array
> > +
> > +  ports:
> > +    type: object
> > +    properties:
> > +      '#address-cells':
> > +        const: 1
> > +      '#size-cells':
> > +        const: 0
> > +
> > +    patternProperties:
> > +      "^port@[0-9]+$":
> 
> As ports and port are OF graph nodes, it would be better if we 
> standardized on a different name for these. I think we've used 
> 'ethernet-port' some.

I suspect DSA was using port before OF graph came along. Yep:

commit 5e95329b701c4edf6c4d72487ec0369fa148c0bd
Author: Florian Fainelli <florian@openwrt.org>
Date:   Fri Mar 22 10:50:50 2013 +0000

    dsa: add device tree bindings to register DSA switches

commit 4d56ed5a009b7d31ecae1dd26c047b8bb0dd9287
Author: Philipp Zabel <p.zabel@pengutronix.de>
Date:   Tue Feb 25 15:44:49 2014 +0100

    Documentation: of: Document graph bindings

So this usage is will established and it is probably a bit late to
change it now.

   Andrew

      parent reply	other threads:[~2020-07-10 17:39 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-10  9:06 [PATCH v1 0/1] dt-bindings: net: dsa: Add DSA yaml binding Kurt Kanzenbach
2020-07-10  9:06 ` [PATCH v1 1/1] " Kurt Kanzenbach
2020-07-10 16:39   ` Rob Herring
2020-07-11 11:35     ` Kurt Kanzenbach
2020-07-11 16:52       ` Andrew Lunn
2020-07-12 10:29         ` Kurt Kanzenbach
2020-07-13 20:56         ` Rob Herring
2020-07-10 16:45   ` Rob Herring
2020-07-10 17:20     ` Florian Fainelli
2020-07-10 19:38       ` Rob Herring
2020-07-11 11:59         ` Kurt Kanzenbach
2020-07-11 16:42           ` Andrew Lunn
2020-07-13 20:41           ` Rob Herring
2020-07-14  6:18             ` Kurt Kanzenbach
2020-07-10 17:39     ` Andrew Lunn [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200710173936.GF1037260@lunn.ch \
    --to=andrew@lunn.ch \
    --cc=davem@davemloft.net \
    --cc=devicetree@vger.kernel.org \
    --cc=f.fainelli@gmail.com \
    --cc=kuba@kernel.org \
    --cc=kurt@linutronix.de \
    --cc=netdev@vger.kernel.org \
    --cc=robh@kernel.org \
    --cc=vivien.didelot@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).