netdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Jonathan Lemon <jonathan.lemon@gmail.com>
To: Willem de Bruijn <willemdebruijn.kernel@gmail.com>
Cc: Network Development <netdev@vger.kernel.org>,
	Eric Dumazet <edumazet@google.com>,
	David Ahern <dsahern@gmail.com>, Kernel Team <kernel-team@fb.com>
Subject: Re: [RFC PATCH v3 00/12] Generic zcopy_* functions
Date: Mon, 4 Jan 2021 20:17:07 -0800	[thread overview]
Message-ID: <20210105041707.m574sk4ivjsxvtxi@bsd-mbp.dhcp.thefacebook.com> (raw)
In-Reply-To: <CAF=yD-Jb-tkxYPHrnAk3x641RY6tnrGOJB0UkrBWrXmvuRiM9w@mail.gmail.com>

On Mon, Jan 04, 2021 at 12:39:35PM -0500, Willem de Bruijn wrote:
> On Wed, Dec 30, 2020 at 2:12 PM Jonathan Lemon <jonathan.lemon@gmail.com> wrote:
> >
> > From: Jonathan Lemon <bsd@fb.com>
> >
> > This is set of cleanup patches for zerocopy which are intended
> > to allow a introduction of a different zerocopy implementation.
> >
> > The top level API will use the skb_zcopy_*() functions, while
> > the current TCP specific zerocopy ends up using msg_zerocopy_*()
> > calls.
> >
> > There should be no functional changes from these patches.
> >
> > v2->v3:
> >  Rename zc_flags to 'flags'.  Use SKBFL_xxx naming, similar
> >  to the SKBTX_xx naming.  Leave zerocopy_success naming alone.
> >  Reorder patches.
> >
> > v1->v2:
> >  Break changes to skb_zcopy_put into 3 patches, in order to
> >  make it easier to follow the changes.  Add Willem's suggestion
> >  about renaming sock_zerocopy_
> 
> Overall, this latest version looks fine to me.
> 
> The big question is how this fits in with the broader rx direct
> placement feature. But it makes sense to me to checkpoint as is at
> this point.
> 
> One small comment: skb_zcopy_* is a logical prefix for functions that
> act on sk_buffs, Such as skb_zcopy_set, which associates a uarg with
> an skb. Less for functions that operate directly on the uarg, and do
> not even take an skb as argument: skb_zcopy_get and skb_zcopy_put.
> Perhaps net_zcopy_get/net_zcopy_put?

Or even just zcopy_get / zcopy_put ?
-- 
Jonathan

  reply	other threads:[~2021-01-05  4:25 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-12-30 19:12 [RFC PATCH v3 00/12] Generic zcopy_* functions Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 01/12] skbuff: remove unused skb_zcopy_abort function Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 02/12] skbuff: simplify sock_zerocopy_put Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 03/12] skbuff: Push status and refcounts into sock_zerocopy_callback Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 04/12] skbuff: replace sock_zerocopy_put() with skb_zcopy_put() Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 05/12] skbuff: replace sock_zerocopy_get with skb_zcopy_get Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 06/12] skbuff: Add skb parameter to the ubuf zerocopy callback Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 07/12] skbuff: Call sock_zerocopy_put_abort from skb_zcopy_put_abort Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 08/12] skbuff: Call skb_zcopy_clear() before unref'ing fragments Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 09/12] skbuff: rename sock_zerocopy_* to msg_zerocopy_* Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 10/12] net: group skb_shinfo zerocopy related bits together Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 11/12] skbuff: add flags to ubuf_info for ubuf setup Jonathan Lemon
2020-12-30 19:12 ` [RFC PATCH v3 12/12] tap/tun: add skb_zcopy_init() helper for initialization Jonathan Lemon
2021-01-04 17:39 ` [RFC PATCH v3 00/12] Generic zcopy_* functions Willem de Bruijn
2021-01-05  4:17   ` Jonathan Lemon [this message]
2021-01-05  4:22     ` Willem de Bruijn
2021-01-05  5:38       ` Jonathan Lemon

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210105041707.m574sk4ivjsxvtxi@bsd-mbp.dhcp.thefacebook.com \
    --to=jonathan.lemon@gmail.com \
    --cc=dsahern@gmail.com \
    --cc=edumazet@google.com \
    --cc=kernel-team@fb.com \
    --cc=netdev@vger.kernel.org \
    --cc=willemdebruijn.kernel@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).