netdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Dmitry Vyukov <dvyukov@google.com>
To: Alexander Lobakin <alobakin@pm.me>
Cc: Eric Dumazet <edumazet@google.com>,
	"David S. Miller" <davem@davemloft.net>,
	Jakub Kicinski <kuba@kernel.org>,
	Edward Cree <ecree.xilinx@gmail.com>,
	Jonathan Lemon <jonathan.lemon@gmail.com>,
	Willem de Bruijn <willemb@google.com>,
	Miaohe Lin <linmiaohe@huawei.com>,
	Steffen Klassert <steffen.klassert@secunet.com>,
	Guillaume Nault <gnault@redhat.com>,
	Yadu Kishore <kyk.segfault@gmail.com>,
	Al Viro <viro@zeniv.linux.org.uk>,
	netdev <netdev@vger.kernel.org>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 net-next 2/3] skbuff: (re)use NAPI skb cache on allocation path
Date: Thu, 14 Jan 2021 13:51:44 +0100	[thread overview]
Message-ID: <CACT4Y+Z2Nr_iRDeQArtdihtKOLE3Z4Cyz6h5rEbuQCZ6vihe3w@mail.gmail.com> (raw)
In-Reply-To: <CACT4Y+bcj_jBkUJhRMvo8kjB78WyoBtCH8+-L0tGkxuRpaO66Q@mail.gmail.com>

On Thu, Jan 14, 2021 at 1:50 PM Dmitry Vyukov <dvyukov@google.com> wrote:
>
> On Thu, Jan 14, 2021 at 1:44 PM Alexander Lobakin <alobakin@pm.me> wrote:
> >
> > From: Dmitry Vyukov <dvyukov@google.com>
> > Date: Thu, 14 Jan 2021 12:47:31 +0100
> >
> > > On Thu, Jan 14, 2021 at 12:41 PM Alexander Lobakin <alobakin@pm.me> wrote:
> > >>
> > >> From: Eric Dumazet <edumazet@google.com>
> > >> Date: Wed, 13 Jan 2021 15:36:05 +0100
> > >>
> > >>> On Wed, Jan 13, 2021 at 2:37 PM Alexander Lobakin <alobakin@pm.me> wrote:
> > >>>>
> > >>>> Instead of calling kmem_cache_alloc() every time when building a NAPI
> > >>>> skb, (re)use skbuff_heads from napi_alloc_cache.skb_cache. Previously
> > >>>> this cache was only used for bulk-freeing skbuff_heads consumed via
> > >>>> napi_consume_skb() or __kfree_skb_defer().
> > >>>>
> > >>>> Typical path is:
> > >>>>  - skb is queued for freeing from driver or stack, its skbuff_head
> > >>>>    goes into the cache instead of immediate freeing;
> > >>>>  - driver or stack requests NAPI skb allocation, an skbuff_head is
> > >>>>    taken from the cache instead of allocation.
> > >>>>
> > >>>> Corner cases:
> > >>>>  - if it's empty on skb allocation, bulk-allocate the first half;
> > >>>>  - if it's full on skb consuming, bulk-wipe the second half.
> > >>>>
> > >>>> Also try to balance its size after completing network softirqs
> > >>>> (__kfree_skb_flush()).
> > >>>
> > >>> I do not see the point of doing this rebalance (especially if we do not change
> > >>> its name describing its purpose more accurately).
> > >>>
> > >>> For moderate load, we will have a reduced bulk size (typically one or two).
> > >>> Number of skbs in the cache is in [0, 64[ , there is really no risk of
> > >>> letting skbs there for a long period of time.
> > >>> (32 * sizeof(sk_buff) = 8192)
> > >>> I would personally get rid of this function completely.
> > >>
> > >> When I had a cache of 128 entries, I had worse results without this
> > >> function. But seems like I forgot to retest when I switched to the
> > >> original size of 64.
> > >> I also thought about removing this function entirely, will test.
> > >>
> > >>> Also it seems you missed my KASAN support request ?
> > >>  I guess this is a matter of using kasan_unpoison_range(), we can ask for help.
> > >>
> > >> I saw your request, but don't see a reason for doing this.
> > >> We are not caching already freed skbuff_heads. They don't get
> > >> kmem_cache_freed before getting into local cache. KASAN poisons
> > >> them no earlier than at kmem_cache_free() (or did I miss someting?).
> > >> heads being cached just get rid of all references and at the moment
> > >> of dropping to the cache they are pretty the same as if they were
> > >> allocated.
> > >
> > > KASAN should not report false positives in this case.
> > > But I think Eric meant preventing false negatives. If we kmalloc 17
> > > bytes, KASAN will detect out-of-bounds accesses beyond these 17 bytes.
> > > But we put that data into 128-byte blocks, KASAN will miss
> > > out-of-bounds accesses beyond 17 bytes up to 128 bytes.
> > > The same holds for "logical" use-after-frees when object is free, but
> > > not freed into slab.
> > >
> > > An important custom cache should use annotations like
> > > kasan_poison_object_data/kasan_unpoison_range.
> >
> > As I understand, I should
> > kasan_poison_object_data(skbuff_head_cache, skb) and then
> > kasan_unpoison_range(skb, sizeof(*skb)) when putting it into the
> > cache?
>
> I think it's the other way around. It should be _un_poisoned when used.
> If it's fixed size, then unpoison_object_data should be a better fit:
> https://elixir.bootlin.com/linux/v5.11-rc3/source/mm/kasan/common.c#L253

Variable-size poisoning/unpoisoning would be needed for the skb data itself:
https://bugzilla.kernel.org/show_bug.cgi?id=199055

  reply	other threads:[~2021-01-14 12:53 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-01-13 13:35 [PATCH v2 net-next 0/3] skbuff: introduce skbuff_heads reusing and bulking Alexander Lobakin
2021-01-13 13:36 ` [PATCH v2 net-next 1/3] skbuff: open-code __build_skb() inside __napi_alloc_skb() Alexander Lobakin
2021-01-13 13:37   ` [PATCH v2 net-next 2/3] skbuff: (re)use NAPI skb cache on allocation path Alexander Lobakin
2021-01-13 14:36     ` Eric Dumazet
2021-01-14 11:41       ` Alexander Lobakin
2021-01-14 11:47         ` Dmitry Vyukov
2021-01-14 12:44           ` Alexander Lobakin
2021-01-14 12:50             ` Dmitry Vyukov
2021-01-14 12:51               ` Dmitry Vyukov [this message]
2021-01-14 13:06                 ` Alexander Lobakin
2021-01-14 13:00               ` Alexander Lobakin
2021-01-14 13:01                 ` Dmitry Vyukov
2021-01-13 13:37   ` [PATCH v2 net-next 3/3] skbuff: recycle GRO_MERGED_FREE skbs into NAPI skb cache Alexander Lobakin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CACT4Y+Z2Nr_iRDeQArtdihtKOLE3Z4Cyz6h5rEbuQCZ6vihe3w@mail.gmail.com \
    --to=dvyukov@google.com \
    --cc=alobakin@pm.me \
    --cc=davem@davemloft.net \
    --cc=ecree.xilinx@gmail.com \
    --cc=edumazet@google.com \
    --cc=gnault@redhat.com \
    --cc=jonathan.lemon@gmail.com \
    --cc=kuba@kernel.org \
    --cc=kyk.segfault@gmail.com \
    --cc=linmiaohe@huawei.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=steffen.klassert@secunet.com \
    --cc=viro@zeniv.linux.org.uk \
    --cc=willemb@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).