netfilter-devel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 1116/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 12:17 Baole Ni
  2016-08-02 18:07 ` Jan Engelhardt
  0 siblings, 1 reply; 3+ messages in thread
From: Baole Ni @ 2016-08-02 12:17 UTC (permalink / raw)
  To: wensong, horms, ja, pablo, kaber, kadlec, davem, m.szyprowski,
	kyungmin.park, k.kozlowski
  Cc: netdev, lvs-devel, netfilter-devel, coreteam, linux-kernel,
	chuansheng.liu, baolex.ni, aryabinin

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 net/netfilter/ipvs/ip_vs_conn.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/net/netfilter/ipvs/ip_vs_conn.c b/net/netfilter/ipvs/ip_vs_conn.c
index 096a451..6a88389 100644
--- a/net/netfilter/ipvs/ip_vs_conn.c
+++ b/net/netfilter/ipvs/ip_vs_conn.c
@@ -50,7 +50,7 @@
  * Connection hash size. Default is what was selected at compile time.
 */
 static int ip_vs_conn_tab_bits = CONFIG_IP_VS_TAB_BITS;
-module_param_named(conn_tab_bits, ip_vs_conn_tab_bits, int, 0444);
+module_param_named(conn_tab_bits, ip_vs_conn_tab_bits, int, S_IRUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(conn_tab_bits, "Set connections' hash size");
 
 /* size and mask values */
-- 
2.9.2

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH 1116/1285] Replace numeric parameter like 0444 with macro
  2016-08-02 12:17 [PATCH 1116/1285] Replace numeric parameter like 0444 with macro Baole Ni
@ 2016-08-02 18:07 ` Jan Engelhardt
  2016-08-02 19:13   ` Jarod Wilson
  0 siblings, 1 reply; 3+ messages in thread
From: Jan Engelhardt @ 2016-08-02 18:07 UTC (permalink / raw)
  To: Baole Ni
  Cc: Linux Networking Developer Mailing List, lvs-devel,
	Netfilter Developer Mailing List, Linux Kernel Mailing List,
	chuansheng.liu


On Tuesday 2016-08-02 14:17, Baole Ni wrote:

>I find that the developers often just specified the numeric value
>when calling a macro which is defined with a parameter for access permission.
>As we know, these numeric value for access permission have had the corresponding macro,
>and that using macro can improve the robustness and readability of the code,
>thus, I suggest replacing the numeric parameter with the macro.
>
> static int ip_vs_conn_tab_bits = CONFIG_IP_VS_TAB_BITS;
>-module_param_named(conn_tab_bits, ip_vs_conn_tab_bits, int, 0444);
>+module_param_named(conn_tab_bits, ip_vs_conn_tab_bits, int, S_IRUSR | S_IRGRP | S_IROTH);

We have S_IRUGO for this.

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH 1116/1285] Replace numeric parameter like 0444 with macro
  2016-08-02 18:07 ` Jan Engelhardt
@ 2016-08-02 19:13   ` Jarod Wilson
  0 siblings, 0 replies; 3+ messages in thread
From: Jarod Wilson @ 2016-08-02 19:13 UTC (permalink / raw)
  To: Jan Engelhardt
  Cc: Baole Ni, Linux Networking Developer Mailing List, lvs-devel,
	Netfilter Developer Mailing List, Linux Kernel Mailing List,
	chuansheng.liu

On Tue, Aug 02, 2016 at 08:07:11PM +0200, Jan Engelhardt wrote:
> 
> On Tuesday 2016-08-02 14:17, Baole Ni wrote:
> 
> >I find that the developers often just specified the numeric value
> >when calling a macro which is defined with a parameter for access permission.
> >As we know, these numeric value for access permission have had the corresponding macro,
> >and that using macro can improve the robustness and readability of the code,
> >thus, I suggest replacing the numeric parameter with the macro.
> >
> > static int ip_vs_conn_tab_bits = CONFIG_IP_VS_TAB_BITS;
> >-module_param_named(conn_tab_bits, ip_vs_conn_tab_bits, int, 0444);
> >+module_param_named(conn_tab_bits, ip_vs_conn_tab_bits, int, S_IRUSR | S_IRGRP | S_IROTH);
> 
> We have S_IRUGO for this.

Aye, for further edification, Baole, please read include/linux/stat.h,
particularly this part:

#define S_IRWXUGO       (S_IRWXU|S_IRWXG|S_IRWXO)
#define S_IALLUGO       (S_ISUID|S_ISGID|S_ISVTX|S_IRWXUGO)
#define S_IRUGO         (S_IRUSR|S_IRGRP|S_IROTH)
#define S_IWUGO         (S_IWUSR|S_IWGRP|S_IWOTH)
#define S_IXUGO         (S_IXUSR|S_IXGRP|S_IXOTH)

I suspect many of the patches in this set should be using one of the above
defines instead, never mind the ridiculousness of firing off such a
massive set at once, with every patch having the same (often not correct)
title, and the highly questionable benefit of the set to begin with.

-- 
Jarod Wilson
jarod@redhat.com

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2016-08-02 19:13 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 12:17 [PATCH 1116/1285] Replace numeric parameter like 0444 with macro Baole Ni
2016-08-02 18:07 ` Jan Engelhardt
2016-08-02 19:13   ` Jarod Wilson

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).