nouveau.lists.freedesktop.org archive mirror
 help / color / mirror / Atom feed
From: Jason Gunthorpe <jgg@nvidia.com>
To: Alistair Popple <apopple@nvidia.com>
Cc: rcampbell@nvidia.com, willy@infradead.org,
	linux-doc@vger.kernel.org, nouveau@lists.freedesktop.org,
	dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
	kvm-ppc@vger.kernel.org, hch@infradead.org, linux-mm@kvack.org,
	bskeggs@redhat.com, daniel@ffwll.ch, akpm@linux-foundation.org,
	Christoph Hellwig <hch@lst.de>
Subject: Re: [Nouveau] [PATCH v7 3/8] mm/rmap: Split try_to_munlock from try_to_unmap
Date: Tue, 30 Mar 2021 19:24:40 -0300	[thread overview]
Message-ID: <20210330222440.GC2356281@nvidia.com> (raw)
In-Reply-To: <12442194.rtmf8Ope3M@nvdebian>

On Wed, Mar 31, 2021 at 09:09:30AM +1100, Alistair Popple wrote:

> > > @@ -1796,8 +1821,7 @@ bool try_to_unmap(struct page *page, enum ttu_flags 
> flags)
> > >  void try_to_munlock(struct page *page)
> > >  {
> > 
> > But this is also called try_to_munlock ??
> 
> As far as I can tell this has always been called try_to_munlock() even though 
> it appears to do the opposite.

Maybe we should change it then?

> > /**
> >  * try_to_munlock - try to munlock a page
> >  * @page: the page to be munlocked
> >  *
> >  * Called from munlock code.  Checks all of the VMAs mapping the page
> >  * to make sure nobody else has this page mlocked. The page will be
> >  * returned with PG_mlocked cleared if no other vmas have it mlocked.
> >  */
> 
> In other words it sets PG_mlocked if one or more vmas has it mlocked. So
> try_to_mlock() might be a better name, except that seems to have the potential 
> for confusion as well because it's only called from the munlock code path and 
> never for mlock.

That explanation makes more sense.. This function looks like it is
'set PG_mlocked of the page if any vm->flags has VM_LOCKED'

Maybe call it check_vm_locked or something then and reword the above
comment?

(and why is it OK to read vm->flags for this without any locking?)

> > Something needs attention here..
> 
> I think the code is correct, but perhaps the naming could be better. Would be 
> interested hearing any thoughts on renaming try_to_munlock() to try_to_mlock() 
> as the current name appears based on the context it is called from (munlock) 
> rather than what it does (mlock).

The point of this patch is to make it clearer, after all, so I'd
change something and maybe slightly clarify the comment.

Jason
_______________________________________________
Nouveau mailing list
Nouveau@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/nouveau

  parent reply	other threads:[~2021-03-30 22:24 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-03-26  0:07 [Nouveau] [PATCH v7 0/8] Add support for SVM atomics in Nouveau Alistair Popple
2021-03-26  0:07 ` [Nouveau] [PATCH v7 1/8] mm: Remove special swap entry functions Alistair Popple
2021-03-30 18:38   ` Jason Gunthorpe
2021-03-26  0:07 ` [Nouveau] [PATCH v7 2/8] mm/swapops: Rework swap entry manipulation code Alistair Popple
2021-03-26  0:08 ` [Nouveau] [PATCH v7 3/8] mm/rmap: Split try_to_munlock from try_to_unmap Alistair Popple
2021-03-30 18:49   ` Jason Gunthorpe
2021-03-30 22:09     ` Alistair Popple
2021-03-30 22:16       ` Alistair Popple
2021-03-30 22:24       ` Jason Gunthorpe [this message]
2021-03-30 22:43         ` John Hubbard
2021-03-30 22:56           ` Alistair Popple
2021-03-31  3:56             ` John Hubbard
2021-03-31  4:09               ` John Hubbard
2021-03-31  4:15               ` Alistair Popple
2021-03-31 11:57                 ` Jason Gunthorpe
2021-04-01  4:36                   ` Alistair Popple
2021-04-01 19:21                     ` Shakeel Butt
2021-03-26  0:08 ` [Nouveau] [PATCH v7 4/8] mm/rmap: Split migration into its own function Alistair Popple
2021-03-26  0:08 ` [Nouveau] [PATCH v7 5/8] mm: Device exclusive memory access Alistair Popple
2021-03-30 19:32   ` Jason Gunthorpe
2021-03-31 12:59     ` Alistair Popple
2021-03-31 13:18       ` Jason Gunthorpe
2021-03-31 13:27         ` Alistair Popple
2021-03-31 13:46           ` Jason Gunthorpe
2021-04-01  0:45             ` Alistair Popple
2021-04-01  0:48               ` Jason Gunthorpe
2021-04-01  2:20                 ` Alistair Popple
2021-04-01 11:55                   ` Jason Gunthorpe
2021-03-26  0:08 ` [Nouveau] [PATCH v7 6/8] mm: Selftests for exclusive device memory Alistair Popple
2021-03-26  0:08 ` [Nouveau] [PATCH v7 7/8] nouveau/svm: Refactor nouveau_range_fault Alistair Popple
2021-03-26  0:08 ` [Nouveau] [PATCH v7 8/8] nouveau/svm: Implement atomic SVM access Alistair Popple

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210330222440.GC2356281@nvidia.com \
    --to=jgg@nvidia.com \
    --cc=akpm@linux-foundation.org \
    --cc=apopple@nvidia.com \
    --cc=bskeggs@redhat.com \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=hch@infradead.org \
    --cc=hch@lst.de \
    --cc=kvm-ppc@vger.kernel.org \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=nouveau@lists.freedesktop.org \
    --cc=rcampbell@nvidia.com \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).