nvdimm.lists.linux.dev archive mirror
 help / color / mirror / Atom feed
From: Dan Williams <dan.j.williams@intel.com>
To: Dave Jiang <dave.jiang@intel.com>
Cc: linux-nvdimm <linux-nvdimm@lists.01.org>
Subject: Re: [PATCH v2 1/2] ndctl: convert namespace actions to use util_filter_params
Date: Tue, 24 Apr 2018 18:42:36 -0700	[thread overview]
Message-ID: <CAPcyv4iu6SHB3jEYFqMaFXt4S-=4Zpc7FKpqV61X2jNdjPGF9A@mail.gmail.com> (raw)
In-Reply-To: <152461031638.17395.12751766602088283269.stgit@djiang5-desk3.ch.intel.com>

On Tue, Apr 24, 2018 at 3:52 PM, Dave Jiang <dave.jiang@intel.com> wrote:
> In preparation of moving to using util_filter_walk, moving parts of namespace
> params to util_filter_params.
>
> Signed-off-by: Dave Jiang <dave.jiang@intel.com>
> ---
>  ndctl/namespace.c |  165 ++++++++++++++++++++++++++---------------------------
>  1 file changed, 82 insertions(+), 83 deletions(-)
>
> diff --git a/ndctl/namespace.c b/ndctl/namespace.c
> index fe86d826..e7173ce9 100644
> --- a/ndctl/namespace.c
> +++ b/ndctl/namespace.c
> @@ -40,21 +40,20 @@ static struct parameters {
>         bool mode_default;
>         bool align_default;
>         bool autolabel;
> -       const char *bus;
>         const char *map;
> -       const char *type;
>         const char *uuid;
>         const char *name;
>         const char *size;
>         const char *mode;
> -       const char *region;
>         const char *reconfig;
>         const char *sector_size;
>         const char *align;
> -} param = {
> +} ndns_action = {
>         .autolabel = true,
>  };
>
> +struct util_filter_params param;

Lets cut down on the thrash in this patch by calling this something
other than 'param'. I.e. all the parameters that are not being
converted to util_filter_params should not need to be touched.
_______________________________________________
Linux-nvdimm mailing list
Linux-nvdimm@lists.01.org
https://lists.01.org/mailman/listinfo/linux-nvdimm

      parent reply	other threads:[~2018-04-25  1:42 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-24 22:52 [PATCH v2 1/2] ndctl: convert namespace actions to use util_filter_params Dave Jiang
2018-04-24 22:53 ` [PATCH v2 2/2] ndctl: convert namespace actions to use util_filter_walk() Dave Jiang
2018-04-25  1:42 ` Dan Williams [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAPcyv4iu6SHB3jEYFqMaFXt4S-=4Zpc7FKpqV61X2jNdjPGF9A@mail.gmail.com' \
    --to=dan.j.williams@intel.com \
    --cc=dave.jiang@intel.com \
    --cc=linux-nvdimm@lists.01.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).