nvdimm.lists.linux.dev archive mirror
 help / color / mirror / Atom feed
* [PATCH v2] ACPI: nfit: remove redundant assignment if nfit_mem found
@ 2018-08-02  8:44 oceanhehy
  2018-08-10 23:45 ` Verma, Vishal L
  0 siblings, 1 reply; 3+ messages in thread
From: oceanhehy @ 2018-08-02  8:44 UTC (permalink / raw)
  To: dan.j.williams, ross.zwisler, vishal.l.verma, dave.jiang, rjw, lenb
  Cc: linux-acpi, Ocean He, linux-kernel, linux-nvdimm

From: Ocean He <hehy1@lenovo.com>

When nfit_mem is found via list_for_each_entry, it has already been
assigned valid value. There is no need to assign it again in the following
codes.

Signed-off-by: Ocean He <hehy1@lenovo.com>
---
v1: https://patchwork.kernel.org/patch/10553277/
v2: Sorry for noise. I got an email problem, so I have to resend to loop 
linux-nvdimm@lists.01.org.

 drivers/acpi/nfit/core.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/drivers/acpi/nfit/core.c b/drivers/acpi/nfit/core.c
index 7c47900..85dde54 100644
--- a/drivers/acpi/nfit/core.c
+++ b/drivers/acpi/nfit/core.c
@@ -1048,9 +1048,7 @@ static int __nfit_mem_init(struct acpi_nfit_desc *acpi_desc,
 				break;
 			}
 
-		if (found)
-			nfit_mem = found;
-		else {
+		if (!found) {
 			nfit_mem = devm_kzalloc(acpi_desc->dev,
 					sizeof(*nfit_mem), GFP_KERNEL);
 			if (!nfit_mem)
-- 
1.8.3.1

_______________________________________________
Linux-nvdimm mailing list
Linux-nvdimm@lists.01.org
https://lists.01.org/mailman/listinfo/linux-nvdimm

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH v2] ACPI: nfit: remove redundant assignment if nfit_mem found
  2018-08-02  8:44 [PATCH v2] ACPI: nfit: remove redundant assignment if nfit_mem found oceanhehy
@ 2018-08-10 23:45 ` Verma, Vishal L
  2018-08-13  2:53   ` [External] " Ocean HY1 He
  0 siblings, 1 reply; 3+ messages in thread
From: Verma, Vishal L @ 2018-08-10 23:45 UTC (permalink / raw)
  To: Williams, Dan J, ross.zwisler, oceanhehy, Jiang, Dave, lenb, rjw
  Cc: linux-acpi, hehy1, linux-kernel, linux-nvdimm


On Thu, 2018-08-02 at 04:44 -0400, oceanhehy@gmail.com wrote:
> From: Ocean He <hehy1@lenovo.com>
> 
> When nfit_mem is found via list_for_each_entry, it has already been
> assigned valid value. There is no need to assign it again in the
> following
> codes.
> 
> Signed-off-by: Ocean He <hehy1@lenovo.com>
> ---
> v1: https://patchwork.kernel.org/patch/10553277/
> v2: Sorry for noise. I got an email problem, so I have to resend to
> loop 
> linux-nvdimm@lists.01.org.
> 
>  drivers/acpi/nfit/core.c | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/drivers/acpi/nfit/core.c b/drivers/acpi/nfit/core.c
> index 7c47900..85dde54 100644
> --- a/drivers/acpi/nfit/core.c
> +++ b/drivers/acpi/nfit/core.c
> @@ -1048,9 +1048,7 @@ static int __nfit_mem_init(struct
> acpi_nfit_desc *acpi_desc,
>  				break;
>  			}
>  
> -		if (found)
> -			nfit_mem = found;
> -		else {
> +		if (!found) {

Hi Ocean,

While this is technically correct, the old way was easier to read. We
loop through and find the matching handle. If we found one, then
nfit_mem was whatever was found. If not, we allocate it.

With this change, one has to go grok the list_for_.. loop to figure out
where nfit_mem is coming from. I'd personally prefer to keep the
existing way..

>  			nfit_mem = devm_kzalloc(acpi_desc->dev,
>  					sizeof(*nfit_mem),
> GFP_KERNEL);
>  			if (!nfit_mem)
_______________________________________________
Linux-nvdimm mailing list
Linux-nvdimm@lists.01.org
https://lists.01.org/mailman/listinfo/linux-nvdimm

^ permalink raw reply	[flat|nested] 3+ messages in thread

* RE: [External]  Re: [PATCH v2] ACPI: nfit: remove redundant assignment if nfit_mem found
  2018-08-10 23:45 ` Verma, Vishal L
@ 2018-08-13  2:53   ` Ocean HY1 He
  0 siblings, 0 replies; 3+ messages in thread
From: Ocean HY1 He @ 2018-08-13  2:53 UTC (permalink / raw)
  To: Verma, Vishal L, Williams, Dan J, ross.zwisler, oceanhehy, Jiang,
	Dave, lenb, rjw
  Cc: linux-acpi, linux-kernel, linux-nvdimm



> -----Original Message-----
> From: Verma, Vishal L <vishal.l.verma@intel.com>
> Sent: Saturday, August 11, 2018 7:46 AM
> To: Williams, Dan J <dan.j.williams@intel.com>; ross.zwisler@linux.intel.com;
> oceanhehy@gmail.com; Jiang, Dave <dave.jiang@intel.com>; lenb@kernel.org;
> rjw@rjwysocki.net
> Cc: linux-kernel@vger.kernel.org; linux-nvdimm@lists.01.org; linux-
> acpi@vger.kernel.org; Ocean HY1 He <hehy1@lenovo.com>
> Subject: [External] Re: [PATCH v2] ACPI: nfit: remove redundant assignment if
> nfit_mem found
> 
> 
> On Thu, 2018-08-02 at 04:44 -0400, oceanhehy@gmail.com wrote:
> > From: Ocean He <hehy1@lenovo.com>
> >
> > When nfit_mem is found via list_for_each_entry, it has already been
> > assigned valid value. There is no need to assign it again in the
> > following
> > codes.
> >
> > Signed-off-by: Ocean He <hehy1@lenovo.com>
> > ---
> > v1: https://patchwork.kernel.org/patch/10553277/
> > v2: Sorry for noise. I got an email problem, so I have to resend to
> > loop
> > linux-nvdimm@lists.01.org.
> >
> >  drivers/acpi/nfit/core.c | 4 +---
> >  1 file changed, 1 insertion(+), 3 deletions(-)
> >
> > diff --git a/drivers/acpi/nfit/core.c b/drivers/acpi/nfit/core.c
> > index 7c47900..85dde54 100644
> > --- a/drivers/acpi/nfit/core.c
> > +++ b/drivers/acpi/nfit/core.c
> > @@ -1048,9 +1048,7 @@ static int __nfit_mem_init(struct
> > acpi_nfit_desc *acpi_desc,
> >  				break;
> >  			}
> >
> > -		if (found)
> > -			nfit_mem = found;
> > -		else {
> > +		if (!found) {
> 
> Hi Ocean,
> 
> While this is technically correct, the old way was easier to read. We
> loop through and find the matching handle. If we found one, then
> nfit_mem was whatever was found. If not, we allocate it.
> 
> With this change, one has to go grok the list_for_.. loop to figure out
> where nfit_mem is coming from. I'd personally prefer to keep the
> existing way..
> 
Hi Verma,

You're right that it took me some time to find out where nfit_mem
was found, when I look these codes at first.

It's reasonable to keep the existing way for well readability.

Thanks,
Ocean.
> >  			nfit_mem = devm_kzalloc(acpi_desc->dev,
> >  					sizeof(*nfit_mem),
> > GFP_KERNEL);
> >  			if (!nfit_mem)
_______________________________________________
Linux-nvdimm mailing list
Linux-nvdimm@lists.01.org
https://lists.01.org/mailman/listinfo/linux-nvdimm

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2018-08-13  2:53 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-08-02  8:44 [PATCH v2] ACPI: nfit: remove redundant assignment if nfit_mem found oceanhehy
2018-08-10 23:45 ` Verma, Vishal L
2018-08-13  2:53   ` [External] " Ocean HY1 He

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).