nvdimm.lists.linux.dev archive mirror
 help / color / mirror / Atom feed
From: Joao Martins <joao.m.martins@oracle.com>
To: Christoph Hellwig <hch@lst.de>
Cc: linux-mm@kvack.org, Andrew Morton <akpm@linux-foundation.org>,
	Dan Williams <dan.j.williams@intel.com>,
	Vishal Verma <vishal.l.verma@intel.com>,
	Dave Jiang <dave.jiang@intel.com>,
	Naoya Horiguchi <naoya.horiguchi@nec.com>,
	Matthew Wilcox <willy@infradead.org>,
	Jason Gunthorpe <jgg@ziepe.ca>,
	John Hubbard <jhubbard@nvidia.com>,
	Jane Chu <jane.chu@oracle.com>,
	Muchun Song <songmuchun@bytedance.com>,
	Mike Kravetz <mike.kravetz@oracle.com>,
	Jonathan Corbet <corbet@lwn.net>,
	nvdimm@lists.linux.dev, linux-doc@vger.kernel.org
Subject: Re: [PATCH v6 09/10] device-dax: set mapping prior to vmf_insert_pfn{,_pmd,pud}()
Date: Mon, 29 Nov 2021 15:49:46 +0000	[thread overview]
Message-ID: <b8056071-d0fe-b8ef-5fe3-85ab639f4bf7@oracle.com> (raw)
In-Reply-To: <20211129073235.GA23843@lst.de>

On 11/29/21 07:32, Christoph Hellwig wrote:
> On Fri, Nov 26, 2021 at 06:39:39PM +0000, Joao Martins wrote:
>> @@ -230,23 +235,18 @@ static vm_fault_t dev_dax_huge_fault(struct vm_fault *vmf,
>>  	id = dax_read_lock();
>>  	switch (pe_size) {
>>  	case PE_SIZE_PTE:
>> -		fault_size = PAGE_SIZE;
>>  		rc = __dev_dax_pte_fault(dev_dax, vmf, &pfn);
>>  		break;
>>  	case PE_SIZE_PMD:
>> -		fault_size = PMD_SIZE;
>>  		rc = __dev_dax_pmd_fault(dev_dax, vmf, &pfn);
>>  		break;
>>  	case PE_SIZE_PUD:
>> -		fault_size = PUD_SIZE;
>>  		rc = __dev_dax_pud_fault(dev_dax, vmf, &pfn);
>>  		break;
>>  	default:
>>  		rc = VM_FAULT_SIGBUS;
>>  	}
>>
>>  	dax_read_unlock(id);
> 
> I wonder if if would make sense to move dax_read_lock / dax_read_unlock
> іnto the individul helpers as well now.  That way you could directly
> return from the switch. 

Hmmm -- if by individual helpers moving to __dev_dax_{pte,pmd,pud}_fault()
it would be slightly less straighforward. Unless you might mean to move
to check_vma() (around the dax_alive() check) and that might actually
remove the opencoding of dax_read_lock in dax_mmap() even.

I would rather prefer that this cleanup around dax_read_{un,}lock is
a separate patch separate to this series, unless you feel strongly that
it needs to be part of this set.

> Aso it seems like pfn is only an input
> parameter now and doesn't need to be passed by reference.
> 
It's actually just an output parameter (that dax_set_mapping would then use).

The fault handlers in device-dax use vmf->address to calculate pfn that they
insert in the page table entry. After this patch we can actually just remove
@pfn argument.

	Joao

  reply	other threads:[~2021-11-29 15:50 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-11-24 19:09 [PATCH v6 00/10] mm, device-dax: Introduce compound pages in devmap Joao Martins
2021-11-24 19:09 ` [PATCH v6 01/10] memory-failure: fetch compound_head after pgmap_pfn_valid() Joao Martins
2021-11-24 19:09 ` [PATCH v6 02/10] mm/page_alloc: split prep_compound_page into head and tail subparts Joao Martins
2021-11-24 19:09 ` [PATCH v6 03/10] mm/page_alloc: refactor memmap_init_zone_device() page init Joao Martins
2021-11-24 19:09 ` [PATCH v6 04/10] mm/memremap: add ZONE_DEVICE support for compound pages Joao Martins
2021-11-25  6:11   ` Christoph Hellwig
2021-11-25 11:35     ` Joao Martins
2021-11-24 19:10 ` [PATCH v6 05/10] device-dax: use ALIGN() for determining pgoff Joao Martins
2021-11-24 19:10 ` [PATCH v6 06/10] device-dax: use struct_size() Joao Martins
2021-11-24 19:10 ` [PATCH v6 07/10] device-dax: ensure dev_dax->pgmap is valid for dynamic devices Joao Martins
2021-11-24 19:10 ` [PATCH v6 08/10] device-dax: factor out page mapping initialization Joao Martins
2021-11-24 19:10 ` [PATCH v6 09/10] device-dax: set mapping prior to vmf_insert_pfn{,_pmd,pud}() Joao Martins
2021-11-25 11:42   ` Joao Martins
2021-11-26 18:39     ` Joao Martins
2021-11-29  7:32       ` Christoph Hellwig
2021-11-29 15:49         ` Joao Martins [this message]
2021-11-29 16:48           ` Christoph Hellwig
2021-11-29 17:20           ` Joao Martins
2021-11-24 19:10 ` [PATCH v6 10/10] device-dax: compound devmap support Joao Martins
2021-11-24 22:30 ` [PATCH v6 00/10] mm, device-dax: Introduce compound pages in devmap Dan Williams
2021-11-24 22:41   ` Andrew Morton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b8056071-d0fe-b8ef-5fe3-85ab639f4bf7@oracle.com \
    --to=joao.m.martins@oracle.com \
    --cc=akpm@linux-foundation.org \
    --cc=corbet@lwn.net \
    --cc=dan.j.williams@intel.com \
    --cc=dave.jiang@intel.com \
    --cc=hch@lst.de \
    --cc=jane.chu@oracle.com \
    --cc=jgg@ziepe.ca \
    --cc=jhubbard@nvidia.com \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mike.kravetz@oracle.com \
    --cc=naoya.horiguchi@nec.com \
    --cc=nvdimm@lists.linux.dev \
    --cc=songmuchun@bytedance.com \
    --cc=vishal.l.verma@intel.com \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).