[drm/hisilicon,v2,0/3] hibmc clean up and code refactoring
mbox series

Message ID 1596415114-21175-1-git-send-email-tiantao6@hisilicon.com
Headers show
Series
  • hibmc clean up and code refactoring
Related show

Message

Tian Tao Aug. 3, 2020, 12:38 a.m. UTC
patch #1 and #3 is clean up, patch #2 is for code refactoring

Changes since v1:
- Rewrite the commits messages and patch name in #1
- Rewrite the commits message in #2.
- Add the new patch #3

Tian Tao (3):
  drm/hisilicon: Remove the unused include statements
  drm/hisilicon: Code refactoring for hibmc_drv_de
  drm/hisilicon: Rename variables to represent the correct meaning

 drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_de.c   | 58 ++++++------------------
 drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_drv.c  |  5 --
 drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_drv.h  |  2 +
 drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_vdac.c |  2 -
 4 files changed, 15 insertions(+), 52 deletions(-)

Comments

Thomas Zimmermann Aug. 12, 2020, 7:04 a.m. UTC | #1
Hi

Am 03.08.20 um 02:38 schrieb Tian Tao:
> patch #1 and #3 is clean up, patch #2 is for code refactoring

Sorry for all my reviews taking so long. Please merge patch #3 into
patch #2 and then the series is

Reviewed-by: Thomas Zimmermann <tzimmermann@suse.de>

I noticed that hibmc use DRM_ERROR in several places. A good follow-up
patchset would be the conversion to drm_info/drm_warn/drm_error/etc.

Best regards
Thomas

> 
> Changes since v1:
> - Rewrite the commits messages and patch name in #1
> - Rewrite the commits message in #2.
> - Add the new patch #3
> 
> Tian Tao (3):
>   drm/hisilicon: Remove the unused include statements
>   drm/hisilicon: Code refactoring for hibmc_drv_de
>   drm/hisilicon: Rename variables to represent the correct meaning
> 
>  drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_de.c   | 58 ++++++------------------
>  drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_drv.c  |  5 --
>  drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_drv.h  |  2 +
>  drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_vdac.c |  2 -
>  4 files changed, 15 insertions(+), 52 deletions(-)
>
tiantao (H) Aug. 12, 2020, 7:12 a.m. UTC | #2
在 2020/8/12 15:04, Thomas Zimmermann 写道:
> Hi
> 
> Am 03.08.20 um 02:38 schrieb Tian Tao:
>> patch #1 and #3 is clean up, patch #2 is for code refactoring
> 
> Sorry for all my reviews taking so long. Please merge patch #3 into
> patch #2 and then the series is
> 
thanks,I will send v3 to fix this.
> Reviewed-by: Thomas Zimmermann <tzimmermann@suse.de>
> 
> I noticed that hibmc use DRM_ERROR in several places. A good follow-up
> patchset would be the conversion to drm_info/drm_warn/drm_error/etc.
> 
I will send another patchset to fix this.
> Best regards
> Thomas
> 
>>
>> Changes since v1:
>> - Rewrite the commits messages and patch name in #1
>> - Rewrite the commits message in #2.
>> - Add the new patch #3
>>
>> Tian Tao (3):
>>    drm/hisilicon: Remove the unused include statements
>>    drm/hisilicon: Code refactoring for hibmc_drv_de
>>    drm/hisilicon: Rename variables to represent the correct meaning
>>
>>   drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_de.c   | 58 ++++++------------------
>>   drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_drv.c  |  5 --
>>   drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_drv.h  |  2 +
>>   drivers/gpu/drm/hisilicon/hibmc/hibmc_drm_vdac.c |  2 -
>>   4 files changed, 15 insertions(+), 52 deletions(-)
>>
>