[next] scsi: megaraid_sas: fix spelling mistake "megarid_sas" -> "megaraid_sas"
diff mbox series

Message ID 20190720215840.23831-1-colin.king@canonical.com
State Accepted
Commit 359603a3847e58843881db87e5f464bb85539e95
Headers show
Series
  • [next] scsi: megaraid_sas: fix spelling mistake "megarid_sas" -> "megaraid_sas"
Related show

Commit Message

Colin King July 20, 2019, 9:58 p.m. UTC
From: Colin Ian King <colin.king@canonical.com>

Fix spelling mistake in kernel warning message and replace
printk with with pr_warn.

Signed-off-by: Colin Ian King <colin.king@canonical.com>
---
 drivers/scsi/megaraid/megaraid_sas_base.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Sumit Saxena July 23, 2019, 6:17 p.m. UTC | #1
On Sun, Jul 21, 2019 at 3:28 AM Colin King <colin.king@canonical.com> wrote:
>
> From: Colin Ian King <colin.king@canonical.com>
>
> Fix spelling mistake in kernel warning message and replace
> printk with with pr_warn.
>
> Signed-off-by: Colin Ian King <colin.king@canonical.com>
Acked-by: Sumit Saxena <sumit.saxena@broadcom.com>
> ---
>  drivers/scsi/megaraid/megaraid_sas_base.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/scsi/megaraid/megaraid_sas_base.c b/drivers/scsi/megaraid/megaraid_sas_base.c
> index b2339d04a700..2590746c81e3 100644
> --- a/drivers/scsi/megaraid/megaraid_sas_base.c
> +++ b/drivers/scsi/megaraid/megaraid_sas_base.c
> @@ -8763,7 +8763,7 @@ static int __init megasas_init(void)
>
>         if ((event_log_level < MFI_EVT_CLASS_DEBUG) ||
>             (event_log_level > MFI_EVT_CLASS_DEAD)) {
> -               printk(KERN_WARNING "megarid_sas: provided event log level is out of range, setting it to default 2(CLASS_CRITICAL), permissible range is: -2 to 4\n");
> +               pr_warn("megaraid_sas: provided event log level is out of range, setting it to default 2(CLASS_CRITICAL), permissible range is: -2 to 4\n");
>                 event_log_level = MFI_EVT_CLASS_CRITICAL;
>         }
>
> --
> 2.20.1
>
Martin K. Petersen July 24, 2019, 2:16 a.m. UTC | #2
Colin,

> Fix spelling mistake in kernel warning message and replace printk with
> with pr_warn.

Applied to 5.3/scsi-fixes, thanks!

Patch
diff mbox series

diff --git a/drivers/scsi/megaraid/megaraid_sas_base.c b/drivers/scsi/megaraid/megaraid_sas_base.c
index b2339d04a700..2590746c81e3 100644
--- a/drivers/scsi/megaraid/megaraid_sas_base.c
+++ b/drivers/scsi/megaraid/megaraid_sas_base.c
@@ -8763,7 +8763,7 @@  static int __init megasas_init(void)
 
 	if ((event_log_level < MFI_EVT_CLASS_DEBUG) ||
 	    (event_log_level > MFI_EVT_CLASS_DEAD)) {
-		printk(KERN_WARNING "megarid_sas: provided event log level is out of range, setting it to default 2(CLASS_CRITICAL), permissible range is: -2 to 4\n");
+		pr_warn("megaraid_sas: provided event log level is out of range, setting it to default 2(CLASS_CRITICAL), permissible range is: -2 to 4\n");
 		event_log_level = MFI_EVT_CLASS_CRITICAL;
 	}