linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: John Stultz <john.stultz@linaro.org>
To: lkml <linux-kernel@vger.kernel.org>
Cc: Xu YiPing <xuyiping@hisilicon.com>,
	Rongrong Zou <zourongrong@gmail.com>,
	David Airlie <airlied@linux.ie>, Daniel Vetter <daniel@ffwll.ch>,
	dri-devel <dri-devel@lists.freedesktop.org>,
	Sam Ravnborg <sam@ravnborg.org>,
	John Stultz <john.stultz@linaro.org>
Subject: [PATCH v3 21/26] drm: kirin: Rename plane_init and crtc_init
Date: Thu,  1 Aug 2019 03:44:34 +0000	[thread overview]
Message-ID: <20190801034439.98227-22-john.stultz@linaro.org> (raw)
In-Reply-To: <20190801034439.98227-1-john.stultz@linaro.org>

From: Xu YiPing <xuyiping@hisilicon.com>

As part of refactoring the kirin driver to better support
different hardware revisions, this patch renames
ade_crtc/plane_init kirin_plane/crtc_init, as they will later be
moved to kirin drm drv and shared with the kirin960 hardware
support.

Cc: Rongrong Zou <zourongrong@gmail.com>
Cc: David Airlie <airlied@linux.ie>
Cc: Daniel Vetter <daniel@ffwll.ch>
Cc: dri-devel <dri-devel@lists.freedesktop.org>
Cc: Sam Ravnborg <sam@ravnborg.org>
Reviewed-by: Sam Ravnborg <sam@ravnborg.org>
Signed-off-by: Xu YiPing <xuyiping@hisilicon.com>
[jstultz: reworded commit message]
Signed-off-by: John Stultz <john.stultz@linaro.org>
---
 drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c b/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c
index 66434c0cce6e..0bdcac981d8b 100644
--- a/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c
+++ b/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c
@@ -571,7 +571,7 @@ static const struct drm_crtc_funcs ade_crtc_funcs = {
 	.disable_vblank	= ade_crtc_disable_vblank,
 };
 
-static int ade_crtc_init(struct drm_device *dev, struct drm_crtc *crtc,
+static int kirin_drm_crtc_init(struct drm_device *dev, struct drm_crtc *crtc,
 			 struct drm_plane *plane)
 {
 	struct device_node *port;
@@ -892,8 +892,9 @@ static struct drm_plane_funcs ade_plane_funcs = {
 	.atomic_destroy_state = drm_atomic_helper_plane_destroy_state,
 };
 
-static int ade_plane_init(struct drm_device *dev, struct kirin_plane *kplane,
-			  enum drm_plane_type type)
+static int kirin_drm_plane_init(struct drm_device *dev,
+				struct kirin_plane *kplane,
+				enum drm_plane_type type)
 {
 	int ret = 0;
 
@@ -1024,13 +1025,13 @@ static int ade_drm_init(struct platform_device *pdev)
 		else
 			type = DRM_PLANE_TYPE_OVERLAY;
 
-		ret = ade_plane_init(dev, kplane, type);
+		ret = kirin_drm_plane_init(dev, kplane, type);
 		if (ret)
 			return ret;
 	}
 
 	/* crtc init */
-	ret = ade_crtc_init(dev, &kcrtc->base,
+	ret = kirin_drm_crtc_init(dev, &kcrtc->base,
 				&ade->planes[ade_driver_data.prim_plane].base);
 	if (ret)
 		return ret;
-- 
2.17.1


  parent reply	other threads:[~2019-08-01  3:45 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-01  3:44 [PATCH v3 00/26] drm: Kirin driver cleanups to prep for Kirin960 support John Stultz
2019-08-01  3:44 ` [PATCH v3 01/26] drm: kirin: Fix for hikey620 display offset problem John Stultz
2019-08-01  3:44 ` [PATCH v3 02/26] drm: kirin: Get rid of drmP.h includes John Stultz
2019-08-01  3:44 ` [PATCH v3 03/26] drm: kirin: Remove HISI_KIRIN_DW_DSI config option John Stultz
2019-08-01  3:44 ` [PATCH v3 04/26] drm: kirin: Remove unreachable return John Stultz
2019-08-01  3:44 ` [PATCH v3 05/26] drm: kirin: Remove uncessary parameter indirection John Stultz
2019-08-01  3:44 ` [PATCH v3 06/26] drm: kirin: Remove out_format from ade_crtc John Stultz
2019-08-01  3:44 ` [PATCH v3 07/26] drm: kirin: Rename ade_plane to kirin_plane John Stultz
2019-08-01  3:44 ` [PATCH v3 08/26] drm: kirin: Rename ade_crtc to kirin_crtc John Stultz
2019-08-01  3:44 ` [PATCH v3 09/26] drm: kirin: Dynamically allocate the hw_ctx John Stultz
2019-08-01  3:44 ` [PATCH v3 10/26] drm: kirin: Move request irq handle in ade hw ctx alloc John Stultz
2019-08-01  3:44 ` [PATCH v3 11/26] drm: kirin: Move workqueue to ade_hw_ctx structure John Stultz
2019-08-01  3:44 ` [PATCH v3 12/26] drm: kirin: Move kirin_crtc, kirin_plane, kirin_format to kirin_drm_drv.h John Stultz
2019-08-01  3:44 ` [PATCH v3 13/26] drm: kirin: Reanme dc_ops to kirin_drm_data John Stultz
2019-08-01  3:44 ` [PATCH v3 14/26] drm: kirin: Move ade crtc/plane help functions to driver_data John Stultz
2019-08-01  3:44 ` [PATCH v3 15/26] drm: kirin: Move channel formats to driver data John Stultz
2019-08-01  3:44 ` [PATCH v3 16/26] drm: kirin: Move mode config function to driver_data John Stultz
2019-08-01  3:44 ` [PATCH v3 17/26] drm: kirin: Move plane number and primay plane in driver data John Stultz
2019-08-01  3:44 ` [PATCH v3 18/26] drm: kirin: Move config max_width and max_height to " John Stultz
2019-08-01  3:44 ` [PATCH v3 19/26] drm: kirin: Move drm driver " John Stultz
2019-08-01  3:44 ` [PATCH v3 20/26] drm: kirin: Add register connect helper functions in drm init John Stultz
2019-08-01  3:44 ` John Stultz [this message]
2019-08-01  3:44 ` [PATCH v3 22/26] drm: kirin: Fix dev->driver_data setting John Stultz
2019-08-01  3:44 ` [PATCH v3 23/26] drm: kirin: Make driver_data variable non-global John Stultz
2019-08-01  3:44 ` [PATCH v3 24/26] drm: kirin: Add alloc_hw_ctx/clean_hw_ctx ops in driver data John Stultz
2019-08-01  3:44 ` [PATCH v3 25/26] drm: kirin: Pass driver data to crtc init and plane init John Stultz
2019-08-01  3:44 ` [PATCH v3 26/26] drm: kirin: Move ade drm init to kirin drm drv John Stultz
2019-08-03 14:17 ` [PATCH v3 00/26] drm: Kirin driver cleanups to prep for Kirin960 support Sam Ravnborg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190801034439.98227-22-john.stultz@linaro.org \
    --to=john.stultz@linaro.org \
    --cc=airlied@linux.ie \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sam@ravnborg.org \
    --cc=xuyiping@hisilicon.com \
    --cc=zourongrong@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).