linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: John Stultz <john.stultz@linaro.org>
To: lkml <linux-kernel@vger.kernel.org>
Cc: Xu YiPing <xuyiping@hisilicon.com>,
	Rongrong Zou <zourongrong@gmail.com>,
	David Airlie <airlied@linux.ie>, Daniel Vetter <daniel@ffwll.ch>,
	dri-devel <dri-devel@lists.freedesktop.org>,
	Sam Ravnborg <sam@ravnborg.org>,
	John Stultz <john.stultz@linaro.org>
Subject: [PATCH v3 22/26] drm: kirin: Fix dev->driver_data setting
Date: Thu,  1 Aug 2019 03:44:35 +0000	[thread overview]
Message-ID: <20190801034439.98227-23-john.stultz@linaro.org> (raw)
In-Reply-To: <20190801034439.98227-1-john.stultz@linaro.org>

From: Xu YiPing <xuyiping@hisilicon.com>

As part of refactoring the kirin driver to better support
different hardware revisions, this patch changes the
dev->driver_data to point to a drm_device, not ade_data.

Thus we set the driver data to drm device after alloc.

Cc: Rongrong Zou <zourongrong@gmail.com>
Cc: David Airlie <airlied@linux.ie>
Cc: Daniel Vetter <daniel@ffwll.ch>
Cc: dri-devel <dri-devel@lists.freedesktop.org>
Cc: Sam Ravnborg <sam@ravnborg.org>
Reviewed-by: Sam Ravnborg <sam@ravnborg.org>
Signed-off-by: Xu YiPing <xuyiping@hisilicon.com>
[jstultz: Reworded commit message]
Signed-off-by: John Stultz <john.stultz@linaro.org>
---
 drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c | 1 -
 drivers/gpu/drm/hisilicon/kirin/kirin_drm_drv.c | 3 +--
 2 files changed, 1 insertion(+), 3 deletions(-)

diff --git a/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c b/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c
index 0bdcac981d8b..09dc2c07533d 100644
--- a/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c
+++ b/drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c
@@ -998,7 +998,6 @@ static int ade_drm_init(struct platform_device *pdev)
 		DRM_ERROR("failed to alloc ade_data\n");
 		return -ENOMEM;
 	}
-	platform_set_drvdata(pdev, ade);
 
 	ctx = ade_hw_ctx_alloc(pdev, &ade->crtc.base);
 	if (IS_ERR(ctx)) {
diff --git a/drivers/gpu/drm/hisilicon/kirin/kirin_drm_drv.c b/drivers/gpu/drm/hisilicon/kirin/kirin_drm_drv.c
index 1c9658e9565e..f1853b84ab58 100644
--- a/drivers/gpu/drm/hisilicon/kirin/kirin_drm_drv.c
+++ b/drivers/gpu/drm/hisilicon/kirin/kirin_drm_drv.c
@@ -43,8 +43,6 @@ static int kirin_drm_kms_init(struct drm_device *dev)
 {
 	int ret;
 
-	dev_set_drvdata(dev->dev, dev);
-
 	/* dev->mode_config initialization */
 	drm_mode_config_init(dev);
 	dev->mode_config.min_width = 0;
@@ -139,6 +137,7 @@ static int kirin_drm_bind(struct device *dev)
 	drm_dev = drm_dev_alloc(driver_data->driver, dev);
 	if (IS_ERR(drm_dev))
 		return PTR_ERR(drm_dev);
+	dev_set_drvdata(dev, drm_dev);
 
 	ret = kirin_drm_kms_init(drm_dev);
 	if (ret)
-- 
2.17.1


  parent reply	other threads:[~2019-08-01  3:45 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-01  3:44 [PATCH v3 00/26] drm: Kirin driver cleanups to prep for Kirin960 support John Stultz
2019-08-01  3:44 ` [PATCH v3 01/26] drm: kirin: Fix for hikey620 display offset problem John Stultz
2019-08-01  3:44 ` [PATCH v3 02/26] drm: kirin: Get rid of drmP.h includes John Stultz
2019-08-01  3:44 ` [PATCH v3 03/26] drm: kirin: Remove HISI_KIRIN_DW_DSI config option John Stultz
2019-08-01  3:44 ` [PATCH v3 04/26] drm: kirin: Remove unreachable return John Stultz
2019-08-01  3:44 ` [PATCH v3 05/26] drm: kirin: Remove uncessary parameter indirection John Stultz
2019-08-01  3:44 ` [PATCH v3 06/26] drm: kirin: Remove out_format from ade_crtc John Stultz
2019-08-01  3:44 ` [PATCH v3 07/26] drm: kirin: Rename ade_plane to kirin_plane John Stultz
2019-08-01  3:44 ` [PATCH v3 08/26] drm: kirin: Rename ade_crtc to kirin_crtc John Stultz
2019-08-01  3:44 ` [PATCH v3 09/26] drm: kirin: Dynamically allocate the hw_ctx John Stultz
2019-08-01  3:44 ` [PATCH v3 10/26] drm: kirin: Move request irq handle in ade hw ctx alloc John Stultz
2019-08-01  3:44 ` [PATCH v3 11/26] drm: kirin: Move workqueue to ade_hw_ctx structure John Stultz
2019-08-01  3:44 ` [PATCH v3 12/26] drm: kirin: Move kirin_crtc, kirin_plane, kirin_format to kirin_drm_drv.h John Stultz
2019-08-01  3:44 ` [PATCH v3 13/26] drm: kirin: Reanme dc_ops to kirin_drm_data John Stultz
2019-08-01  3:44 ` [PATCH v3 14/26] drm: kirin: Move ade crtc/plane help functions to driver_data John Stultz
2019-08-01  3:44 ` [PATCH v3 15/26] drm: kirin: Move channel formats to driver data John Stultz
2019-08-01  3:44 ` [PATCH v3 16/26] drm: kirin: Move mode config function to driver_data John Stultz
2019-08-01  3:44 ` [PATCH v3 17/26] drm: kirin: Move plane number and primay plane in driver data John Stultz
2019-08-01  3:44 ` [PATCH v3 18/26] drm: kirin: Move config max_width and max_height to " John Stultz
2019-08-01  3:44 ` [PATCH v3 19/26] drm: kirin: Move drm driver " John Stultz
2019-08-01  3:44 ` [PATCH v3 20/26] drm: kirin: Add register connect helper functions in drm init John Stultz
2019-08-01  3:44 ` [PATCH v3 21/26] drm: kirin: Rename plane_init and crtc_init John Stultz
2019-08-01  3:44 ` John Stultz [this message]
2019-08-01  3:44 ` [PATCH v3 23/26] drm: kirin: Make driver_data variable non-global John Stultz
2019-08-01  3:44 ` [PATCH v3 24/26] drm: kirin: Add alloc_hw_ctx/clean_hw_ctx ops in driver data John Stultz
2019-08-01  3:44 ` [PATCH v3 25/26] drm: kirin: Pass driver data to crtc init and plane init John Stultz
2019-08-01  3:44 ` [PATCH v3 26/26] drm: kirin: Move ade drm init to kirin drm drv John Stultz
2019-08-03 14:17 ` [PATCH v3 00/26] drm: Kirin driver cleanups to prep for Kirin960 support Sam Ravnborg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190801034439.98227-23-john.stultz@linaro.org \
    --to=john.stultz@linaro.org \
    --cc=airlied@linux.ie \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sam@ravnborg.org \
    --cc=xuyiping@hisilicon.com \
    --cc=zourongrong@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).