linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: John Stultz <john.stultz@linaro.org>
To: lkml <linux-kernel@vger.kernel.org>
Cc: John Stultz <john.stultz@linaro.org>,
	Rongrong Zou <zourongrong@gmail.com>,
	Xinliang Liu <z.liuxinliang@hisilicon.com>,
	David Airlie <airlied@linux.ie>, Daniel Vetter <daniel@ffwll.ch>,
	dri-devel <dri-devel@lists.freedesktop.org>,
	Sam Ravnborg <sam@ravnborg.org>
Subject: [PATCH v5 03/25] drm: kirin: Remove unreachable return
Date: Tue, 20 Aug 2019 23:06:04 +0000	[thread overview]
Message-ID: <20190820230626.23253-4-john.stultz@linaro.org> (raw)
In-Reply-To: <20190820230626.23253-1-john.stultz@linaro.org>

The 'return 0' in kirin_drm_platform_probe() is unreachable
code, so remove it.

Cc: Rongrong Zou <zourongrong@gmail.com>
Cc: Xinliang Liu <z.liuxinliang@hisilicon.com>
Cc: David Airlie <airlied@linux.ie>
Cc: Daniel Vetter <daniel@ffwll.ch>
Cc: dri-devel <dri-devel@lists.freedesktop.org>
Cc: Sam Ravnborg <sam@ravnborg.org>
Acked-by: Xinliang Liu <z.liuxinliang@hisilicon.com>
Reviewed-by: Sam Ravnborg <sam@ravnborg.org>
Suggested by: Xu YiPing <xuyiping@hisilicon.com>
Signed-off-by: John Stultz <john.stultz@linaro.org>
---
 drivers/gpu/drm/hisilicon/kirin/kirin_drm_drv.c | 2 --
 1 file changed, 2 deletions(-)

diff --git a/drivers/gpu/drm/hisilicon/kirin/kirin_drm_drv.c b/drivers/gpu/drm/hisilicon/kirin/kirin_drm_drv.c
index 204c94c01e3d..fcdd6b1e167d 100644
--- a/drivers/gpu/drm/hisilicon/kirin/kirin_drm_drv.c
+++ b/drivers/gpu/drm/hisilicon/kirin/kirin_drm_drv.c
@@ -208,8 +208,6 @@ static int kirin_drm_platform_probe(struct platform_device *pdev)
 	of_node_put(remote);
 
 	return component_master_add_with_match(dev, &kirin_drm_ops, match);
-
-	return 0;
 }
 
 static int kirin_drm_platform_remove(struct platform_device *pdev)
-- 
2.17.1


  parent reply	other threads:[~2019-08-20 23:06 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-20 23:06 [PATCH v5 00/25] drm: Kirin driver cleanups to prep for Kirin960 support John Stultz
2019-08-20 23:06 ` [PATCH v5 01/25] drm: kirin: Fix for hikey620 display offset problem John Stultz
2019-08-20 23:06 ` [PATCH v5 02/25] drm: kirin: Remove HISI_KIRIN_DW_DSI config option John Stultz
2019-08-20 23:06 ` John Stultz [this message]
2019-08-20 23:06 ` [PATCH v5 04/25] drm: kirin: Remove uncessary parameter indirection John Stultz
2019-08-20 23:06 ` [PATCH v5 05/25] drm: kirin: Remove out_format from ade_crtc John Stultz
2019-08-20 23:06 ` [PATCH v5 06/25] drm: kirin: Rename ade_plane to kirin_plane John Stultz
2019-08-20 23:06 ` [PATCH v5 07/25] drm: kirin: Rename ade_crtc to kirin_crtc John Stultz
2019-08-20 23:06 ` [PATCH v5 08/25] drm: kirin: Dynamically allocate the hw_ctx John Stultz
2019-08-20 23:06 ` [PATCH v5 09/25] drm: kirin: Move request irq handle in ade hw ctx alloc John Stultz
2019-08-20 23:06 ` [PATCH v5 10/25] drm: kirin: Move workqueue to ade_hw_ctx structure John Stultz
2019-08-20 23:06 ` [PATCH v5 11/25] drm: kirin: Move kirin_crtc, kirin_plane, kirin_format to kirin_drm_drv.h John Stultz
2019-08-20 23:06 ` [PATCH v5 12/25] drm: kirin: Reanme dc_ops to kirin_drm_data John Stultz
2019-08-20 23:06 ` [PATCH v5 13/25] drm: kirin: Move ade crtc/plane help functions to driver_data John Stultz
2019-08-20 23:06 ` [PATCH v5 14/25] drm: kirin: Move channel formats to driver data John Stultz
2019-08-20 23:06 ` [PATCH v5 15/25] drm: kirin: Move mode config function to driver_data John Stultz
2019-08-20 23:06 ` [PATCH v5 16/25] drm: kirin: Move plane number and primay plane in driver data John Stultz
2019-08-20 23:06 ` [PATCH v5 17/25] drm: kirin: Move config max_width and max_height to " John Stultz
2019-08-20 23:06 ` [PATCH v5 18/25] drm: kirin: Move drm driver " John Stultz
2019-08-20 23:06 ` [PATCH v5 19/25] drm: kirin: Add register connect helper functions in drm init John Stultz
2020-04-07  8:02   ` Daniel Vetter
2019-08-20 23:06 ` [PATCH v5 20/25] drm: kirin: Rename plane_init and crtc_init John Stultz
2019-08-20 23:06 ` [PATCH v5 21/25] drm: kirin: Fix dev->driver_data setting John Stultz
2019-08-20 23:06 ` [PATCH v5 22/25] drm: kirin: Make driver_data variable non-global John Stultz
2019-08-20 23:06 ` [PATCH v5 23/25] drm: kirin: Add alloc_hw_ctx/clean_hw_ctx ops in driver data John Stultz
2019-08-20 23:06 ` [PATCH v5 24/25] drm: kirin: Pass driver data to crtc init and plane init John Stultz
2019-08-20 23:06 ` [PATCH v5 25/25] drm: kirin: Move ade drm init to kirin drm drv John Stultz
2019-08-21 18:04 ` [PATCH v5 00/25] drm: Kirin driver cleanups to prep for Kirin960 support Sam Ravnborg
2019-08-21 19:13   ` John Stultz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190820230626.23253-4-john.stultz@linaro.org \
    --to=john.stultz@linaro.org \
    --cc=airlied@linux.ie \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sam@ravnborg.org \
    --cc=z.liuxinliang@hisilicon.com \
    --cc=zourongrong@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).