linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Lee Jones <lee.jones@linaro.org>
To: Enric Balletbo i Serra <enric.balletbo@collabora.com>
Cc: linux-kernel@vger.kernel.org, Jonathan Corbet <corbet@lwn.net>,
	Krzysztof Kozlowski <krzk@kernel.org>,
	Will Deacon <will.deacon@arm.com>,
	MyungJoo Ham <myungjoo.ham@samsung.com>,
	Chanwoo Choi <cw00.choi@samsung.com>,
	Benson Leung <bleung@chromium.org>,
	Guenter Roeck <groeck@chromium.org>,
	Jonathan Cameron <jic23@kernel.org>,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	Mauro Carvalho Chehab <mchehab@kernel.org>,
	Sebastian Reichel <sre@kernel.org>,
	Thierry Reding <thierry.reding@gmail.com>,
	Alexandre Belloni <alexandre.belloni@bootlin.com>,
	Liam Girdwood <lgirdwood@gmail.com>,
	Mark Brown <broonie@kernel.org>,
	Neil Armstrong <narmstrong@baylibre.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Collabora kernel ML <kernel@collabora.com>,
	arnd@arndb.de
Subject: [GIT PULL] Immutable branch between MFD, Extcon, HID, I2C, IIO, Input, Chrome, Power, PWM, RTC and Sounds due for the v5.4 merge window
Date: Mon, 2 Sep 2019 11:36:33 +0100	[thread overview]
Message-ID: <20190902103633.GA26880@dell> (raw)
In-Reply-To: <20190902095309.18574-1-enric.balletbo@collabora.com>

Enjoy!

The following changes since commit 5f9e832c137075045d15cd6899ab0505cfb2ca4b:

  Linus 5.3-rc1 (2019-07-21 14:05:38 -0700)

are available in the Git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/lee/mfd.git ib-mfd-extcon-hid-i2c-iio-input-media-chrome-power-pwm-rtc-sound-v5.4

for you to fetch changes up to 28e6fcc871bcff640c8960448034ea3a7c7fdfa3:

  mfd: cros_ec: Use mfd_add_hotplug_devices() helper (2019-09-02 11:34:24 +0100)

----------------------------------------------------------------
Immutable branch between MFD, Extcon, HID, I2C, IIO, Input, Chrome, Power, PWM, RTC and Sounds due for the v5.4 merge window

----------------------------------------------------------------
Enric Balletbo i Serra (10):
      mfd / platform: cros_ec: Handle chained ECs as platform devices
      mfd / platform: cros_ec: Move cros-ec core driver out from MFD
      mfd / platform: cros_ec: Miscellaneous character device to talk with the EC
      mfd: cros_ec: Switch to use the new cros-ec-chardev driver
      mfd / platform: cros_ec: Rename config to a better name
      mfd / platform: cros_ec: Reorganize platform and mfd includes
      mfd: cros_ec: Use kzalloc and cros_ec_cmd_xfer_status helper
      mfd: cros_ec: Add convenience struct to define dedicated CrOS EC MCUs
      mfd: cros_ec: Add convenience struct to define autodetectable CrOS EC subdevices
      mfd: cros_ec: Use mfd_add_hotplug_devices() helper

 drivers/extcon/Kconfig                             |   2 +-
 drivers/extcon/extcon-usbc-cros-ec.c               |   3 +-
 drivers/hid/Kconfig                                |   2 +-
 drivers/hid/hid-google-hammer.c                    |   4 +-
 drivers/i2c/busses/Kconfig                         |   2 +-
 drivers/i2c/busses/i2c-cros-ec-tunnel.c            |   4 +-
 drivers/iio/accel/cros_ec_accel_legacy.c           |   3 +-
 drivers/iio/common/cros_ec_sensors/Kconfig         |   2 +-
 .../iio/common/cros_ec_sensors/cros_ec_lid_angle.c |   3 +-
 .../iio/common/cros_ec_sensors/cros_ec_sensors.c   |   3 +-
 .../common/cros_ec_sensors/cros_ec_sensors_core.c  |   3 +-
 drivers/iio/light/cros_ec_light_prox.c             |   3 +-
 drivers/iio/pressure/cros_ec_baro.c                |   3 +-
 drivers/input/keyboard/Kconfig                     |   2 +-
 drivers/input/keyboard/cros_ec_keyb.c              |   4 +-
 drivers/media/platform/Kconfig                     |   3 +-
 drivers/media/platform/cros-ec-cec/cros-ec-cec.c   |   5 +-
 drivers/mfd/Kconfig                                |  26 +-
 drivers/mfd/Makefile                               |   4 +-
 drivers/mfd/cros_ec_dev.c                          | 463 ++++++---------------
 drivers/platform/chrome/Kconfig                    |  60 ++-
 drivers/platform/chrome/Makefile                   |   2 +
 drivers/{mfd => platform/chrome}/cros_ec.c         |  64 +--
 drivers/platform/chrome/cros_ec_chardev.c          | 252 +++++++++++
 drivers/platform/chrome/cros_ec_debugfs.c          |   3 +-
 drivers/platform/chrome/cros_ec_i2c.c              |  12 +-
 drivers/platform/chrome/cros_ec_ishtp.c            |   5 +-
 drivers/platform/chrome/cros_ec_lightbar.c         |   3 +-
 drivers/platform/chrome/cros_ec_lpc.c              |   7 +-
 drivers/platform/chrome/cros_ec_proto.c            |   3 +-
 drivers/platform/chrome/cros_ec_rpmsg.c            |   6 +-
 drivers/platform/chrome/cros_ec_spi.c              |  12 +-
 drivers/platform/chrome/cros_ec_sysfs.c            |   3 +-
 drivers/platform/chrome/cros_ec_trace.c            |   2 +-
 drivers/platform/chrome/cros_ec_trace.h            |   4 +-
 drivers/platform/chrome/cros_ec_vbc.c              |   3 +-
 drivers/platform/chrome/cros_usbpd_logger.c        |   5 +-
 drivers/power/supply/Kconfig                       |   2 +-
 drivers/power/supply/cros_usbpd-charger.c          |   5 +-
 drivers/pwm/Kconfig                                |   2 +-
 drivers/pwm/pwm-cros-ec.c                          |   4 +-
 drivers/rtc/Kconfig                                |   2 +-
 drivers/rtc/rtc-cros-ec.c                          |   3 +-
 include/Kbuild                                     |   2 +-
 include/linux/iio/common/cros_ec_sensors_core.h    |   3 +-
 include/linux/mfd/cros_ec.h                        | 292 -------------
 .../linux/platform_data/cros_ec_chardev.h          |  12 +-
 .../{mfd => platform_data}/cros_ec_commands.h      |   0
 include/linux/platform_data/cros_ec_proto.h        | 319 ++++++++++++++
 sound/soc/codecs/Kconfig                           |   4 +-
 sound/soc/codecs/cros_ec_codec.c                   |   4 +-
 sound/soc/qcom/Kconfig                             |   2 +-
 52 files changed, 900 insertions(+), 746 deletions(-)
 rename drivers/{mfd => platform/chrome}/cros_ec.c (84%)
 create mode 100644 drivers/platform/chrome/cros_ec_chardev.c
 rename drivers/mfd/cros_ec_dev.h => include/linux/platform_data/cros_ec_chardev.h (79%)
 rename include/linux/{mfd => platform_data}/cros_ec_commands.h (100%)
 create mode 100644 include/linux/platform_data/cros_ec_proto.h

-- 
Lee Jones [李琼斯]
Linaro Services Technical Lead
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog

      parent reply	other threads:[~2019-09-02 10:36 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-09-02  9:52 [PATCH v7 00/10] Move part of cros-ec out of MFD subsystem Enric Balletbo i Serra
2019-09-02  9:53 ` [PATCH v7 01/10] mfd / platform: cros_ec: Handle chained ECs as platform devices Enric Balletbo i Serra
2019-09-02  9:53 ` [PATCH v7 02/10] mfd / platform: cros_ec: Move cros-ec core driver out from MFD Enric Balletbo i Serra
2019-09-02  9:53 ` [PATCH v7 03/10] mfd / platform: cros_ec: Miscellaneous character device to talk with the EC Enric Balletbo i Serra
2019-09-02  9:53 ` [PATCH v7 04/10] mfd: cros_ec: Switch to use the new cros-ec-chardev driver Enric Balletbo i Serra
2019-09-02  9:53 ` [PATCH v7 05/10] mfd / platform: cros_ec: Rename config to a better name Enric Balletbo i Serra
2019-09-02  9:53 ` [PATCH v7 06/10] mfd / platform: cros_ec: Reorganize platform and mfd includes Enric Balletbo i Serra
2019-09-02  9:53 ` [PATCH v7 07/10] mfd: cros_ec: Use kzalloc and cros_ec_cmd_xfer_status helper Enric Balletbo i Serra
2019-09-02  9:53 ` [PATCH v7 08/10] mfd: cros_ec: Add convenience struct to define dedicated CrOS EC MCUs Enric Balletbo i Serra
2019-09-02  9:53 ` [PATCH v7 09/10] mfd: cros_ec: Add convenience struct to define autodetectable CrOS EC subdevices Enric Balletbo i Serra
2019-09-02  9:53 ` [PATCH v7 10/10] mfd: cros_ec: Use mfd_add_hotplug_devices() helper Enric Balletbo i Serra
2019-09-02 10:36 ` Lee Jones [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190902103633.GA26880@dell \
    --to=lee.jones@linaro.org \
    --cc=alexandre.belloni@bootlin.com \
    --cc=arnd@arndb.de \
    --cc=bleung@chromium.org \
    --cc=broonie@kernel.org \
    --cc=corbet@lwn.net \
    --cc=cw00.choi@samsung.com \
    --cc=dmitry.torokhov@gmail.com \
    --cc=enric.balletbo@collabora.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=groeck@chromium.org \
    --cc=jic23@kernel.org \
    --cc=kernel@collabora.com \
    --cc=krzk@kernel.org \
    --cc=lgirdwood@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mchehab@kernel.org \
    --cc=myungjoo.ham@samsung.com \
    --cc=narmstrong@baylibre.com \
    --cc=sre@kernel.org \
    --cc=thierry.reding@gmail.com \
    --cc=will.deacon@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).