linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Jagan Teki <jagan@amarulasolutions.com>
To: Heiko Stuebner <heiko@sntech.de>, Levin Du <djw@t-chip.com.cn>,
	Akash Gajjar <akash@openedev.com>,
	Rob Herring <robh+dt@kernel.org>,
	Mark Rutland <mark.rutland@arm.com>
Cc: Da Xue <da@lessconfused.com>,
	devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
	linux-rockchip@lists.infradead.org, linux-kernel@vger.kernel.org,
	linux-amarula@amarulasolutions.com,
	Jagan Teki <jagan@amarulasolutions.com>
Subject: [PATCH 5/6] arm64: dts: rockchip: Rename vcc12v_sys into dc_12v for roc-rk3399-pc
Date: Thu, 19 Sep 2019 10:58:21 +0530	[thread overview]
Message-ID: <20190919052822.10403-6-jagan@amarulasolutions.com> (raw)
In-Reply-To: <20190919052822.10403-1-jagan@amarulasolutions.com>

It is always better practice to follow regulator naming conventions
as per the schematics for future references.

This would indeed helpful to review and check the naming convention
directly on schematics, both for the code reviewers and the developers.

So, rename vcc12v_sys into dc_12v as per rk3399 power tree as per
roc-rk3399-pc schematics.

Signed-off-by: Jagan Teki <jagan@amarulasolutions.com>
---
 .../boot/dts/rockchip/rk3399-libretech-roc-rk3399-pc.dts  | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/arch/arm64/boot/dts/rockchip/rk3399-libretech-roc-rk3399-pc.dts b/arch/arm64/boot/dts/rockchip/rk3399-libretech-roc-rk3399-pc.dts
index e09bcbdd92f5..51242ea5447d 100644
--- a/arch/arm64/boot/dts/rockchip/rk3399-libretech-roc-rk3399-pc.dts
+++ b/arch/arm64/boot/dts/rockchip/rk3399-libretech-roc-rk3399-pc.dts
@@ -57,9 +57,9 @@
 	 * should be placed inside mp8859, but not until mp8859 has
 	 * its own dt-binding.
 	 */
-	vcc12v_sys: mp8859-dcdc1 {
+	dc_12v: mp8859-dcdc1 {
 		compatible = "regulator-fixed";
-		regulator-name = "vcc12v_sys";
+		regulator-name = "dc_12v";
 		regulator-always-on;
 		regulator-boot-on;
 		regulator-min-microvolt = <12000000>;
@@ -85,7 +85,7 @@
 		regulator-boot-on;
 		regulator-min-microvolt = <3300000>;
 		regulator-max-microvolt = <3300000>;
-		vin-supply = <&vcc12v_sys>;
+		vin-supply = <&dc_12v>;
 	};
 
 	/* Actually 3 regulators (host0, 1, 2) controlled by the same gpio */
@@ -118,7 +118,7 @@
 		regulator-boot-on;
 		regulator-min-microvolt = <5000000>;
 		regulator-max-microvolt = <5000000>;
-		vin-supply = <&vcc12v_sys>;
+		vin-supply = <&dc_12v>;
 	};
 
 	vdd_log: vdd-log {
-- 
2.18.0.321.gffc6fa0e3


  parent reply	other threads:[~2019-09-19  5:29 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-09-19  5:28 [PATCH 0/6] arm64: dts: rockchip: ROC-PC fixes Jagan Teki
2019-09-19  5:28 ` [PATCH 1/6] arm64: dts: rockchip: Fix rk3399-roc-pc pwm2 pin Jagan Teki
2019-09-29 21:21   ` Heiko Stuebner
2019-10-01 10:26     ` Jagan Teki
2019-10-01 10:34       ` Michael Nazzareno Trimarchi
2019-10-08  3:11       ` djw
2019-10-16 17:09         ` Jagan Teki
2019-10-17 13:26           ` Markus Reichl
2019-10-17 13:49             ` Jagan Teki
2019-10-17 23:33               ` Heiko Stuebner
2019-10-22  6:19                 ` djw
2019-09-19  5:28 ` [PATCH 2/6] dt-bindings: arm: rockchip: Use libretech for roc-pc binding Jagan Teki
2019-09-19  5:28 ` [PATCH 3/6] arm64: dts: rockchip: Use libretech model, compatible for ROC-PC Jagan Teki
2019-09-19  5:28 ` [PATCH 4/6] arm64: dts: rockchip: Rename roc-pc with libretech notation Jagan Teki
2019-09-29 21:32   ` Heiko Stuebner
2019-10-01 10:33     ` Jagan Teki
2019-10-01 11:01       ` Chen-Yu Tsai
2019-09-19  5:28 ` Jagan Teki [this message]
2019-10-03 22:49   ` [PATCH 5/6] arm64: dts: rockchip: Rename vcc12v_sys into dc_12v for roc-rk3399-pc Heiko Stuebner
2019-09-19  5:28 ` [PATCH 6/6] arm64: dts: rockchip: Fix roc-rk3399-pc regulator input rails Jagan Teki
2019-10-03 22:50   ` Heiko Stuebner
2019-10-16 17:11 ` [PATCH 0/6] arm64: dts: rockchip: ROC-PC fixes Jagan Teki

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190919052822.10403-6-jagan@amarulasolutions.com \
    --to=jagan@amarulasolutions.com \
    --cc=akash@openedev.com \
    --cc=da@lessconfused.com \
    --cc=devicetree@vger.kernel.org \
    --cc=djw@t-chip.com.cn \
    --cc=heiko@sntech.de \
    --cc=linux-amarula@amarulasolutions.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-rockchip@lists.infradead.org \
    --cc=mark.rutland@arm.com \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).