linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Kent Gibson <warthog618@gmail.com>
To: linux-kernel@vger.kernel.org, linux-gpio@vger.kernel.org,
	bgolaszewski@baylibre.com, linus.walleij@linaro.org
Cc: Kent Gibson <warthog618@gmail.com>
Subject: [PATCH 11/17] gpiolib: cdev: remove recalculation of offset
Date: Wed,  8 Jul 2020 12:15:54 +0800	[thread overview]
Message-ID: <20200708041600.768775-12-warthog618@gmail.com> (raw)
In-Reply-To: <20200708041600.768775-1-warthog618@gmail.com>

Remove recalculation of offset from desc, where desc itself was calculated
from offset.

There is no benefit from the desc -> hwgpio conversion in this context.
The only implicit benefit of the offset -> desc -> hwgpio is
the range check in the offset -> desc, but where desc is required you
still get that, and where desc isn't required it is simpler to perform
the range check directly.

Signed-off-by: Kent Gibson <warthog618@gmail.com>
---
 drivers/gpio/gpiolib-cdev.c | 20 +++++++-------------
 1 file changed, 7 insertions(+), 13 deletions(-)

diff --git a/drivers/gpio/gpiolib-cdev.c b/drivers/gpio/gpiolib-cdev.c
index b2b26dc25051..c86fb9305681 100644
--- a/drivers/gpio/gpiolib-cdev.c
+++ b/drivers/gpio/gpiolib-cdev.c
@@ -832,7 +832,6 @@ static long gpio_ioctl(struct file *file, unsigned int cmd, unsigned long arg)
 	void __user *ip = (void __user *)arg;
 	struct gpio_desc *desc;
 	__u32 offset;
-	int hwgpio;
 
 	/* We fail any subsequent ioctl():s when the chip is gone */
 	if (!gc)
@@ -860,12 +859,11 @@ static long gpio_ioctl(struct file *file, unsigned int cmd, unsigned long arg)
 		if (copy_from_user(&lineinfo, ip, sizeof(lineinfo)))
 			return -EFAULT;
 
+		/* this doubles as a range check on line_offset */
 		desc = gpiochip_get_desc(gc, lineinfo.line_offset);
 		if (IS_ERR(desc))
 			return PTR_ERR(desc);
 
-		hwgpio = gpio_chip_hwgpio(desc);
-
 		gpio_desc_to_lineinfo(desc, &lineinfo);
 
 		if (copy_to_user(ip, &lineinfo, sizeof(lineinfo)))
@@ -881,19 +879,18 @@ static long gpio_ioctl(struct file *file, unsigned int cmd, unsigned long arg)
 		if (copy_from_user(&lineinfo, ip, sizeof(lineinfo)))
 			return -EFAULT;
 
+		/* this doubles as a range check on line_offset */
 		desc = gpiochip_get_desc(gc, lineinfo.line_offset);
 		if (IS_ERR(desc))
 			return PTR_ERR(desc);
 
-		hwgpio = gpio_chip_hwgpio(desc);
-
-		if (test_and_set_bit(hwgpio, cdev->watched_lines))
+		if (test_and_set_bit(lineinfo.line_offset, cdev->watched_lines))
 			return -EBUSY;
 
 		gpio_desc_to_lineinfo(desc, &lineinfo);
 
 		if (copy_to_user(ip, &lineinfo, sizeof(lineinfo))) {
-			clear_bit(hwgpio, cdev->watched_lines);
+			clear_bit(lineinfo.line_offset, cdev->watched_lines);
 			return -EFAULT;
 		}
 
@@ -902,13 +899,10 @@ static long gpio_ioctl(struct file *file, unsigned int cmd, unsigned long arg)
 		if (copy_from_user(&offset, ip, sizeof(offset)))
 			return -EFAULT;
 
-		desc = gpiochip_get_desc(gc, offset);
-		if (IS_ERR(desc))
-			return PTR_ERR(desc);
-
-		hwgpio = gpio_chip_hwgpio(desc);
+		if (offset >= cdev->gdev->ngpio)
+			return -EINVAL;
 
-		if (!test_and_clear_bit(hwgpio, cdev->watched_lines))
+		if (!test_and_clear_bit(offset, cdev->watched_lines))
 			return -EBUSY;
 
 		return 0;
-- 
2.27.0


  parent reply	other threads:[~2020-07-08  4:20 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-08  4:15 [PATCH 00/17] gpiolib: cdev: pre-uAPI v2 cleanups Kent Gibson
2020-07-08  4:15 ` [PATCH 01/17] gpiolib: move gpiolib-sysfs function declarations into their own header Kent Gibson
2020-07-08  4:15 ` [PATCH 02/17] gpiolib: cdev: sort includes Kent Gibson
2020-07-08  4:15 ` [PATCH 03/17] gpiolib: cdev: minor indentation fixes Kent Gibson
2020-07-08  4:15 ` [PATCH 04/17] gpiolib: cdev: refactor gpiohandle_flags_to_desc_flags Kent Gibson
2020-07-08  4:15 ` [PATCH 05/17] gpiolib: cdev: rename 'filep' and 'filp' to 'file' to be consistent with other use Kent Gibson
2020-07-08  4:15 ` [PATCH 06/17] gpiolib: cdev: rename numdescs to num_descs Kent Gibson
2020-07-08  4:15 ` [PATCH 07/17] gpiolib: cdev: remove pointless decrement of i Kent Gibson
2020-07-08  4:15 ` [PATCH 08/17] gpiolib: cdev: use blocking notifier call chain instead of atomic Kent Gibson
2020-07-09 10:06   ` Bartosz Golaszewski
2020-07-08  4:15 ` [PATCH 09/17] gpiolib: cdev: rename priv to cdev Kent Gibson
2020-07-08  4:15 ` [PATCH 10/17] gpiolib: cdev: fix minor race in GET_LINEINFO_WATCH Kent Gibson
2020-07-08  4:15 ` Kent Gibson [this message]
2020-07-08  4:15 ` [PATCH 12/17] gpiolib: cdev: refactor linehandle cleanup into linehandle_free Kent Gibson
2020-07-08  4:15 ` [PATCH 13/17] gpiolib: cdev: refactor lineevent cleanup into lineevent_free Kent Gibson
2020-07-08  4:15 ` [PATCH 14/17] gpio: uapi: fix misplaced comment line Kent Gibson
2020-07-08  4:15 ` [PATCH 15/17] tools: gpio: fix spurious close warning in lsgpio Kent Gibson
2020-07-08  4:15 ` [PATCH 16/17] tools: gpio: fix spurious close warning in gpio-utils Kent Gibson
2020-07-08  4:16 ` [PATCH 17/17] tools: gpio: fix spurious close warning in gpio-event-mon Kent Gibson
2020-07-09 13:19 ` [PATCH 00/17] gpiolib: cdev: pre-uAPI v2 cleanups Bartosz Golaszewski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200708041600.768775-12-warthog618@gmail.com \
    --to=warthog618@gmail.com \
    --cc=bgolaszewski@baylibre.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).