linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Lee Jones <lee.jones@linaro.org>
To: kvalo@codeaurora.org
Cc: linux-kernel@vger.kernel.org, Lee Jones <lee.jones@linaro.org>,
	Amitkumar Karwar <amitkarwar@gmail.com>,
	Ganapathi Bhat <ganapathi.bhat@nxp.com>,
	Xinming Hu <huxinming820@gmail.com>,
	"David S. Miller" <davem@davemloft.net>,
	Jakub Kicinski <kuba@kernel.org>,
	linux-wireless@vger.kernel.org, netdev@vger.kernel.org
Subject: [PATCH 31/41] mwifiex: pcie: Remove a couple of unchecked 'ret's
Date: Mon,  2 Nov 2020 11:24:00 +0000	[thread overview]
Message-ID: <20201102112410.1049272-32-lee.jones@linaro.org> (raw)
In-Reply-To: <20201102112410.1049272-1-lee.jones@linaro.org>

Fixes the following W=1 kernel build warning(s):

 drivers/net/wireless/marvell/mwifiex/pcie.c: In function ‘mwifiex_pcie_remove’:
 drivers/net/wireless/marvell/mwifiex/pcie.c:432:6: warning: variable ‘ret’ set but not used [-Wunused-but-set-variable]
 drivers/net/wireless/marvell/mwifiex/pcie.c: In function ‘mwifiex_cleanup_pcie’:
 drivers/net/wireless/marvell/mwifiex/pcie.c:3142:6: warning: variable ‘ret’ set but not used [-Wunused-but-set-variable]

Cc: Amitkumar Karwar <amitkarwar@gmail.com>
Cc: Ganapathi Bhat <ganapathi.bhat@nxp.com>
Cc: Xinming Hu <huxinming820@gmail.com>
Cc: Kalle Valo <kvalo@codeaurora.org>
Cc: "David S. Miller" <davem@davemloft.net>
Cc: Jakub Kicinski <kuba@kernel.org>
Cc: linux-wireless@vger.kernel.org
Cc: netdev@vger.kernel.org
Signed-off-by: Lee Jones <lee.jones@linaro.org>
---
 drivers/net/wireless/marvell/mwifiex/pcie.c | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/drivers/net/wireless/marvell/mwifiex/pcie.c b/drivers/net/wireless/marvell/mwifiex/pcie.c
index 6a10ff0377a24..67e0247ebaa65 100644
--- a/drivers/net/wireless/marvell/mwifiex/pcie.c
+++ b/drivers/net/wireless/marvell/mwifiex/pcie.c
@@ -429,7 +429,6 @@ static void mwifiex_pcie_remove(struct pci_dev *pdev)
 	struct mwifiex_private *priv;
 	const struct mwifiex_pcie_card_reg *reg;
 	u32 fw_status;
-	int ret;
 
 	card = pci_get_drvdata(pdev);
 
@@ -441,7 +440,7 @@ static void mwifiex_pcie_remove(struct pci_dev *pdev)
 
 	reg = card->pcie.reg;
 	if (reg)
-		ret = mwifiex_read_reg(adapter, reg->fw_status, &fw_status);
+		mwifiex_read_reg(adapter, reg->fw_status, &fw_status);
 	else
 		fw_status = -1;
 
@@ -3139,12 +3138,11 @@ static void mwifiex_cleanup_pcie(struct mwifiex_adapter *adapter)
 	struct pcie_service_card *card = adapter->card;
 	struct pci_dev *pdev = card->dev;
 	const struct mwifiex_pcie_card_reg *reg = card->pcie.reg;
-	int ret;
 	u32 fw_status;
 
 	cancel_work_sync(&card->work);
 
-	ret = mwifiex_read_reg(adapter, reg->fw_status, &fw_status);
+	mwifiex_read_reg(adapter, reg->fw_status, &fw_status);
 	if (fw_status == FIRMWARE_READY_PCIE) {
 		mwifiex_dbg(adapter, INFO,
 			    "Clearing driver ready signature\n");
-- 
2.25.1


  parent reply	other threads:[~2020-11-02 11:25 UTC|newest]

Thread overview: 62+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-02 11:23 [PATCH 00/41] [Set 4] Rid W=1 warnings in Wireless Lee Jones
2020-11-02 11:23 ` [PATCH 01/41] wil6210: wmi: Correct misnamed function parameter 'ptr_' Lee Jones
2020-11-07  8:10   ` Kalle Valo
2020-11-02 11:23 ` [PATCH 02/41] rsi_91x_usb: Fix some basic kernel-doc issues Lee Jones
2020-11-07 16:03   ` [02/41] rsi: " Kalle Valo
2020-11-02 11:23 ` [PATCH 03/41] rtl8192cu: mac: Fix some missing/ill-documented function parameters Lee Jones
2020-11-07 16:15   ` [03/41] rtlwifi: " Kalle Valo
2020-11-02 11:23 ` [PATCH 04/41] rsi_91x_usb_ops: Source file headers are not good candidates for kernel-doc Lee Jones
2020-11-02 11:23 ` [PATCH 05/41] rtl8192cu: trx: Demote clear abuse of kernel-doc format Lee Jones
2020-11-02 16:50   ` Larry Finger
2020-11-03  8:51     ` Lee Jones
2020-11-02 11:23 ` [PATCH 06/41] brcmfmac: bcmsdh: Fix description for function parameter 'pktlist' Lee Jones
2020-11-07 16:04   ` Kalle Valo
2020-11-02 11:23 ` [PATCH 07/41] brcmfmac: pcie: Provide description for missing function parameter 'devinfo' Lee Jones
2020-11-02 11:23 ` [PATCH 08/41] iwlwifi: mvm: rs: Demote non-conformant function documentation headers Lee Jones
2020-11-02 11:23 ` [PATCH 09/41] wl1251: cmd: Rename 'len' to 'buf_len' in the documentation Lee Jones
2020-11-07 16:06   ` Kalle Valo
2020-11-02 11:23 ` [PATCH 10/41] ath9k: ar9330_1p1_initvals: Remove unused const variable 'ar9331_common_tx_gain_offset1_1' Lee Jones
2020-11-07  8:08   ` Kalle Valo
2020-11-02 11:23 ` [PATCH 11/41] ath9k: ar9340_initvals: Remove unused const variable 'ar9340Modes_ub124_tx_gain_table_1p0' Lee Jones
2020-11-02 11:23 ` [PATCH 12/41] ath9k: ar9485_initvals: Remove unused const variable 'ar9485_fast_clock_1_1_baseband_postamble' Lee Jones
2020-11-02 11:23 ` [PATCH 13/41] ath9k: ar9003_2p2_initvals: Remove unused const variables Lee Jones
2020-11-02 11:23 ` [PATCH 14/41] prism54: isl_ioctl: Fix one function header and demote another Lee Jones
2020-11-02 11:23 ` [PATCH 15/41] iwlwifi: iwl-eeprom-read: Demote one nonconformant function header Lee Jones
2020-11-02 11:23 ` [PATCH 16/41] iwlwifi: iwl-eeprom-parse: Fix 'struct iwl_eeprom_enhanced_txpwr's header Lee Jones
2020-11-02 11:23 ` [PATCH 17/41] intersil: hostap_hw: Prevent incompatible function type cast Lee Jones
2020-11-07 16:01   ` Kalle Valo
2020-11-02 11:23 ` [PATCH 18/41] brcm80211: fweh: Add missing description for 'gfp' Lee Jones
2020-11-02 11:23 ` [PATCH 19/41] ath: regd: Provide description for ath_reg_apply_ir_flags's 'reg' param Lee Jones
2020-11-07  8:07   ` Kalle Valo
2020-11-02 11:23 ` [PATCH 20/41] ath9k: ar5008_phy: Demote half completed function headers Lee Jones
2020-11-02 11:23 ` [PATCH 21/41] ath: dfs_pattern_detector: Fix some function kernel-doc headers Lee Jones
2020-11-02 11:23 ` [PATCH 22/41] ath: dfs_pri_detector: Demote zero/half completed " Lee Jones
2020-11-02 11:23 ` [PATCH 23/41] iwlwifi: iwl-phy-db: Add missing struct member description for 'trans' Lee Jones
2020-11-02 11:23 ` [PATCH 24/41] wl3501_cs: Fix misspelling and provide missing documentation Lee Jones
2020-11-02 11:23 ` [PATCH 25/41] rtlwifi: halbtc8723b2ant: Remove a bunch of set but unused variables Lee Jones
2020-11-02 11:23 ` [PATCH 26/41] rtlwifi: phy: Remove set but unused variable 'bbvalue' Lee Jones
2020-11-02 11:23 ` [PATCH 27/41] rtlwifi: halbtc8821a1ant: Remove set but unused variable 'wifi_rssi_state' Lee Jones
2020-11-02 11:23 ` [PATCH 28/41] rtl8723be: phy: Remove set but unused variable 'lc_cal' Lee Jones
2020-11-02 11:23 ` [PATCH 29/41] rtl8188ee: phy: Remove set but unused variable 'reg_ea4' Lee Jones
2020-11-02 11:23 ` [PATCH 30/41] rtlwifi: halbtc8821a2ant: Remove a bunch of unused variables Lee Jones
2020-11-02 11:24 ` Lee Jones [this message]
2020-11-02 11:24 ` [PATCH 32/41] rtl8723be: trx: Remove set but unused variable 'cck_highpwr' Lee Jones
2020-11-02 11:24 ` [PATCH 33/41] rtlwifi: rtl8821ae: phy: Remove a couple of unused variables Lee Jones
2020-11-02 11:24 ` [PATCH 34/41] rtl8821ae: phy: Place braces around empty if() body Lee Jones
2020-11-02 11:24 ` [PATCH 35/41] wlcore: spi: Demote a non-compliant function header, fix another Lee Jones
2020-11-02 11:24 ` [PATCH 36/41] rtw8822b: Return type is not const Lee Jones
2020-11-07 16:10   ` [36/41] rtw88: " Kalle Valo
2020-11-02 11:24 ` [PATCH 37/41] iwlwifi: fw: dbg: Fix misspelling of 'reg_data' in function header Lee Jones
2020-11-02 11:24 ` [PATCH 38/41] realtek: rtw8822c: Remove unused variable 'corr_val' Lee Jones
2020-11-07 16:11   ` [38/41] rtw88: " Kalle Valo
2020-11-02 11:24 ` [PATCH 39/41] ath9k: dynack: Demote non-compliant function header Lee Jones
2020-11-02 11:24 ` [PATCH 40/41] iwlwifi: fw: acpi: Demote non-conformant function headers Lee Jones
2020-11-02 11:24 ` [PATCH 41/41] realtek: rtw88: pci: Add prototypes for .probe, .remove and .shutdown Lee Jones
2020-11-03  0:06   ` Brian Norris
2020-11-03  8:44     ` Lee Jones
2020-11-07 16:28       ` Kalle Valo
2020-11-07 18:42         ` Lee Jones
2020-11-02 15:42 ` [PATCH 00/41] [Set 4] Rid W=1 warnings in Wireless Kalle Valo
2020-11-06 13:28   ` Lee Jones
2020-11-06 13:35     ` Kalle Valo
2020-11-06 14:35       ` Lee Jones

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201102112410.1049272-32-lee.jones@linaro.org \
    --to=lee.jones@linaro.org \
    --cc=amitkarwar@gmail.com \
    --cc=davem@davemloft.net \
    --cc=ganapathi.bhat@nxp.com \
    --cc=huxinming820@gmail.com \
    --cc=kuba@kernel.org \
    --cc=kvalo@codeaurora.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).