linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: frowand.list@gmail.com
To: Rob Herring <robh+dt@kernel.org>,
	pantelis.antoniou@konsulko.com,
	Pantelis Antoniou <panto@antoniou-consulting.com>
Cc: devicetree@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: [RFC PATCH 13/13] of: Remove unused variable overlay_symbols
Date: Tue, 25 Oct 2016 13:59:06 -0700	[thread overview]
Message-ID: <1477429146-27039-14-git-send-email-frowand.list@gmail.com> (raw)
In-Reply-To: <1477429146-27039-1-git-send-email-frowand.list@gmail.com>

From: Frank Rowand <frank.rowand@am.sony.com>

This unused variable is a reminder that symbols in overlays are
not available to subsequent overlays.  If such a feature is
desired then there are several ways it could be implemented.

Signed-off-by: Frank Rowand <frank.rowand@am.sony.com>
---
 drivers/of/resolver.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/of/resolver.c b/drivers/of/resolver.c
index 3f7cf569c7ea..b48d16200ccd 100644
--- a/drivers/of/resolver.c
+++ b/drivers/of/resolver.c
@@ -272,7 +272,7 @@ static int adjust_local_phandle_references(struct device_node *local_fixups,
 int of_resolve_phandles(struct device_node *overlay)
 {
 	struct device_node *child, *local_fixups, *refnode;
-	struct device_node *tree_symbols, *overlay_symbols, *overlay_fixups;
+	struct device_node *tree_symbols, *overlay_fixups;
 	struct property *prop;
 	const char *refpath;
 	phandle phandle, phandle_delta;
@@ -302,12 +302,9 @@ int of_resolve_phandles(struct device_node *overlay)
 	if (err)
 		goto err_out;
 
-	overlay_symbols = NULL;
 	overlay_fixups = NULL;
 
 	for_each_child_of_node(overlay, child) {
-		if (!of_node_cmp(child->name, "__symbols__"))
-			overlay_symbols = child;
 		if (!of_node_cmp(child->name, "__fixups__"))
 			overlay_fixups = child;
 	}
-- 
1.9.1

  parent reply	other threads:[~2016-10-25 21:00 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-25 20:58 [RFC PATCH 00/13] of: Make drivers/of/resolver.c more readable frowand.list
2016-10-25 20:58 ` [RFC PATCH 01/13] of: Remove comments that state the obvious frowand.list
2016-10-25 21:29   ` Joe Perches
2016-10-27 12:18   ` Rob Herring
2016-10-27 16:02     ` Frank Rowand
2016-10-25 20:58 ` [RFC PATCH 02/13] of: Remove excessive printks to reduce clutter frowand.list
2016-10-27 12:21   ` Rob Herring
2016-10-27 13:51     ` Pantelis Antoniou
2016-10-27 16:09       ` Frank Rowand
2016-10-27 16:04     ` Frank Rowand
2016-10-25 20:58 ` [RFC PATCH 03/13] of: Remove braces around single line blocks frowand.list
2016-10-25 20:58 ` [RFC PATCH 04/13] of: Convert comparisons to zero or NULL to simplify logical expressions frowand.list
2016-10-25 20:58 ` [RFC PATCH 05/13] of: Rename functions to more accurately reflect what they do frowand.list
2016-10-25 20:58 ` [RFC PATCH 06/13] of: Remove prefix "__of_" and prefix "__" from local function names frowand.list
2016-10-27 12:47   ` Rob Herring
2016-10-27 16:35     ` Frank Rowand
2016-10-27 16:58       ` Rob Herring
2016-10-27 18:25         ` Frank Rowand
2016-10-27 20:20           ` Rob Herring
2016-10-25 20:59 ` [RFC PATCH 07/13] of: Rename variables to better reflect purpose or follow convention frowand.list
2016-10-25 20:59 ` [RFC PATCH 08/13] of: Update structure of code, remove BUG_ON() frowand.list
2016-10-25 20:59 ` [RFC PATCH 09/13] of: Remove redundant size check frowand.list
2016-10-25 20:59 ` [RFC PATCH 10/13] of: Update comments to reflect changes and increase clarity frowand.list
2016-10-25 20:59 ` [RFC PATCH 11/13] of: Add back an error message, restructured frowand.list
2016-10-25 20:59 ` [RFC PATCH 12/13] of: Move setting of pointer to beside test for non-null frowand.list
2016-10-25 20:59 ` frowand.list [this message]
2016-10-27 14:41   ` [RFC PATCH 13/13] of: Remove unused variable overlay_symbols Pantelis Antoniou
2016-10-27 16:27     ` Frank Rowand
2016-10-27 16:53       ` Frank Rowand
2016-10-27 16:57         ` Frank Rowand
2016-10-25 21:02 ` [RFC PATCH 00/13] of: Make drivers/of/resolver.c more readable Frank Rowand
2016-10-27 12:03   ` Rob Herring
2016-10-27 16:36     ` Frank Rowand
2016-10-27 13:46   ` Pantelis Antoniou

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1477429146-27039-14-git-send-email-frowand.list@gmail.com \
    --to=frowand.list@gmail.com \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pantelis.antoniou@konsulko.com \
    --cc=panto@antoniou-consulting.com \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).