linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: frowand.list@gmail.com
To: Rob Herring <robh+dt@kernel.org>,
	pantelis.antoniou@konsulko.com,
	Pantelis Antoniou <panto@antoniou-consulting.com>
Cc: devicetree@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: [RFC PATCH 05/13] of: Rename functions to more accurately reflect what they do
Date: Tue, 25 Oct 2016 13:58:58 -0700	[thread overview]
Message-ID: <1477429146-27039-6-git-send-email-frowand.list@gmail.com> (raw)
In-Reply-To: <1477429146-27039-1-git-send-email-frowand.list@gmail.com>

From: Frank Rowand <frank.rowand@am.sony.com>

Signed-off-by: Frank Rowand <frank.rowand@am.sony.com>
---
 drivers/of/resolver.c | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)

diff --git a/drivers/of/resolver.c b/drivers/of/resolver.c
index 31fd3800787a..3d123b612789 100644
--- a/drivers/of/resolver.c
+++ b/drivers/of/resolver.c
@@ -53,7 +53,7 @@ static struct device_node *__of_find_node_by_full_name(struct device_node *node,
 /*
  * Find live tree's maximum phandle value.
  */
-static phandle of_get_tree_max_phandle(void)
+static phandle live_tree_max_phandle(void)
 {
 	struct device_node *node;
 	phandle phandle;
@@ -74,7 +74,7 @@ static phandle of_get_tree_max_phandle(void)
 /*
  * Adjust a subtree's phandle values by a given delta.
  */
-static void __of_adjust_tree_phandles(struct device_node *node,
+static void adjust_overlay_phandles(struct device_node *node,
 		int phandle_delta)
 {
 	struct device_node *child;
@@ -101,10 +101,10 @@ static void __of_adjust_tree_phandles(struct device_node *node,
 	}
 
 	for_each_child_of_node(node, child)
-		__of_adjust_tree_phandles(child, phandle_delta);
+		adjust_overlay_phandles(child, phandle_delta);
 }
 
-static int __of_adjust_phandle_ref(struct device_node *node,
+static int update_usages_of_a_phandle_reference(struct device_node *node,
 		struct property *rprop, int value)
 {
 	phandle phandle;
@@ -184,7 +184,7 @@ static int __of_node_name_cmp(const struct device_node *dn1,
  * Does not take any devtree locks so make sure you call this on a tree
  * which is at the detached state.
  */
-static int __of_adjust_tree_phandle_references(struct device_node *node,
+static int adjust_local_phandle_references(struct device_node *node,
 		struct device_node *target, int phandle_delta)
 {
 	struct device_node *child, *childtarget;
@@ -238,7 +238,7 @@ static int __of_adjust_tree_phandle_references(struct device_node *node,
 		if (!childtarget)
 			return -EINVAL;
 
-		err = __of_adjust_tree_phandle_references(child, childtarget,
+		err = adjust_local_phandle_references(child, childtarget,
 				phandle_delta);
 		if (err)
 			return err;
@@ -277,8 +277,8 @@ int of_resolve_phandles(struct device_node *resolve)
 	if (!resolve || !of_node_check_flag(resolve, OF_DETACHED))
 		return -EINVAL;
 
-	phandle_delta = of_get_tree_max_phandle() + 1;
-	__of_adjust_tree_phandles(resolve, phandle_delta);
+	phandle_delta = live_tree_max_phandle() + 1;
+	adjust_overlay_phandles(resolve, phandle_delta);
 
 	childroot = NULL;
 	for_each_child_of_node(resolve, childroot)
@@ -286,12 +286,12 @@ int of_resolve_phandles(struct device_node *resolve)
 			break;
 
 	if (childroot != NULL) {
-		err = __of_adjust_tree_phandle_references(childroot,
+		err = adjust_local_phandle_references(childroot,
 				resolve, 0);
 		if (err)
 			return err;
 
-		BUG_ON(__of_adjust_tree_phandle_references(childroot,
+		BUG_ON(adjust_local_phandle_references(childroot,
 				resolve, phandle_delta));
 	}
 
@@ -344,7 +344,7 @@ int of_resolve_phandles(struct device_node *resolve)
 		phandle = refnode->phandle;
 		of_node_put(refnode);
 
-		err = __of_adjust_phandle_ref(resolve, rprop, phandle);
+		err = update_usages_of_a_phandle_reference(resolve, rprop, phandle);
 		if (err)
 			break;
 	}
-- 
1.9.1

  parent reply	other threads:[~2016-10-25 21:02 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-25 20:58 [RFC PATCH 00/13] of: Make drivers/of/resolver.c more readable frowand.list
2016-10-25 20:58 ` [RFC PATCH 01/13] of: Remove comments that state the obvious frowand.list
2016-10-25 21:29   ` Joe Perches
2016-10-27 12:18   ` Rob Herring
2016-10-27 16:02     ` Frank Rowand
2016-10-25 20:58 ` [RFC PATCH 02/13] of: Remove excessive printks to reduce clutter frowand.list
2016-10-27 12:21   ` Rob Herring
2016-10-27 13:51     ` Pantelis Antoniou
2016-10-27 16:09       ` Frank Rowand
2016-10-27 16:04     ` Frank Rowand
2016-10-25 20:58 ` [RFC PATCH 03/13] of: Remove braces around single line blocks frowand.list
2016-10-25 20:58 ` [RFC PATCH 04/13] of: Convert comparisons to zero or NULL to simplify logical expressions frowand.list
2016-10-25 20:58 ` frowand.list [this message]
2016-10-25 20:58 ` [RFC PATCH 06/13] of: Remove prefix "__of_" and prefix "__" from local function names frowand.list
2016-10-27 12:47   ` Rob Herring
2016-10-27 16:35     ` Frank Rowand
2016-10-27 16:58       ` Rob Herring
2016-10-27 18:25         ` Frank Rowand
2016-10-27 20:20           ` Rob Herring
2016-10-25 20:59 ` [RFC PATCH 07/13] of: Rename variables to better reflect purpose or follow convention frowand.list
2016-10-25 20:59 ` [RFC PATCH 08/13] of: Update structure of code, remove BUG_ON() frowand.list
2016-10-25 20:59 ` [RFC PATCH 09/13] of: Remove redundant size check frowand.list
2016-10-25 20:59 ` [RFC PATCH 10/13] of: Update comments to reflect changes and increase clarity frowand.list
2016-10-25 20:59 ` [RFC PATCH 11/13] of: Add back an error message, restructured frowand.list
2016-10-25 20:59 ` [RFC PATCH 12/13] of: Move setting of pointer to beside test for non-null frowand.list
2016-10-25 20:59 ` [RFC PATCH 13/13] of: Remove unused variable overlay_symbols frowand.list
2016-10-27 14:41   ` Pantelis Antoniou
2016-10-27 16:27     ` Frank Rowand
2016-10-27 16:53       ` Frank Rowand
2016-10-27 16:57         ` Frank Rowand
2016-10-25 21:02 ` [RFC PATCH 00/13] of: Make drivers/of/resolver.c more readable Frank Rowand
2016-10-27 12:03   ` Rob Herring
2016-10-27 16:36     ` Frank Rowand
2016-10-27 13:46   ` Pantelis Antoniou

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1477429146-27039-6-git-send-email-frowand.list@gmail.com \
    --to=frowand.list@gmail.com \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pantelis.antoniou@konsulko.com \
    --cc=panto@antoniou-consulting.com \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).