linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: frowand.list@gmail.com
To: Rob Herring <robh+dt@kernel.org>,
	pantelis.antoniou@konsulko.com,
	Pantelis Antoniou <panto@antoniou-consulting.com>
Cc: devicetree@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: [PATCH 08/12] of: Remove redundant size check
Date: Fri, 28 Oct 2016 23:26:28 -0700	[thread overview]
Message-ID: <1477722392-32172-9-git-send-email-frowand.list@gmail.com> (raw)
In-Reply-To: <1477722392-32172-1-git-send-email-frowand.list@gmail.com>

From: Frank Rowand <frank.rowand@am.sony.com>

Remove a redundant check of buffer size.

Signed-off-by: Frank Rowand <frank.rowand@am.sony.com>
---
 drivers/of/resolver.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/of/resolver.c b/drivers/of/resolver.c
index 708daca1d522..76c09cb57eae 100644
--- a/drivers/of/resolver.c
+++ b/drivers/of/resolver.c
@@ -216,7 +216,7 @@ static int adjust_local_phandle_references(struct device_node *local_fixups,
 
 		for (i = 0; i < count; i++) {
 			off = be32_to_cpu(((__be32 *)prop_fix->value)[i]);
-			if (off >= prop->length || (off + 4) > prop->length)
+			if ((off + 4) > prop->length)
 				return -EINVAL;
 
 			phandle = be32_to_cpu(*(__be32 *)(prop->value + off));
-- 
1.9.1

  parent reply	other threads:[~2016-10-29  6:29 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-29  6:26 [PATCH 00/12] of: Make drivers/of/resolver.c more readable frowand.list
2016-10-29  6:26 ` [PATCH 01/12] of: Remove comments that state the obvious, to reduce clutter frowand.list
2016-10-29  6:26 ` [PATCH 02/12] of: Remove excessive printks " frowand.list
2016-10-29  6:26 ` [PATCH 03/12] of: Convert comparisons to zero or NULL to logical expressions frowand.list
2016-10-29  6:26 ` [PATCH 04/12] of: Rename functions to more accurately reflect what they do frowand.list
2016-10-29  6:26 ` [PATCH 05/12] of: Remove prefix "__of_" from local function names frowand.list
2016-10-29  6:26 ` [PATCH 06/12] of: Rename variables to better reflect purpose or follow convention frowand.list
2016-10-29  6:26 ` [PATCH 07/12] of: Update structure of code to be clearer, also remove BUG_ON() frowand.list
2016-10-29  6:26 ` frowand.list [this message]
2016-10-29  6:26 ` [PATCH 09/12] of: Update comments to reflect changes and increase clarity frowand.list
2016-10-29  6:26 ` [PATCH 10/12] of: Add back an error message, restructured frowand.list
2016-10-29  6:26 ` [PATCH 11/12] of: Move setting of pointer to beside test for non-null frowand.list
2016-10-29  6:26 ` [PATCH 12/12] of: Remove unused variable overlay_symbols frowand.list
2016-11-10 20:56 ` [PATCH 00/12] of: Make drivers/of/resolver.c more readable Rob Herring

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1477722392-32172-9-git-send-email-frowand.list@gmail.com \
    --to=frowand.list@gmail.com \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pantelis.antoniou@konsulko.com \
    --cc=panto@antoniou-consulting.com \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).