linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: iommu@lists.linux-foundation.org
Cc: "Konrad Rzeszutek Wilk" <konrad@darnok.org>,
	"Michal Simek" <monstr@monstr.eu>,
	"Guan Xuetao" <gxt@mprc.pku.edu.cn>,
	"Christian König" <ckoenig.leichtzumerken@gmail.com>,
	linux-arm-kernel@lists.infradead.org, linux-ia64@vger.kernel.org,
	linux-mips@linux-mips.org, linuxppc-dev@lists.ozlabs.org,
	x86@kernel.org, linux-arch@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: [PATCH 04/22] powerpc: rename swiotlb_dma_ops
Date: Wed, 10 Jan 2018 09:09:14 +0100	[thread overview]
Message-ID: <20180110080932.14157-5-hch@lst.de> (raw)
In-Reply-To: <20180110080932.14157-1-hch@lst.de>

We'll need that name for a generic implementation soon.

Signed-off-by: Christoph Hellwig <hch@lst.de>
---
 arch/powerpc/include/asm/swiotlb.h | 2 +-
 arch/powerpc/kernel/dma-swiotlb.c  | 4 ++--
 arch/powerpc/kernel/dma.c          | 2 +-
 arch/powerpc/sysdev/fsl_pci.c      | 2 +-
 4 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/arch/powerpc/include/asm/swiotlb.h b/arch/powerpc/include/asm/swiotlb.h
index 9341ee804d19..f65ecf57b66c 100644
--- a/arch/powerpc/include/asm/swiotlb.h
+++ b/arch/powerpc/include/asm/swiotlb.h
@@ -13,7 +13,7 @@
 
 #include <linux/swiotlb.h>
 
-extern const struct dma_map_ops swiotlb_dma_ops;
+extern const struct dma_map_ops powerpc_swiotlb_dma_ops;
 
 extern unsigned int ppc_swiotlb_enable;
 int __init swiotlb_setup_bus_notifier(void);
diff --git a/arch/powerpc/kernel/dma-swiotlb.c b/arch/powerpc/kernel/dma-swiotlb.c
index f1e99b9cee97..506ac4fafac5 100644
--- a/arch/powerpc/kernel/dma-swiotlb.c
+++ b/arch/powerpc/kernel/dma-swiotlb.c
@@ -46,7 +46,7 @@ static u64 swiotlb_powerpc_get_required(struct device *dev)
  * map_page, and unmap_page on highmem, use normal dma_ops
  * for everything else.
  */
-const struct dma_map_ops swiotlb_dma_ops = {
+const struct dma_map_ops powerpc_swiotlb_dma_ops = {
 	.alloc = __dma_nommu_alloc_coherent,
 	.free = __dma_nommu_free_coherent,
 	.mmap = dma_nommu_mmap_coherent,
@@ -89,7 +89,7 @@ static int ppc_swiotlb_bus_notify(struct notifier_block *nb,
 
 	/* May need to bounce if the device can't address all of DRAM */
 	if ((dma_get_mask(dev) + 1) < memblock_end_of_DRAM())
-		set_dma_ops(dev, &swiotlb_dma_ops);
+		set_dma_ops(dev, &powerpc_swiotlb_dma_ops);
 
 	return NOTIFY_DONE;
 }
diff --git a/arch/powerpc/kernel/dma.c b/arch/powerpc/kernel/dma.c
index 76079841d3d0..da20569de9d4 100644
--- a/arch/powerpc/kernel/dma.c
+++ b/arch/powerpc/kernel/dma.c
@@ -33,7 +33,7 @@ static u64 __maybe_unused get_pfn_limit(struct device *dev)
 	struct dev_archdata __maybe_unused *sd = &dev->archdata;
 
 #ifdef CONFIG_SWIOTLB
-	if (sd->max_direct_dma_addr && dev->dma_ops == &swiotlb_dma_ops)
+	if (sd->max_direct_dma_addr && dev->dma_ops == &powerpc_swiotlb_dma_ops)
 		pfn = min_t(u64, pfn, sd->max_direct_dma_addr >> PAGE_SHIFT);
 #endif
 
diff --git a/arch/powerpc/sysdev/fsl_pci.c b/arch/powerpc/sysdev/fsl_pci.c
index e4d0133bbeeb..61e07c78d64f 100644
--- a/arch/powerpc/sysdev/fsl_pci.c
+++ b/arch/powerpc/sysdev/fsl_pci.c
@@ -118,7 +118,7 @@ static void setup_swiotlb_ops(struct pci_controller *hose)
 {
 	if (ppc_swiotlb_enable) {
 		hose->controller_ops.dma_dev_setup = pci_dma_dev_setup_swiotlb;
-		set_pci_dma_ops(&swiotlb_dma_ops);
+		set_pci_dma_ops(&powerpc_swiotlb_dma_ops);
 	}
 }
 #else
-- 
2.14.2

  parent reply	other threads:[~2018-01-10  8:09 UTC|newest]

Thread overview: 45+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-01-10  8:09 consolidate swiotlb dma_map implementations Christoph Hellwig
2018-01-10  8:09 ` [PATCH 01/22] swiotlb: suppress warning when __GFP_NOWARN is set Christoph Hellwig
2018-01-10  8:09 ` [PATCH 02/22] arm64: rename swiotlb_dma_ops Christoph Hellwig
2018-01-10 12:13   ` Robin Murphy
2018-01-10  8:09 ` [PATCH 03/22] ia64: " Christoph Hellwig
2018-01-12 13:24   ` Konrad Rzeszutek Wilk
2018-01-10  8:09 ` Christoph Hellwig [this message]
2018-01-12 13:25   ` [PATCH 04/22] powerpc: " Konrad Rzeszutek Wilk
2018-01-10  8:09 ` [PATCH 05/22] x86: " Christoph Hellwig
2018-01-12 13:25   ` Konrad Rzeszutek Wilk
2018-01-10  8:09 ` [PATCH 06/22] swiotlb: rename swiotlb_free to swiotlb_exit Christoph Hellwig
2018-01-12 13:39   ` Konrad Rzeszutek Wilk
2018-01-10  8:09 ` [PATCH 07/22] swiotlb: add common swiotlb_map_ops Christoph Hellwig
2018-01-10  8:09 ` [PATCH 08/22] swiotlb: wire up ->dma_supported in swiotlb_dma_ops Christoph Hellwig
2018-01-10 12:16   ` Robin Murphy
2018-01-10 15:35     ` Christoph Hellwig
2018-01-10 17:23       ` Robin Murphy
2018-01-10  8:09 ` [PATCH 09/22] swiotlb: refactor coherent buffer freeing Christoph Hellwig
2018-01-10  8:09 ` [PATCH 10/22] swiotlb: refactor coherent buffer allocation Christoph Hellwig
2018-01-10 12:22   ` Robin Murphy
2018-01-10 15:46     ` Christoph Hellwig
2018-01-10 17:02       ` Robin Murphy
2018-01-15  9:10         ` Christoph Hellwig
2018-01-10  8:09 ` [PATCH 11/22] swiotlb: remove various exports Christoph Hellwig
2018-01-10  8:09 ` [PATCH 12/22] ia64: replace ZONE_DMA with ZONE_DMA32 Christoph Hellwig
2018-01-10  8:09 ` [PATCH 13/22] ia64: use generic swiotlb_ops Christoph Hellwig
2018-01-10  8:09 ` [PATCH 14/22] ia64: clean up swiotlb support Christoph Hellwig
2018-01-10  8:09 ` [PATCH 15/22] ia64: remove an ifdef around the content of pci-dma.c Christoph Hellwig
2018-01-10  8:09 ` [PATCH 16/22] unicore32: use generic swiotlb_ops Christoph Hellwig
2018-01-10  8:09 ` [PATCH 17/22] tile: replace ZONE_DMA with ZONE_DMA32 Christoph Hellwig
2018-01-10  8:09 ` [PATCH 18/22] tile: use generic swiotlb_ops Christoph Hellwig
2018-01-10  8:09 ` [PATCH 19/22] mips/netlogic: remove swiotlb support Christoph Hellwig
2018-01-10  8:09 ` [PATCH 20/22] mips: use swiotlb_{alloc,free} Christoph Hellwig
2018-01-10  8:09 ` [PATCH 21/22] arm64: replace ZONE_DMA with ZONE_DMA32 Christoph Hellwig
2018-01-10 12:58   ` Robin Murphy
2018-01-10 15:55     ` Christoph Hellwig
2018-01-10 15:55       ` Christoph Hellwig
2018-01-10 17:10         ` Robin Murphy
2018-01-10  8:09 ` [PATCH 22/22] arm64: use swiotlb_alloc and swiotlb_free Christoph Hellwig
2018-01-10 13:16   ` Robin Murphy
2018-01-10  8:23 ` consolidate swiotlb dma_map implementations Christian König
2018-01-16  7:53 ` Christoph Hellwig
2018-01-16  8:22   ` Christian König
2018-01-16  8:28     ` Christoph Hellwig
2018-01-16  8:52       ` Christian König

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180110080932.14157-5-hch@lst.de \
    --to=hch@lst.de \
    --cc=ckoenig.leichtzumerken@gmail.com \
    --cc=gxt@mprc.pku.edu.cn \
    --cc=iommu@lists.linux-foundation.org \
    --cc=konrad@darnok.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mips@linux-mips.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=monstr@monstr.eu \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).