From: Hans de Goede <hdegoede@redhat.com>
To: Kate Hsuan <hpa@redhat.com>, Mark Gross <mgross@linux.intel.com>,
Alex Hung <alex.hung@canonical.com>,
Sujith Thomas <sujith.thomas@intel.com>,
Rajneesh Bhardwaj <irenic.rajneesh@gmail.com>,
David E Box <david.e.box@intel.com>,
Zha Qipeng <qipeng.zha@intel.com>,
Mika Westerberg <mika.westerberg@linux.intel.com>,
Srinivas Pandruvada <srinivas.pandruvada@linux.intel.com>,
AceLan Kao <acelan.kao@canonical.com>,
Jithu Joseph <jithu.joseph@intel.com>,
Maurice Ma <maurice.ma@intel.com>,
Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Dan Carpenter <dan.carpenter@oracle.com>,
Daniel Scally <djrscally@gmail.com>,
linux-kernel@vger.kernel.org, Dell.Client.Kernel@dell.com
Cc: platform-driver-x86@vger.kernel.org
Subject: Re: [PATCH 00/20] Move Intel platform drivers to intel directory to improve readability.
Date: Tue, 10 Aug 2021 16:05:28 +0200 [thread overview]
Message-ID: <3a69ebb0-b27d-e8d5-e219-c6ee388cd628@redhat.com> (raw)
In-Reply-To: <20210810095832.4234-1-hpa@redhat.com>
Hi Kate,
On 8/10/21 11:58 AM, Kate Hsuan wrote:
> All the intel platform specific drivers are moved to intel/.
> It makes more clear file structure to improve the readability.
>
> Kate Hsuan (20):
> Move Intel hid of pdx86 to intel directory to improve readability.
> Move Intel WMI driver of pdx86 to intel/ directory to improve
> readability.
> Move Intel bxtwc driver of pdx86 to intel/ directory to improve
> readability.
> Move Intel chtdc_ti driver of pdx86 to improve readability.
> Move MRFLD power button driver of pdx86 to intel directory to improve
> readability.
> Move Intel PMC core of pdx86 to intel/ directory to improve
> readability.
> Move Intel PMT driver of pdx86 to intel/ to improve readability.
> Move Intel P-Unit of pdx86 to intel/ directory to improve readability.
> Move Intel SCU IPC of pdx86 to intel directory to increase
> readability.
> Move Intel SoC telemetry driver to intel directory to improve
> readability.
> Move Intel IPS driver of pdx86 to improve readability.
> Move Intel RST driver of pdx86 to intel directory to improve
> readability.
> Move Intel smartconnect driver of pdx86 to intel/ directory to improve
> readability.
> Move Intel SST driver to intel/ directory to improve readability.
> Move Intel turbo max 3 driver to intel/ directory to improve
> readability.
> Move Intel uncore freq driver to intel/ directory to improve
> readability.
> Move Intel int0002 vgpio driver to intel/ directory to inprove
> readability.
> Move Intel thermal driver for menlow platform driver to intel/
> directory to improve readability.
> Move OakTrail driver to the intel/ directory to improve readability.
> Move Intel virtual botton driver to intel/ directory to improve
> readability.
Thank you for doing this. I have a couple of remarks which I would
like to see addressed for version 2 of this series:
1. The commit messages are currently all one line, so basically
only a Subject and they are missing a Body describing the change
in more detail (as already pointed out by Mika).
2. Kernel patch subjects (the first line of the commit message)
should always be prefixed with the subsystem + component which they
are for, so instead of e.g.
"Move Intel hid of pdx86 to intel directory to improve readability."
you would use:
"platform/x86: intel-hid: Move to intel sub-directory to improve readability."
But that is a bit long; and normally the Subject line is just
a summary while the body explains things like the why, so this should
probably be shorted to:
"platform/x86: intel-hid: Move to intel sub-directory"
For the Subject, with the Body explaining what exactly is being changed
and why.
3. You are using new sub-directories for all drivers which you
are moving, but for drivers which are currently just 1 c-file, this
means going from 1 c-file to 3 files (c-file + Kconfig + Makefile)
this seems a bit too much. I believe that it would be better for
the single file drivers (e.g. intel-hid.c, intel-vbtn.c) to be moved
directly under drivers/platform/x86/intel and for there Kconfig
and Makefile bits to be moved to the already existing Kconfig
and Makefile files there.
4. As Andy already mentioned when moving a file like
"intel_scu_ipc.c" to drivers/platform/x86/intel/scu then the
whole path becomes:
drivers/platform/x86/intel/scu/intel_scu_ipc.c
Which is quite long / quite a lot to type and repeats
intel + scu twice, so it would be better to drop the intel_scu
prefix from the filenames in this case resulting in:
drivers/platform/x86/intel/scu/ipc.c
in this example's case. This requires some extrea work:
4.1 You will need to adjust private includes to the new
filenames
4.2 If you simply adjust say this Makefile line:
obj-$(CONFIG_INTEL_SCU_PCI) += intel_scu_pcidrv.o
to:
obj-$(CONFIG_INTEL_SCU_PCI) += pcidrv.o
a pcidrv.ko will get build, but that is a very generic name
and then we end up with module-name clashes which are not
allowed.
So the Makefile needs to become a bit more complicated like this:
intel_scu_pcidrv-y := pcidrv.o
obj-$(CONFIG_INTEL_SCU_PCI) += intel_scu_pcidrv.o
See for example:
https://git.kernel.org/pub/scm/linux/kernel/git/pdx86/platform-drivers-x86.git/tree/drivers/platform/x86/intel/pmt/Makefile?h=for-next
5. Some of the files which you are moving are mentioned in the
MAINTAINERS file. For each file which you are moving please check if
it is listed in the MAINTAINERS file, keeping wildcards in mind,
so search e.g. for intel_scu for the intel_scu_* move.
And if the file is listed then update the MAINTAINERS entry to
point to the new location.
Regards,
Hans
next prev parent reply other threads:[~2021-08-10 14:05 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-08-10 9:58 [PATCH 00/20] Move Intel platform drivers to intel directory to improve readability Kate Hsuan
2021-08-10 9:58 ` [PATCH 01/20] Move Intel hid of pdx86 " Kate Hsuan
2021-08-10 9:58 ` [PATCH 02/20] Move Intel WMI driver of pdx86 to intel/ " Kate Hsuan
2021-08-10 9:58 ` [PATCH 03/20] Move Intel bxtwc " Kate Hsuan
2021-08-10 9:58 ` [PATCH 04/20] Move Intel chtdc_ti driver of pdx86 " Kate Hsuan
2021-08-10 9:58 ` [PATCH 05/20] Move MRFLD power button driver of pdx86 to intel directory " Kate Hsuan
2021-08-10 9:58 ` [PATCH 06/20] Move Intel PMC core of pdx86 to intel/ " Kate Hsuan
2021-08-10 9:58 ` [PATCH 07/20] Move Intel PMT driver of pdx86 to intel/ " Kate Hsuan
2021-08-10 16:51 ` David E. Box
2021-08-10 9:58 ` [PATCH 08/20] Move Intel P-Unit of pdx86 to intel/ directory " Kate Hsuan
2021-08-10 16:55 ` David E. Box
2021-08-11 5:43 ` Kate Hsuan
2021-08-10 9:58 ` [PATCH 09/20] Move Intel SCU IPC of pdx86 to intel directory to increase readability Kate Hsuan
2021-08-10 10:05 ` Mika Westerberg
2021-08-10 11:43 ` Kate Hsuan
2021-08-10 13:27 ` Andy Shevchenko
2021-08-10 9:58 ` [PATCH 10/20] Move Intel SoC telemetry driver to intel directory to improve readability Kate Hsuan
2021-08-10 9:58 ` [PATCH 11/20] Move Intel IPS driver of pdx86 " Kate Hsuan
2021-08-10 9:58 ` [PATCH 12/20] Move Intel RST driver of pdx86 to intel directory " Kate Hsuan
2021-08-10 9:58 ` [PATCH 13/20] Move Intel smartconnect driver of pdx86 to intel/ " Kate Hsuan
2021-08-10 9:58 ` [PATCH 14/20] Move Intel SST driver " Kate Hsuan
2021-08-10 9:58 ` [PATCH 15/20] Move Intel turbo max 3 " Kate Hsuan
2021-08-10 9:58 ` [PATCH 16/20] Move Intel uncore freq " Kate Hsuan
2021-08-10 9:58 ` [PATCH 17/20] Move Intel int0002 vgpio driver to intel/ directory to inprove readability Kate Hsuan
2021-08-10 9:58 ` [PATCH 18/20] Move Intel thermal driver for menlow platform driver to intel/ directory to improve readability Kate Hsuan
2021-08-14 10:39 ` Daniel Lezcano
2021-08-15 14:08 ` Hans de Goede
2021-08-16 3:11 ` Pandruvada, Srinivas
2021-08-16 7:40 ` Hans de Goede
2021-08-16 7:43 ` Kate Hsuan
2021-08-10 9:58 ` [PATCH 19/20] Move OakTrail driver to the " Kate Hsuan
2021-08-10 9:58 ` [PATCH 20/20] Move Intel virtual botton driver to " Kate Hsuan
2021-08-10 13:23 ` [PATCH 00/20] Move Intel platform drivers to intel " Andy Shevchenko
2021-08-11 12:41 ` Andy Shevchenko
2021-08-10 14:05 ` Hans de Goede [this message]
2021-08-11 9:06 ` Kate Hsuan
2021-08-10 17:03 ` David E. Box
2021-08-10 17:28 ` Randy Dunlap
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3a69ebb0-b27d-e8d5-e219-c6ee388cd628@redhat.com \
--to=hdegoede@redhat.com \
--cc=Dell.Client.Kernel@dell.com \
--cc=acelan.kao@canonical.com \
--cc=alex.hung@canonical.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=dan.carpenter@oracle.com \
--cc=david.e.box@intel.com \
--cc=djrscally@gmail.com \
--cc=hpa@redhat.com \
--cc=irenic.rajneesh@gmail.com \
--cc=jithu.joseph@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=maurice.ma@intel.com \
--cc=mgross@linux.intel.com \
--cc=mika.westerberg@linux.intel.com \
--cc=platform-driver-x86@vger.kernel.org \
--cc=qipeng.zha@intel.com \
--cc=srinivas.pandruvada@linux.intel.com \
--cc=sujith.thomas@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).