QEMU-Devel Archive on lore.kernel.org
 help / color / Atom feed
* [Bug 1851664] Re: qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's to guest machine
       [not found] <157313838504.19702.7205622932379991141.malonedeb@wampee.canonical.com>
@ 2019-11-07 16:37 ` Thomas Huth
  2019-11-07 17:45 ` IndrasenaReddy Gali
                   ` (3 subsequent siblings)
  4 siblings, 0 replies; 5+ messages in thread
From: Thomas Huth @ 2019-11-07 16:37 UTC (permalink / raw)
  To: qemu-devel

Please provide information how you started QEMU, and some information
about your PCI device (e.g. the output of lspci).

** Information type changed from Private Security to Public

** Changed in: qemu
       Status: New => Incomplete

-- 
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1851664

Title:
  qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's
  to guest machine

Status in QEMU:
  Incomplete

Bug description:
  We are trying to attach 6 VF's to the guest machine on 4.1.1 qemu emulator.
  We are observing "VFIO_MAP_DMA : -28" error.

  We are using w-bits=48 bits while lunching VM.

To manage notifications about this bug go to:
https://bugs.launchpad.net/qemu/+bug/1851664/+subscriptions


^ permalink raw reply	[flat|nested] 5+ messages in thread

* [Bug 1851664] Re: qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's to guest machine
       [not found] <157313838504.19702.7205622932379991141.malonedeb@wampee.canonical.com>
  2019-11-07 16:37 ` [Bug 1851664] Re: qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's to guest machine Thomas Huth
@ 2019-11-07 17:45 ` IndrasenaReddy Gali
  2019-11-07 17:46 ` IndrasenaReddy Gali
                   ` (2 subsequent siblings)
  4 siblings, 0 replies; 5+ messages in thread
From: IndrasenaReddy Gali @ 2019-11-07 17:45 UTC (permalink / raw)
  To: qemu-devel

qemu-system-x86_64 -name guest=fedora24 -machine q35,accel=kvm,kernel-irqchip=split \
        -enable-kvm \
        -m 4G \
        -smp 8,sockets=1,cores=8,threads=1 \
        -device intel-iommu,intremap=on,caching-mode=on,aw-bits=48  \
        -drive file=<OS_IMAGE_FILE>,format=raw \
        -device ioh3420,id=pcie.1,chassis=1 \
        -device virtio-net-pci,bus=pcie.1,disable-legacy=on,disable-modern=off,iommu_platform=on,ats=on,netdev=net0 \
        -netdev user,id=net0,hostfwd=tcp::1111-:22\
        -device vfio-pci,host=3f:02.1  \
		-device vfio-pci,host=3f:02.2  \
		-device vfio-pci,host=3f:02.3 \
		-device vfio-pci,host=3f:02.4 \
        -device vfio-pci,host=3d:02.4 \
		-device vfio-pci,host=3d:02.5 \
		-device vfio-pci,host=3d:02.6 \
        -nographic

-- 
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1851664

Title:
  qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's
  to guest machine

Status in QEMU:
  Incomplete

Bug description:
  We are trying to attach 6 VF's to the guest machine on 4.1.1 qemu emulator.
  We are observing "VFIO_MAP_DMA : -28" error.

  We are using w-bits=48 bits while lunching VM.

To manage notifications about this bug go to:
https://bugs.launchpad.net/qemu/+bug/1851664/+subscriptions


^ permalink raw reply	[flat|nested] 5+ messages in thread

* [Bug 1851664] Re: qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's to guest machine
       [not found] <157313838504.19702.7205622932379991141.malonedeb@wampee.canonical.com>
  2019-11-07 16:37 ` [Bug 1851664] Re: qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's to guest machine Thomas Huth
  2019-11-07 17:45 ` IndrasenaReddy Gali
@ 2019-11-07 17:46 ` IndrasenaReddy Gali
  2019-11-07 17:46 ` Alex Williamson
  2019-11-08 15:48 ` IndrasenaReddy Gali
  4 siblings, 0 replies; 5+ messages in thread
From: IndrasenaReddy Gali @ 2019-11-07 17:46 UTC (permalink / raw)
  To: qemu-devel

Please find the above qemu command to lunch guest machine

-- 
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1851664

Title:
  qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's
  to guest machine

Status in QEMU:
  Incomplete

Bug description:
  We are trying to attach 6 VF's to the guest machine on 4.1.1 qemu emulator.
  We are observing "VFIO_MAP_DMA : -28" error.

  We are using w-bits=48 bits while lunching VM.

To manage notifications about this bug go to:
https://bugs.launchpad.net/qemu/+bug/1851664/+subscriptions


^ permalink raw reply	[flat|nested] 5+ messages in thread

* [Bug 1851664] Re: qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's to guest machine
       [not found] <157313838504.19702.7205622932379991141.malonedeb@wampee.canonical.com>
                   ` (2 preceding siblings ...)
  2019-11-07 17:46 ` IndrasenaReddy Gali
@ 2019-11-07 17:46 ` Alex Williamson
  2019-11-08 15:48 ` IndrasenaReddy Gali
  4 siblings, 0 replies; 5+ messages in thread
From: Alex Williamson @ 2019-11-07 17:46 UTC (permalink / raw)
  To: qemu-devel

Presumably w-bits (aw-bits?) implies using intel-iommu, there's a
opportunity for the vfio iommu backend to return -ENOSPC (-28) if we
exceed the default number of in-flight DMA mappings per container.  The
default limit is 65535.  You can try increasing this by changing the
dma_entry_limit module option on the vfio_iommu_type1 module.  Note that
in a typical vIOMMU config there's a container per device, so the number
of VFs attached is possibly not a factor.  It is however a lot of DMA
mappings for a single device if this is the issue and you'd generally
want to boot the guest with iommu=pt in order to have reasonable
assigned device performance with a vIOMMU, which would also greatly
reduce the number of mappings.

-- 
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1851664

Title:
  qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's
  to guest machine

Status in QEMU:
  Incomplete

Bug description:
  We are trying to attach 6 VF's to the guest machine on 4.1.1 qemu emulator.
  We are observing "VFIO_MAP_DMA : -28" error.

  We are using w-bits=48 bits while lunching VM.

To manage notifications about this bug go to:
https://bugs.launchpad.net/qemu/+bug/1851664/+subscriptions


^ permalink raw reply	[flat|nested] 5+ messages in thread

* [Bug 1851664] Re: qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's to guest machine
       [not found] <157313838504.19702.7205622932379991141.malonedeb@wampee.canonical.com>
                   ` (3 preceding siblings ...)
  2019-11-07 17:46 ` Alex Williamson
@ 2019-11-08 15:48 ` IndrasenaReddy Gali
  4 siblings, 0 replies; 5+ messages in thread
From: IndrasenaReddy Gali @ 2019-11-08 15:48 UTC (permalink / raw)
  To: qemu-devel

After increasing dma_entry_limit limit no issue observed.

But ideal senario device is getting hung and recovery happening only
with host hard rebooting.

-- 
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1851664

Title:
  qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's
  to guest machine

Status in QEMU:
  Incomplete

Bug description:
  We are trying to attach 6 VF's to the guest machine on 4.1.1 qemu emulator.
  We are observing "VFIO_MAP_DMA : -28" error.

  We are using w-bits=48 bits while lunching VM.

To manage notifications about this bug go to:
https://bugs.launchpad.net/qemu/+bug/1851664/+subscriptions


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, back to index

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <157313838504.19702.7205622932379991141.malonedeb@wampee.canonical.com>
2019-11-07 16:37 ` [Bug 1851664] Re: qemu-system-x86_64: "VFIO_MAP_DMA : -28" error when we attache 6 VF's to guest machine Thomas Huth
2019-11-07 17:45 ` IndrasenaReddy Gali
2019-11-07 17:46 ` IndrasenaReddy Gali
2019-11-07 17:46 ` Alex Williamson
2019-11-08 15:48 ` IndrasenaReddy Gali

QEMU-Devel Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/qemu-devel/0 qemu-devel/git/0.git
	git clone --mirror https://lore.kernel.org/qemu-devel/1 qemu-devel/git/1.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 qemu-devel qemu-devel/ https://lore.kernel.org/qemu-devel \
		qemu-devel@nongnu.org
	public-inbox-index qemu-devel

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.nongnu.qemu-devel


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git