On Mon, Jun 17, 2019 at 04:01:45PM +0300, Maxim Levitsky wrote: > On Mon, 2019-06-10 at 19:19 +0530, Aarushi Mehta wrote: > > Signed-off-by: Aarushi Mehta > > Reviewed-by: Stefan Hajnoczi > > --- > > blockdev.c | 4 +++- > > 1 file changed, 3 insertions(+), 1 deletion(-) > > > > diff --git a/blockdev.c b/blockdev.c > > index 3f44b891eb..a2a5b32604 100644 > > --- a/blockdev.c > > +++ b/blockdev.c > > @@ -386,6 +386,8 @@ static void extract_common_blockdev_options(QemuOpts *opts, int *bdrv_flags, > > if ((aio = qemu_opt_get(opts, "aio")) != NULL) { > > if (!strcmp(aio, "native")) { > > *bdrv_flags |= BDRV_O_NATIVE_AIO; > > + } else if (!strcmp(aio, "io_uring")) { > > + *bdrv_flags |= BDRV_O_IO_URING; > > } else if (!strcmp(aio, "threads")) { > > /* this is the default */ > > } else { > > @@ -4579,7 +4581,7 @@ QemuOptsList qemu_common_drive_opts = { > > },{ > > .name = "aio", > > .type = QEMU_OPT_STRING, > > - .help = "host AIO implementation (threads, native)", > > + .help = "host AIO implementation (threads, native, io_uring)", > > },{ > > .name = BDRV_OPT_CACHE_WB, > > .type = QEMU_OPT_BOOL, > > Nitpick: Maybe we should rename the native to libaio (accept both but give an deprication warning)? "libaio" is a clearer name but I'm afraid changing it or introducing a new name is not worth it with so many users, command-lines, scripts, and management tools that know about "native". Having two names that mean the same thing might cause confusion. Let's leave it as is. Stefan