qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
From: Markus Armbruster <armbru@redhat.com>
To: qemu-devel@nongnu.org
Cc: peter.maydell@linaro.org, vsementsov@virtuozzo.com,
	berrange@redhat.com, ehabkost@redhat.com, qemu-block@nongnu.org,
	groug@kaod.org, pbonzini@redhat.com
Subject: [PATCH v3 42/44] qemu-img: Ignore Error objects where the return value suffices
Date: Mon,  6 Jul 2020 10:09:48 +0200	[thread overview]
Message-ID: <20200706080950.403087-43-armbru@redhat.com> (raw)
In-Reply-To: <20200706080950.403087-1-armbru@redhat.com>

Signed-off-by: Markus Armbruster <armbru@redhat.com>
Reviewed-by: Eric Blake <eblake@redhat.com>
---
 qemu-img.c | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)

diff --git a/qemu-img.c b/qemu-img.c
index fc405ee171..a6af0eaf80 100644
--- a/qemu-img.c
+++ b/qemu-img.c
@@ -464,22 +464,18 @@ static int add_old_style_options(const char *fmt, QemuOpts *opts,
                                  const char *base_filename,
                                  const char *base_fmt)
 {
-    Error *err = NULL;
-
     if (base_filename) {
         if (!qemu_opt_set(opts, BLOCK_OPT_BACKING_FILE, base_filename,
-                          &err)) {
+                          NULL)) {
             error_report("Backing file not supported for file format '%s'",
                          fmt);
-            error_free(err);
             return -1;
         }
     }
     if (base_fmt) {
-        if (!qemu_opt_set(opts, BLOCK_OPT_BACKING_FMT, base_fmt, &err)) {
+        if (!qemu_opt_set(opts, BLOCK_OPT_BACKING_FMT, base_fmt, NULL)) {
             error_report("Backing file format not supported for file "
                          "format '%s'", fmt);
-            error_free(err);
             return -1;
         }
     }
-- 
2.26.2



  parent reply	other threads:[~2020-07-06  8:39 UTC|newest]

Thread overview: 65+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-06  8:09 [PATCH v3 00/44] Less clumsy error checking Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 01/44] error: Improve examples in error.h's big comment Markus Armbruster
2020-07-06 14:33   ` Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 02/44] error: Document Error API usage rules Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 03/44] qdev: Use returned bool to check for qdev_realize() etc. failure Markus Armbruster
2020-07-06 10:08   ` Greg Kurz
2020-07-06 11:35     ` Markus Armbruster
2020-07-06 14:43       ` Greg Kurz
2020-07-06  8:09 ` [PATCH v3 04/44] macio: Tidy up error handling in macio_newworld_realize() Markus Armbruster
2020-07-06 14:47   ` Greg Kurz
2020-07-06  8:09 ` [PATCH v3 05/44] virtio-crypto-pci: Tidy up virtio_crypto_pci_realize() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 06/44] qemu-option: Check return value instead of @err where convenient Markus Armbruster
2020-07-06 15:59   ` Greg Kurz
2020-07-06 20:01     ` Markus Armbruster
2020-07-07  8:25       ` Greg Kurz
2020-07-06  8:09 ` [PATCH v3 07/44] qemu-option: Make uses of find_desc_by_name() more similar Markus Armbruster
2020-07-07  8:26   ` Greg Kurz
2020-07-06  8:09 ` [PATCH v3 08/44] qemu-option: Factor out helper find_default_by_name() Markus Armbruster
2020-07-07  8:47   ` Greg Kurz
2020-07-06  8:09 ` [PATCH v3 09/44] qemu-option: Simplify around find_default_by_name() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 10/44] qemu-option: Factor out helper opt_create() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 11/44] qemu-option: Replace opt_set() by cleaner opt_validate() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 12/44] qemu-option: Make functions taking Error ** return bool, not void Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 13/44] qemu-option: Use returned bool to check for failure Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 14/44] block: Avoid error accumulation in bdrv_img_create() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 15/44] hmp: Eliminate a variable in hmp_migrate_set_parameter() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 16/44] qapi: Make visitor functions taking Error ** return bool, not void Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 17/44] qapi: Use returned bool to check for failure, Coccinelle part Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 18/44] qapi: Use returned bool to check for failure, manual part Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 19/44] s390x/pci: Fix harmless mistake in zpci's property fid's setter Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 20/44] qom: Use error_reportf_err() instead of g_printerr() in examples Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 21/44] qom: Rename qdev_get_type() to object_get_type() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 22/44] qom: Crash more nicely on object_property_get_link() failure Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 23/44] qom: Don't handle impossible " Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 24/44] qom: Use return values to check for error where that's simpler Markus Armbruster
2020-07-06 11:23   ` Vladimir Sementsov-Ogievskiy
2020-07-06  8:09 ` [PATCH v3 25/44] qom: Put name parameter before value / visitor parameter Markus Armbruster
2020-07-06 15:19   ` Vladimir Sementsov-Ogievskiy
2020-07-06  8:09 ` [PATCH v3 26/44] qom: Make functions taking Error ** return bool, not void Markus Armbruster
2020-07-06 15:44   ` Vladimir Sementsov-Ogievskiy
2020-07-06  8:09 ` [PATCH v3 27/44] qom: Use returned bool to check for failure, Coccinelle part Markus Armbruster
2020-07-06 16:08   ` Vladimir Sementsov-Ogievskiy
2020-07-06  8:09 ` [PATCH v3 28/44] qom: Use returned bool to check for failure, manual part Markus Armbruster
2020-07-06 16:39   ` Vladimir Sementsov-Ogievskiy
2020-07-06  8:09 ` [PATCH v3 29/44] qom: Make functions taking Error ** return bool, not 0/-1 Markus Armbruster
2020-07-06 16:52   ` Vladimir Sementsov-Ogievskiy
2020-07-06 20:07     ` Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 30/44] qdev: Make functions taking Error ** return bool, not void Markus Armbruster
2020-07-06 16:58   ` Vladimir Sementsov-Ogievskiy
2020-07-06  8:09 ` [PATCH v3 31/44] qdev: Use returned bool to check for failure, Coccinelle part Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 32/44] error: Avoid unnecessary error_propagate() after error_setg() Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 33/44] error: Eliminate error_propagate() with Coccinelle, part 1 Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 34/44] error: Eliminate error_propagate() with Coccinelle, part 2 Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 35/44] error: Eliminate error_propagate() manually Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 36/44] error: Reduce unnecessary error propagation Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 37/44] block/parallels: Simplify parallels_open() after previous commit Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 38/44] qapi: Smooth another visitor error checking pattern Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 39/44] qapi: Smooth visitor error checking in generated code Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 40/44] qapi: Purge error_propagate() from QAPI core Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 41/44] error: Avoid error_propagate() after migrate_add_blocker() Markus Armbruster
2020-07-06  8:09 ` Markus Armbruster [this message]
2020-07-06  8:09 ` [PATCH v3 43/44] qdev: Ignore Error objects where the return value suffices Markus Armbruster
2020-07-06  8:09 ` [PATCH v3 44/44] hmp: " Markus Armbruster
2020-07-06  8:12 ` [PATCH v3 00/44] Less clumsy error checking Markus Armbruster
2020-07-06 13:44   ` Eric Blake

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200706080950.403087-43-armbru@redhat.com \
    --to=armbru@redhat.com \
    --cc=berrange@redhat.com \
    --cc=ehabkost@redhat.com \
    --cc=groug@kaod.org \
    --cc=pbonzini@redhat.com \
    --cc=peter.maydell@linaro.org \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    --cc=vsementsov@virtuozzo.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).