qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
From: Gerd Hoffmann <kraxel@redhat.com>
To: qemu-devel@nongnu.org
Cc: "Laurent Vivier" <lvivier@redhat.com>,
	"Thomas Huth" <thuth@redhat.com>,
	"Volker Rümelin" <vr_qemu@t-online.de>,
	"Alexander Bulekov" <alxndr@bu.edu>,
	"Bandan Das" <bsd@redhat.com>,
	"Gerd Hoffmann" <kraxel@redhat.com>,
	"Stefan Hajnoczi" <stefanha@redhat.com>,
	"Paolo Bonzini" <pbonzini@redhat.com>
Subject: [PULL 4/7] jackaudio: avoid that the client name contains the word (NULL)
Date: Thu, 17 Jun 2021 14:41:04 +0200	[thread overview]
Message-ID: <20210617124107.2386073-5-kraxel@redhat.com> (raw)
In-Reply-To: <20210617124107.2386073-1-kraxel@redhat.com>

From: Volker Rümelin <vr_qemu@t-online.de>

Currently with jackaudio client name and qemu guest name unset,
the JACK client names are out-(NULL) and in-(NULL). These names
are user visible in the patch bay. Replace the function call to
qemu_get_vm_name() with a call to audio_application_name() which
replaces NULL with "qemu" to have more descriptive names.

Signed-off-by: Volker Rümelin <vr_qemu@t-online.de>
Message-Id: <20210517194604.2545-4-vr_qemu@t-online.de>
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
---
 audio/jackaudio.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/audio/jackaudio.c b/audio/jackaudio.c
index 3031c4e29bd4..e7de6d5433e9 100644
--- a/audio/jackaudio.c
+++ b/audio/jackaudio.c
@@ -26,7 +26,6 @@
 #include "qemu/module.h"
 #include "qemu/atomic.h"
 #include "qemu/main-loop.h"
-#include "qemu-common.h"
 #include "audio.h"
 
 #define AUDIO_CAP "jack"
@@ -412,7 +411,7 @@ static int qjack_client_init(QJackClient *c)
 
     snprintf(client_name, sizeof(client_name), "%s-%s",
         c->out ? "out" : "in",
-        c->opt->client_name ? c->opt->client_name : qemu_get_vm_name());
+        c->opt->client_name ? c->opt->client_name : audio_application_name());
 
     if (c->opt->exact_name) {
         options |= JackUseExactName;
-- 
2.31.1



  parent reply	other threads:[~2021-06-17 13:20 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-17 12:41 [PULL 0/7] Audio 20210617 patches Gerd Hoffmann
2021-06-17 12:41 ` [PULL 1/7] alsaaudio: remove #ifdef DEBUG to avoid bit rot Gerd Hoffmann
2021-06-17 12:41 ` [PULL 2/7] paaudio: remove unused stream flags Gerd Hoffmann
2021-06-17 12:41 ` [PULL 3/7] audio: move code to audio/audio.c Gerd Hoffmann
2021-06-17 12:41 ` Gerd Hoffmann [this message]
2021-06-17 12:41 ` [PULL 5/7] hw/audio/sb16: Avoid assertion by restricting I/O sampling rate range Gerd Hoffmann
2021-06-17 12:41 ` [PULL 6/7] audio: Fix format specifications of debug logs Gerd Hoffmann
2021-06-17 12:41 ` [PULL 7/7] coreaudio: Fix output stream format settings Gerd Hoffmann
2021-06-17 13:24 ` [PULL 0/7] Audio 20210617 patches no-reply
2021-06-18 13:00 ` Peter Maydell

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210617124107.2386073-5-kraxel@redhat.com \
    --to=kraxel@redhat.com \
    --cc=alxndr@bu.edu \
    --cc=bsd@redhat.com \
    --cc=lvivier@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=stefanha@redhat.com \
    --cc=thuth@redhat.com \
    --cc=vr_qemu@t-online.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).