qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
From: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com>
To: Hanna Reitz <hreitz@redhat.com>, qemu-block@nongnu.org
Cc: qemu-devel@nongnu.org, armbru@redhat.com, eblake@redhat.com,
	crosa@redhat.com, ehabkost@redhat.com, berrange@redhat.com,
	pbonzini@redhat.com, jsnow@redhat.com, mreitz@redhat.com,
	kwolf@redhat.com
Subject: Re: [PATCH v7 07/33] block/block-copy: introduce block_copy_set_copy_opts()
Date: Mon, 23 Aug 2021 20:40:56 +0300	[thread overview]
Message-ID: <27a3b6e9-5884-613e-2b03-26e1a20e3136@virtuozzo.com> (raw)
In-Reply-To: <4ab74994-5f7c-c286-8566-a68c999099e6@virtuozzo.com>

23.08.2021 15:05, Vladimir Sementsov-Ogievskiy wrote:
> 10.08.2021 17:55, Hanna Reitz wrote:
>> On 04.08.21 11:37, Vladimir Sementsov-Ogievskiy wrote:
>>> We'll need a possibility to set compress and use_copy_range options
>>> after initialization of the state. So make corresponding part of
>>> block_copy_state_new() separate and public.
>>>
>>> Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com>
>>> ---
>>>   include/block/block-copy.h |  2 ++
>>>   block/block-copy.c         | 66 +++++++++++++++++++++-----------------
>>>   2 files changed, 39 insertions(+), 29 deletions(-)
>>>
>>> diff --git a/include/block/block-copy.h b/include/block/block-copy.h
>>> index 734389d32a..f0ba7bc828 100644
>>> --- a/include/block/block-copy.h
>>> +++ b/include/block/block-copy.h
>>> @@ -28,6 +28,8 @@ BlockCopyState *block_copy_state_new(BdrvChild *source, BdrvChild *target,
>>>                                        int64_t cluster_size, bool use_copy_range,
>>>                                        bool compress, Error **errp);
>>> +void block_copy_set_copy_opts(BlockCopyState *s, bool use_copy_range,
>>> +                              bool compress);
>>>   void block_copy_set_progress_meter(BlockCopyState *s, ProgressMeter *pm);
>>>   void block_copy_state_free(BlockCopyState *s);
>>> diff --git a/block/block-copy.c b/block/block-copy.c
>>> index 58b4345a5a..84c29fb233 100644
>>> --- a/block/block-copy.c
>>> +++ b/block/block-copy.c
>>> @@ -315,21 +315,11 @@ static uint32_t block_copy_max_transfer(BdrvChild *source, BdrvChild *target)
>>>                                        target->bs->bl.max_transfer));
>>>   }
>>> -BlockCopyState *block_copy_state_new(BdrvChild *source, BdrvChild *target,
>>> -                                     int64_t cluster_size, bool use_copy_range,
>>> -                                     bool compress, Error **errp)
>>> +/* Function should be called prior any actual copy request */
>>
>> Given this is something the caller should know, I’d prefer putting this into the block-copy.h header.
>>
>> However, I realize we have a wild mix of this in qemu and often do put such information into the C source file, so...
>>
>>> +void block_copy_set_copy_opts(BlockCopyState *s, bool use_copy_range,
>>> +                              bool compress)
>>>   {
>>> -    BlockCopyState *s;
>>> -    BdrvDirtyBitmap *copy_bitmap;
>>>       bool is_fleecing;
>>> -
>>> -    copy_bitmap = bdrv_create_dirty_bitmap(source->bs, cluster_size, NULL,
>>> -                                           errp);
>>> -    if (!copy_bitmap) {
>>> -        return NULL;
>>> -    }
>>> -    bdrv_disable_dirty_bitmap(copy_bitmap);
>>> -
>>>       /*
>>>        * If source is in backing chain of target assume that target is going to be
>>>        * used for "image fleecing", i.e. it should represent a kind of snapshot of
>>> @@ -344,24 +334,12 @@ BlockCopyState *block_copy_state_new(BdrvChild *source, BdrvChild *target,
>>>        * For more information see commit f8d59dfb40bb and test
>>>        * tests/qemu-iotests/222
>>>        */
>>> -    is_fleecing = bdrv_chain_contains(target->bs, source->bs);
>>> +    is_fleecing = bdrv_chain_contains(s->target->bs, s->source->bs);
>>> -    s = g_new(BlockCopyState, 1);
>>> -    *s = (BlockCopyState) {
>>> -        .source = source,
>>> -        .target = target,
>>> -        .copy_bitmap = copy_bitmap,
>>> -        .cluster_size = cluster_size,
>>> -        .len = bdrv_dirty_bitmap_size(copy_bitmap),
>>> -        .write_flags = (is_fleecing ? BDRV_REQ_SERIALISING : 0) |
>>> -            (compress ? BDRV_REQ_WRITE_COMPRESSED : 0),
>>> -        .mem = shres_create(BLOCK_COPY_MAX_MEM),
>>> -        .max_transfer = QEMU_ALIGN_DOWN(
>>> -                                    block_copy_max_transfer(source, target),
>>> -                                    cluster_size),
>>> -    };
>>> +    s->write_flags = (is_fleecing ? BDRV_REQ_SERIALISING : 0) |
>>> +        (compress ? BDRV_REQ_WRITE_COMPRESSED : 0);
>>
>> Shouldn’t we keep the is_fleecing check in block_copy_state_new()? We must perform it at least once, but there is no benefit in repeating it on every block_copy_set_copy_opts() call, right?
>>
> 
> I think, it may help if user calls block_copy_set_copy_opts() after graph change
> 
> 

On the other hand, nobody actually call this function after generic graph change. And intended usage is start backup when source is already backing child of target.. Will change it, at least for code be more obvious and not raise questions.


-- 
Best regards,
Vladimir


  reply	other threads:[~2021-08-23 17:43 UTC|newest]

Thread overview: 47+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-08-04  9:37 [PATCH v7 00/33] block: publish backup-top filter Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 01/33] block: introduce bdrv_replace_child_bs() Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 02/33] block: introduce blk_replace_bs Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 03/33] qdev-properties: PropertyInfo: add realized_set_allowed field Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 04/33] qdev: allow setting drive property for realized device Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 05/33] block: rename backup-top to copy-before-write Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 06/33] block-copy: move detecting fleecing scheme to block-copy Vladimir Sementsov-Ogievskiy
2021-08-10 14:44   ` Hanna Reitz
2021-08-04  9:37 ` [PATCH v7 07/33] block/block-copy: introduce block_copy_set_copy_opts() Vladimir Sementsov-Ogievskiy
2021-08-10 14:55   ` Hanna Reitz
2021-08-23 12:05     ` Vladimir Sementsov-Ogievskiy
2021-08-23 17:40       ` Vladimir Sementsov-Ogievskiy [this message]
2021-08-04  9:37 ` [PATCH v7 08/33] block/backup: set copy_range and compress after filter insertion Vladimir Sementsov-Ogievskiy
2021-08-10 15:07   ` Hanna Reitz
2021-08-04  9:37 ` [PATCH v7 09/33] block/backup: move cluster size calculation to block-copy Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 10/33] block/copy-before-write: relax permission requirements when no parents Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 11/33] block/copy-before-write: drop extra bdrv_unref on failure path Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 12/33] block/copy-before-write: use file child instead of backing Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 13/33] block/copy-before-write: bdrv_cbw_append(): replace child at last Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 14/33] block/copy-before-write: introduce cbw_init() Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 15/33] block/copy-before-write: cbw_init(): rename variables Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 16/33] block/copy-before-write: cbw_init(): use file child after attaching Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 17/33] block/copy-before-write: bdrv_cbw_append(): drop unused compress arg Vladimir Sementsov-Ogievskiy
2021-08-10 15:17   ` Hanna Reitz
2021-08-23 16:33     ` Vladimir Sementsov-Ogievskiy
2021-08-04  9:37 ` [PATCH v7 18/33] block/copy-before-write: cbw_init(): use options Vladimir Sementsov-Ogievskiy
2021-08-10 15:18   ` Hanna Reitz
2021-08-04  9:37 ` [PATCH v7 19/33] block/copy-before-write: initialize block-copy bitmap Vladimir Sementsov-Ogievskiy
2021-08-04  9:38 ` [PATCH v7 20/33] block/block-copy: make setting progress optional Vladimir Sementsov-Ogievskiy
2021-08-10 15:23   ` Hanna Reitz
2021-08-04  9:38 ` [PATCH v7 21/33] block/copy-before-write: make public block driver Vladimir Sementsov-Ogievskiy
2021-08-04  9:38 ` [PATCH v7 22/33] qapi: publish copy-before-write filter Vladimir Sementsov-Ogievskiy
2021-08-04 13:18   ` Markus Armbruster
2021-08-04  9:38 ` [PATCH v7 23/33] python/qemu/machine.py: refactor _qemu_args() Vladimir Sementsov-Ogievskiy
2021-08-04  9:38 ` [PATCH v7 24/33] python/qemu/machine: QEMUMachine: improve qmp() method Vladimir Sementsov-Ogievskiy
2021-08-04  9:38 ` [PATCH v7 25/33] iotests.py: VM: add own __enter__ method Vladimir Sementsov-Ogievskiy
2021-08-04 16:27   ` John Snow
2021-08-23 17:22     ` Vladimir Sementsov-Ogievskiy
2021-08-04  9:38 ` [PATCH v7 26/33] iotests/222: fix pylint and mypy complains Vladimir Sementsov-Ogievskiy
2021-08-04  9:38 ` [PATCH v7 27/33] iotests/222: constantly use single quotes for strings Vladimir Sementsov-Ogievskiy
2021-08-04  9:38 ` [PATCH v7 28/33] iotests: move 222 to tests/image-fleecing Vladimir Sementsov-Ogievskiy
2021-08-04  9:38 ` [PATCH v7 29/33] iotests.py: hmp_qemu_io: support qdev Vladimir Sementsov-Ogievskiy
2021-08-04 16:17   ` John Snow
2021-08-04  9:38 ` [PATCH v7 30/33] iotests/image-fleecing: proper source device Vladimir Sementsov-Ogievskiy
2021-08-04  9:38 ` [PATCH v7 31/33] iotests/image-fleecing: rename tgt_node Vladimir Sementsov-Ogievskiy
2021-08-04  9:38 ` [PATCH v7 32/33] iotests/image-fleecing: prepare for adding new test-case Vladimir Sementsov-Ogievskiy
2021-08-04  9:38 ` [PATCH v7 33/33] iotests/image-fleecing: add test-case for copy-before-write filter Vladimir Sementsov-Ogievskiy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=27a3b6e9-5884-613e-2b03-26e1a20e3136@virtuozzo.com \
    --to=vsementsov@virtuozzo.com \
    --cc=armbru@redhat.com \
    --cc=berrange@redhat.com \
    --cc=crosa@redhat.com \
    --cc=eblake@redhat.com \
    --cc=ehabkost@redhat.com \
    --cc=hreitz@redhat.com \
    --cc=jsnow@redhat.com \
    --cc=kwolf@redhat.com \
    --cc=mreitz@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).