qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
From: "Philippe Mathieu-Daudé" <philmd@redhat.com>
To: Auger Eric <eric.auger@redhat.com>,
	eric.auger.pro@gmail.com, stefanb@linux.ibm.com,
	qemu-devel@nongnu.org, qemu-arm@nongnu.org,
	peter.maydell@linaro.org
Cc: marcandre.lureau@redhat.com, lersek@redhat.com, ardb@kernel.org
Subject: Re: [RFC v2 1/6] tpm: rename TPM_TIS into TPM_TIS_ISA
Date: Tue, 25 Feb 2020 11:22:14 +0100	[thread overview]
Message-ID: <5eb51283-2bfd-bd02-3bbd-492961e842ff@redhat.com> (raw)
In-Reply-To: <4dd1b4b0-7112-5a8a-9033-9c21eb01b8f9@redhat.com>

On 2/25/20 11:16 AM, Auger Eric wrote:
> Hi Phil,
> 
> On 2/14/20 7:55 PM, Philippe Mathieu-Daudé wrote:
>> On 2/14/20 7:36 PM, Eric Auger wrote:
>>> As we plan to introduce a sysbus TPM_TIS, let's rename
>>> TPM_TIS into TPM_TIS_ISA.
>>>
>>> Signed-off-by: Eric Auger <eric.auger@redhat.com>
>>> ---
>>>    hw/i386/acpi-build.c | 6 +++---
>>>    hw/tpm/tpm_tis.c     | 4 ++--
>>>    include/sysemu/tpm.h | 6 +++---
>>>    3 files changed, 8 insertions(+), 8 deletions(-)
>>>
>>> diff --git a/hw/i386/acpi-build.c b/hw/i386/acpi-build.c
>>> index 9c4e46fa74..26777f8828 100644
>>> --- a/hw/i386/acpi-build.c
>>> +++ b/hw/i386/acpi-build.c
>>> @@ -2026,7 +2026,7 @@ build_dsdt(GArray *table_data, BIOSLinker *linker,
>>>            }
>>>        }
>>>    -    if (TPM_IS_TIS(tpm_find())) {
>>> +    if (TPM_IS_TIS_ISA(tpm_find())) {
>>>            aml_append(crs, aml_memory32_fixed(TPM_TIS_ADDR_BASE,
>>>                       TPM_TIS_ADDR_SIZE, AML_READ_WRITE));
>>>        }
>>> @@ -2197,7 +2197,7 @@ build_dsdt(GArray *table_data, BIOSLinker *linker,
>>>                /* Scan all PCI buses. Generate tables to support
>>> hotplug. */
>>>                build_append_pci_bus_devices(scope, bus,
>>> pm->pcihp_bridge_en);
>>>    -            if (TPM_IS_TIS(tpm)) {
>>> +            if (TPM_IS_TIS_ISA(tpm)) {
>>>                    if (misc->tpm_version == TPM_VERSION_2_0) {
>>>                        dev = aml_device("TPM");
>>>                        aml_append(dev, aml_name_decl("_HID",
>>> @@ -2304,7 +2304,7 @@ build_tpm2(GArray *table_data, BIOSLinker
>>> *linker, GArray *tcpalog)
>>>            (char *)&tpm2_ptr->log_area_start_address - table_data->data;
>>>          tpm2_ptr->platform_class = cpu_to_le16(TPM2_ACPI_CLASS_CLIENT);
>>> -    if (TPM_IS_TIS(tpm_find())) {
>>> +    if (TPM_IS_TIS_ISA(tpm_find())) {
>>>            tpm2_ptr->control_area_address = cpu_to_le64(0);
>>>            tpm2_ptr->start_method = cpu_to_le32(TPM2_START_METHOD_MMIO);
>>>        } else if (TPM_IS_CRB(tpm_find())) {
>>> diff --git a/hw/tpm/tpm_tis.c b/hw/tpm/tpm_tis.c
>>> index 31facb896d..c609737272 100644
>>> --- a/hw/tpm/tpm_tis.c
>>> +++ b/hw/tpm/tpm_tis.c
>>> @@ -91,7 +91,7 @@ typedef struct TPMState {
>>>        TPMPPI ppi;
>>>    } TPMState;
>>>    -#define TPM(obj) OBJECT_CHECK(TPMState, (obj), TYPE_TPM_TIS)
>>> +#define TPM(obj) OBJECT_CHECK(TPMState, (obj), TYPE_TPM_TIS_ISA)
>>>      #define DEBUG_TIS 0
>>>    @@ -1008,7 +1008,7 @@ static void tpm_tis_class_init(ObjectClass
>>> *klass, void *data)
>>>    }
>>>      static const TypeInfo tpm_tis_info = {
>>> -    .name = TYPE_TPM_TIS,
>>> +    .name = TYPE_TPM_TIS_ISA,
>>>        .parent = TYPE_ISA_DEVICE,
>>>        .instance_size = sizeof(TPMState),
>>>        .instance_init = tpm_tis_initfn,
>>> diff --git a/include/sysemu/tpm.h b/include/sysemu/tpm.h
>>> index 15979a3647..1691b92c28 100644
>>> --- a/include/sysemu/tpm.h
>>> +++ b/include/sysemu/tpm.h
>>> @@ -43,12 +43,12 @@ typedef struct TPMIfClass {
>>>        enum TPMVersion (*get_version)(TPMIf *obj);
>>>    } TPMIfClass;
>>>    -#define TYPE_TPM_TIS                "tpm-tis"
>>> +#define TYPE_TPM_TIS_ISA            "tpm-tis"
>>
>> It should be safe to rename this "tpm-tis-isa" in this patch.
> This would change the name of the legacy ISA device and also the way we
> instantiate it through the cmd line. To avoid breaking the compatibility
> I kept the same name and used tpm-tis-device (?) for the new sysbus one.

I thought ISA devices were not user-creatable...

> 
> Thanks
> 
> Eric
>>
>> Regardless:
>> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>
>>
>>>    #define TYPE_TPM_CRB                "tpm-crb"
>>>    #define TYPE_TPM_SPAPR              "tpm-spapr"
>>>    -#define TPM_IS_TIS(chr)                             \
>>> -    object_dynamic_cast(OBJECT(chr), TYPE_TPM_TIS)
>>> +#define TPM_IS_TIS_ISA(chr)                         \
>>> +    object_dynamic_cast(OBJECT(chr), TYPE_TPM_TIS_ISA)
>>>    #define TPM_IS_CRB(chr)                             \
>>>        object_dynamic_cast(OBJECT(chr), TYPE_TPM_CRB)
>>>    #define TPM_IS_SPAPR(chr)                           \
>>>
>>
> 



  reply	other threads:[~2020-02-25 10:22 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-14 18:36 [RFC v2 0/6] vTPM for aarch64 Eric Auger
2020-02-14 18:36 ` [RFC v2 1/6] tpm: rename TPM_TIS into TPM_TIS_ISA Eric Auger
2020-02-14 18:55   ` Philippe Mathieu-Daudé
2020-02-25 10:16     ` Auger Eric
2020-02-25 10:22       ` Philippe Mathieu-Daudé [this message]
2020-02-25 10:28         ` Auger Eric
2020-02-16 18:14   ` Stefan Berger
2020-02-14 18:37 ` [RFC v2 2/6] tpm: Use TPMState as a common struct Eric Auger
2020-02-14 19:01   ` Philippe Mathieu-Daudé
2020-02-16 18:22   ` Stefan Berger
2020-02-17  9:21   ` Philippe Mathieu-Daudé
2020-02-17 18:01     ` Auger Eric
2020-02-25 10:18       ` Auger Eric
2020-02-14 18:37 ` [RFC v2 3/6] tpm: Separate tpm_tis common functions from isa code Eric Auger
2020-02-16 18:27   ` Stefan Berger
2020-02-14 18:37 ` [RFC v2 4/6] tpm: Separate TPM_TIS and TPM_TIS_ISA configs Eric Auger
2020-02-14 19:03   ` Philippe Mathieu-Daudé
2020-02-25 10:05     ` Auger Eric
2020-02-14 18:37 ` [RFC v2 5/6] tpm: Add the SysBus TPM TIS device Eric Auger
2020-02-16 18:32   ` Stefan Berger
2020-02-17 18:13     ` Auger Eric
2020-02-25  9:18       ` Auger Eric
2020-02-25  9:52         ` Ard Biesheuvel
2020-02-25 10:18           ` Philippe Mathieu-Daudé
2020-02-26  8:38           ` Auger Eric
2020-02-14 18:37 ` [RFC v2 6/6] hw/arm/virt: vTPM support Eric Auger
2020-02-16 18:47   ` Stefan Berger
2020-02-17 18:26     ` Auger Eric
2020-02-16 16:35 ` [RFC v2 0/6] vTPM for aarch64 Ard Biesheuvel
2020-02-17 18:03   ` Auger Eric

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5eb51283-2bfd-bd02-3bbd-492961e842ff@redhat.com \
    --to=philmd@redhat.com \
    --cc=ardb@kernel.org \
    --cc=eric.auger.pro@gmail.com \
    --cc=eric.auger@redhat.com \
    --cc=lersek@redhat.com \
    --cc=marcandre.lureau@redhat.com \
    --cc=peter.maydell@linaro.org \
    --cc=qemu-arm@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    --cc=stefanb@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).