qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
From: Eric Blake <eblake@redhat.com>
To: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com>,
	qemu-block@nongnu.org
Cc: kwolf@redhat.com, fam@euphon.net, ehabkost@redhat.com,
	qemu-devel@nongnu.org, mreitz@redhat.com, stefanha@redhat.com,
	crosa@redhat.com, den@openvz.org
Subject: Re: [PATCH v4 3/5] block: generate coroutine-wrapper code
Date: Tue, 26 May 2020 16:30:40 -0500	[thread overview]
Message-ID: <7cd429d4-d346-b019-3f72-e98fa55593f9@redhat.com> (raw)
In-Reply-To: <20200525100801.13859-4-vsementsov@virtuozzo.com>

On 5/25/20 5:07 AM, Vladimir Sementsov-Ogievskiy wrote:
> We have a very frequent pattern of creating coroutine from function
> with several arguments:
> 
>    - create structure to pack parameters
>    - create _entry function to call original function taking parameters
>      from struct
>    - do different magic to handle completion: set ret to NOT_DONE or
>      EINPROGRESS, use separate bool for void functions
>    - fill the struct and create coroutine from _entry function and this
>      struct as a parameter
>    - do coroutine enter and BDRV_POLL_WHILE loop
> 
> Let's reduce code duplication. Here:
> 
> Functional part (BDRV_POLL_WHILE loop, aio_wait_kick()) moved to
> (non-generated) block/block-gen.h
> 
> Mechanical part (arguments packing, different kind of needed wrappers)
> are generated from template by scripts/coroutine-wrapper.py to
> resulting file block/block-gen.c
> 
> Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@virtuozzo.com>
> ---

> @@ -175,6 +177,10 @@ generated-files-y += $(TRACE_SOURCES)
>   generated-files-y += $(BUILD_DIR)/trace-events-all
>   generated-files-y += .git-submodule-status
>   
> +COROUTINE_HEADERS = include/block/block.h block/coroutines.h
> +block/block-gen.c: $(COROUTINE_HEADERS) $(SRC_PATH)/scripts/coroutine-wrapper.py
> +	$(call quiet-command, cat $(COROUTINE_HEADERS) | $(SRC_PATH)/scripts/coroutine-wrapper.py > $@,"GEN","$(TARGET_DIR)$@")
> +

Not VPATH-friendly; I posted a proposed fixup! separately.

>   trace-group-name = $(shell dirname $1 | sed -e 's/[^a-zA-Z0-9]/_/g')
>   
>   tracetool-y = $(SRC_PATH)/scripts/tracetool.py
> diff --git a/Makefile.objs b/Makefile.objs
> index 99774cfd25..8cb20f94c3 100644
> --- a/Makefile.objs
> +++ b/Makefile.objs
> @@ -14,7 +14,7 @@ chardev-obj-y = chardev/
>   authz-obj-y = authz/
>   
>   block-obj-y = block/ block/monitor/ nbd/ scsi/
> -block-obj-y += block.o blockjob.o job.o
> +block-obj-y += block.o blockjob.o job.o block/block-gen.o

It may be cleaner to add this in block/Makefile.objs rather than in 
top-level Makefile.objs.  In fact, rearranging your mail a bit...

 > diff --git a/block/Makefile.objs b/block/Makefile.objs
 > index 3635b6b4c1..05e4d033c1 100644
 > --- a/block/Makefile.objs
 > +++ b/block/Makefile.objs
 > @@ -45,6 +45,7 @@ block-obj-y += crypto.o
 >   block-obj-y += aio_task.o
 >   block-obj-y += backup-top.o
 >   block-obj-y += filter-compress.o
 > +block-obj-y += block-gen.o
 >   common-obj-y += monitor/
 >
 >   block-obj-y += stream.o

...you did just that.  Dropping the change to top-level Makefile.objs 
seems to make no difference to a correct build.

> +++ b/block/block-gen.h
> @@ -0,0 +1,55 @@
> +/*
> + * Block layer I/O functions

Is this still the best one-line summary for this file?  Especially since...

> +
> +/* This function is called at the end of generated coroutine entries. */
> +static inline void bdrv_poll_co__on_exit(void)
> +{
> +    aio_wait_kick();
> +}
> +
> +/* Base structure for argument packing structures */
> +typedef struct BdrvPollCo {
> +    BlockDriverState *bs;
> +    bool in_progress;
> +    int ret;
> +    Coroutine *co; /* Keep pointer here for debugging */
> +} BdrvPollCo;
> +
> +static inline int bdrv_poll_co(BdrvPollCo *s)
> +{
> +    assert(!qemu_in_coroutine());
> +
> +    bdrv_coroutine_enter(s->bs, s->co);
> +    BDRV_POLL_WHILE(s->bs, s->in_progress);
> +
> +    return s->ret;
> +}

This part looks fine.


> +++ b/include/block/generated-co-wrapper.h
> @@ -0,0 +1,35 @@
> +/*
> + * Block layer I/O functions

...you repeat it here?

> +/*
> + * generated_co_wrapper
> + * Function specifier, which does nothing but marking functions to be
> + * generated by scripts/coroutine-wrapper.py
> + */
> +#define generated_co_wrapper
> +
> +#endif /* BLOCK_GENERATED_CO_WRAPPER_H */

Not sure if a separate header was needed for this, but I guess it 
doesn't hurt.  I might have just used block_int.h.

> diff --git a/block.c b/block.c
> index 7f06e82880..c1132ab323 100644
> --- a/block.c
> +++ b/block.c
> @@ -4640,43 +4640,6 @@ int coroutine_fn bdrv_co_check(BlockDriverState *bs,
>       return bs->drv->bdrv_co_check(bs, res, fix);
>   }
>   
> -typedef struct CheckCo {
> -    BlockDriverState *bs;
> -    BdrvCheckResult *res;
> -    BdrvCheckMode fix;
> -    int ret;
> -} CheckCo;

This patch is doing two things - introducing a new generator script that 
scans the code for generated_co_wrapper tags, _and_ adds the tags in as 
many places as possible.  It makes for a big patch.  Better might have 
been to introduce the script and the concept of a tag in one patch but 
not actually tag any new functions (so the generated file is basically 
empty, but you prove the build works and can audit the script without 
being bogged down by the mechanical changes), then do a separate patch 
with adding the tags and deleting the code now covered by the generator 
(which will be mostly mechanical).

> +++ b/scripts/coroutine-wrapper.py
> @@ -0,0 +1,168 @@
> +#!/usr/bin/env python3

My python review skills are weak, so you'll probably want another 
reviewer here (although I _can_ state that I checked the generated 
block/block-gen.c file and it makes sense).


> +import re
> +from typing import List, Iterator
> +
> +header = '''/*
> + * File is generated by scripts/coroutine-wrapper.py
> + */

It's worth also generating a short copyright blurb into the generated file.

> +
> +#include "qemu/osdep.h"
> +#include "block/coroutines.h"
> +#include "block/block-gen.h"'''
> +
> +template = """

Why ''' above and """ here?  While python accepts both forms, 
consistency is desirable.  I have no idea what pylint thinks of your 
code, though, so I may be completely overlooking idiomatic styles.

> +
> +/*
> + * Wrappers for $name$
> + */
> +
> +typedef struct $struct_name$ {
> +    BdrvPollCo poll_state;
> +    $fields$
> +} $struct_name$;
> +
> +static void coroutine_fn $name$_entry(void *opaque)
> +{
> +    $struct_name$ *s = opaque;
> +
> +    $assign_ret$$name$($args_from_s$);

Creates a long line. Doesn't matter since this is generated code, so I 
don't know if it's worth trying to coerce python into generating 
something that is wrapped nicely.

> +
> +    s->poll_state.in_progress = false;
> +
> +    bdrv_poll_co__on_exit();

That function only calls aio_wait_kick().  Why did you not want to call 
that directly here, instead of going through such a one-line wrapper 
function?

> +}
> +
> +$ret_type$ $wrapper_name$($args_def$)
> +{
> +    if (qemu_in_coroutine()) {
> +        $do_return$$name$($arg_names$);

Would it be any simpler to teach bdrv_co_invalidate_cache() to return a 
value, so that you can eliminate the need for $do_return$ and just 
hard-code 'return ' here?  The .bdrv_co_invalidate_cache driver callback 
can still return void, and just have the wrapper in block.c return 0. 
But if you want to do that, it would be a separate prerequisite patch.

> +    } else {
> +        $struct_name$ s = {
> +            .poll_state.bs = $bs$,
> +            .poll_state.in_progress = true,
> +
> +            $initializers$
> +        };
> +
> +        s.poll_state.co = qemu_coroutine_create($name$_entry, &s);
> +
> +        $do_return$bdrv_poll_co(&s.poll_state);

Another spot impacted by that one outlier.

> +    }
> +}"""
> +
> +# We want to use python string.format() formatter, which uses curly brackets
> +# as separators. But it's not comfortable with C. So, we used dollars instead,
> +# and now is the time to escape curly brackets and convert dollars.
> +template = template.replace('{', '{{').replace('}', '}}')
> +template = re.sub(r'\$(\w+)\$', r'{\1}', template)

I'll leave it to others to decide if your approach has a more idiomatic 
python solution.  I'm used to the qapi generator using code like this in 
script/qapi/visit.py:

def gen_visit_members_decl(name):
     return mcgen('''

void visit_type_%(c_name)s_members(Visitor *v, %(c_name)s *obj, Error 
**errp);
''',
                  c_name=c_name(name))

which has the same end goal of inserting named tags into a format 
string, but which uses %(tag) for tags rather than your novel approach 
of $tag$ with post-processing.

> +
> +
> +class ParamDecl:
> +    param_re = re.compile(r'(?P<decl>'
> +                          r'(?P<type>.*[ *])'
> +                          r'(?P<name>[a-z][a-z0-9_]*)'
> +                          r')')
> +
> +    def __init__(self, param_decl: str) -> None:
> +        m = self.param_re.match(param_decl.strip())
> +        self.decl = m.group('decl')
> +        self.type = m.group('type')
> +        self.name = m.group('name')
> +
> +
> +class FuncDecl:
> +    def __init__(self, return_type: str, name: str, args: str) -> None:
> +        self.return_type = return_type.strip()
> +        self.name = name.strip()
> +        self.args: List[ParamDecl] = []
> +        self.args = [ParamDecl(arg) for arg in args.split(',')]
> +
> +    def get_args_decl(self) -> str:
> +        return ', '.join(arg.decl for arg in self.args)
> +
> +    def get_arg_names(self) -> str:
> +        return ', '.join(arg.name for arg in self.args)
> +
> +    def gen_struct_fields(self) -> str:
> +        return '\n    '.join(f'{arg.decl};' for arg in self.args)
> +
> +    def gen_struct_initializers(self, indent: int) -> str:
> +        sep = '\n' + ' ' * indent
> +        return sep.join(f'.{a.name} = {a.name},' for a in self.args)
> +
> +
> +# Match wrappers declaration, with generated_co_wrapper mark

s/declaration, with/declared with a/

> +func_decl_re = re.compile(r'^(?P<return_type>(int|void))'
> +                          r'\s*generated_co_wrapper\s*'
> +                          r'(?P<wrapper_name>[a-z][a-z0-9_]*)'
> +                          r'\((?P<args>[^)]*)\);$', re.MULTILINE)
> +
> +
> +def func_decl_iter(text: str) -> Iterator:
> +    for m in func_decl_re.finditer(text):
> +        yield FuncDecl(return_type=m.group('return_type'),
> +                       name=m.group('wrapper_name'),
> +                       args=m.group('args'))
> +
> +
> +def struct_name(func_name: str) -> str:
> +    """some_function_name -> SomeFunctionName"""
> +    words = func_name.split('_')
> +    words = [w[0].upper() + w[1:] for w in words]
> +    return ''.join(words)
> +
> +
> +def make_wrapper(func: FuncDecl) -> str:
> +    assert func.name.startswith('bdrv_')
> +    co_name = 'bdrv_co_' + func.name[5:]
> +
> +    has_ret = func.return_type != 'void'
> +
> +    params = {
> +        'name': co_name,
> +        'do_return': 'return ' if has_ret else '',
> +        'assign_ret': 's->poll_state.ret = ' if has_ret else '',

See my comments above about possibly normalizing the one outlier of 
bdrv_co_invalidate_cache first.

> +        'struct_name': struct_name(co_name),
> +        'wrapper_name': func.name,
> +        'ret_type': func.return_type,
> +        'args_def': func.get_args_decl(),
> +        'arg_names': func.get_arg_names(),
> +        'fields': func.gen_struct_fields(),
> +        'initializers': func.gen_struct_initializers(12),

12 looks like a magic number.

> +        'args_from_s': ', '.join(f's->{a.name}' for a in func.args),
> +    }
> +
> +    if func.args[0].type == 'BlockDriverState *':
> +        params['bs'] = 'bs'
> +    else:
> +        assert func.args[0].type == 'BdrvChild *'
> +        params['bs'] = 'child->bs'
> +
> +    return template.format(**params)
> +
> +
> +if __name__ == '__main__':
> +    import sys
> +
> +    print(header)
> +    for func in func_decl_iter(sys.stdin.read()):
> +        print(make_wrapper(func))
> 

-- 
Eric Blake, Principal Software Engineer
Red Hat, Inc.           +1-919-301-3226
Virtualization:  qemu.org | libvirt.org



  parent reply	other threads:[~2020-05-26 21:32 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-25 10:07 [PATCH v4 0/5] coroutines: generate wrapper code Vladimir Sementsov-Ogievskiy
2020-05-25 10:07 ` [PATCH v4 1/5] block/io: refactor coroutine wrappers Vladimir Sementsov-Ogievskiy
2020-05-26 19:24   ` Eric Blake
2020-05-25 10:07 ` [PATCH v4 2/5] block: declare some coroutine functions in block/coroutines.h Vladimir Sementsov-Ogievskiy
2020-05-26 19:50   ` Eric Blake
2020-05-25 10:07 ` [PATCH v4 3/5] block: generate coroutine-wrapper code Vladimir Sementsov-Ogievskiy
2020-05-26 20:51   ` [PATCH] fixup! " Eric Blake
2020-05-26 21:30   ` Eric Blake [this message]
2020-05-27 11:24     ` [PATCH v4 3/5] " Vladimir Sementsov-Ogievskiy
2020-05-25 10:08 ` [PATCH v4 4/5] block: drop bdrv_prwv Vladimir Sementsov-Ogievskiy
2020-05-26 21:34   ` Eric Blake
2020-05-27 11:35     ` Vladimir Sementsov-Ogievskiy
2020-05-25 10:08 ` [PATCH v4 5/5] block/io: refactor save/load vmstate Vladimir Sementsov-Ogievskiy
2020-05-26 21:36   ` Eric Blake
2020-05-25 13:14 ` [PATCH v4 0/5] coroutines: generate wrapper code no-reply
2020-05-25 13:48   ` Vladimir Sementsov-Ogievskiy
2020-05-26 20:42     ` Eric Blake

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7cd429d4-d346-b019-3f72-e98fa55593f9@redhat.com \
    --to=eblake@redhat.com \
    --cc=crosa@redhat.com \
    --cc=den@openvz.org \
    --cc=ehabkost@redhat.com \
    --cc=fam@euphon.net \
    --cc=kwolf@redhat.com \
    --cc=mreitz@redhat.com \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    --cc=stefanha@redhat.com \
    --cc=vsementsov@virtuozzo.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).