From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from eggs.gnu.org ([2001:4830:134:3::10]:45244) by lists.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1aTr5V-0005Ff-Hf for qemu-devel@nongnu.org; Thu, 11 Feb 2016 08:15:14 -0500 Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71) (envelope-from ) id 1aTr5R-0003bw-Hl for qemu-devel@nongnu.org; Thu, 11 Feb 2016 08:15:13 -0500 Received: from mail-wm0-x234.google.com ([2a00:1450:400c:c09::234]:37907) by eggs.gnu.org with esmtp (Exim 4.71) (envelope-from ) id 1aTr5R-0003bb-6Y for qemu-devel@nongnu.org; Thu, 11 Feb 2016 08:15:09 -0500 Received: by mail-wm0-x234.google.com with SMTP id p63so67862613wmp.1 for ; Thu, 11 Feb 2016 05:15:09 -0800 (PST) References: <1454059965-23402-1-git-send-email-a.rigo@virtualopensystems.com> <1454059965-23402-4-git-send-email-a.rigo@virtualopensystems.com> From: Alex =?utf-8?Q?Benn=C3=A9e?= In-reply-to: <1454059965-23402-4-git-send-email-a.rigo@virtualopensystems.com> Date: Thu, 11 Feb 2016 13:15:06 +0000 Message-ID: <878u2rbd7p.fsf@linaro.org> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 8bit Subject: Re: [Qemu-devel] [RFC v7 03/16] softmmu: Simplify helper_*_st_name, wrap MMIO code List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , To: Alvise Rigo Cc: mttcg@listserver.greensocs.com, claudio.fontana@huawei.com, qemu-devel@nongnu.org, pbonzini@redhat.com, jani.kokkonen@huawei.com, tech@virtualopensystems.com, rth@twiddle.net Alvise Rigo writes: > Attempting to simplify the helper_*_st_name, wrap the MMIO code into an > inline function. > > Based on this work, Alex proposed the following patch series > https://lists.gnu.org/archive/html/qemu-devel/2016-01/msg01136.html > that reduces code duplication of the softmmu_helpers. > > Suggested-by: Jani Kokkonen > Suggested-by: Claudio Fontana > Signed-off-by: Alvise Rigo > --- > softmmu_template.h | 66 ++++++++++++++++++++++++++++++++++++------------------ > 1 file changed, 44 insertions(+), 22 deletions(-) > > diff --git a/softmmu_template.h b/softmmu_template.h > index 7029a03..3d388ec 100644 > --- a/softmmu_template.h > +++ b/softmmu_template.h > @@ -396,6 +396,26 @@ static inline void glue(helper_le_st_name, _do_unl_access)(CPUArchState *env, > } > } > > +static inline void glue(helper_le_st_name, _do_mmio_access)(CPUArchState *env, > + DATA_TYPE val, > + target_ulong addr, > + TCGMemOpIdx oi, > + unsigned mmu_idx, > + int index, > + uintptr_t retaddr) > +{ > + CPUIOTLBEntry *iotlbentry = &env->iotlb[mmu_idx][index]; > + > + if ((addr & (DATA_SIZE - 1)) != 0) { > + glue(helper_le_st_name, _do_unl_access)(env, val, addr, mmu_idx, > + oi, retaddr); > + } > + /* ??? Note that the io helpers always read data in the target > + byte ordering. We should push the LE/BE request down into io. */ > + val = TGT_LE(val); > + glue(io_write, SUFFIX)(env, iotlbentry, val, addr, retaddr); > +} > + > void helper_le_st_name(CPUArchState *env, target_ulong addr, DATA_TYPE val, > TCGMemOpIdx oi, uintptr_t retaddr) > { > @@ -423,17 +443,8 @@ void helper_le_st_name(CPUArchState *env, target_ulong addr, DATA_TYPE val, > > /* Handle an IO access. */ > if (unlikely(tlb_addr & ~TARGET_PAGE_MASK)) { > - CPUIOTLBEntry *iotlbentry; > - if ((addr & (DATA_SIZE - 1)) != 0) { > - glue(helper_le_st_name, _do_unl_access)(env, val, addr, mmu_idx, > - oi, retaddr); > - } > - iotlbentry = &env->iotlb[mmu_idx][index]; > - > - /* ??? Note that the io helpers always read data in the target > - byte ordering. We should push the LE/BE request down into io. */ > - val = TGT_LE(val); > - glue(io_write, SUFFIX)(env, iotlbentry, val, addr, retaddr); > + glue(helper_le_st_name, _do_mmio_access)(env, val, addr, oi, > + mmu_idx, index, retaddr); > return; > } > > @@ -488,6 +499,26 @@ static inline void glue(helper_be_st_name, _do_unl_access)(CPUArchState *env, > } > } > > +static inline void glue(helper_be_st_name, _do_mmio_access)(CPUArchState *env, > + DATA_TYPE val, > + target_ulong addr, > + TCGMemOpIdx oi, > + unsigned mmu_idx, > + int index, > + uintptr_t retaddr) > +{ > + CPUIOTLBEntry *iotlbentry = &env->iotlb[mmu_idx][index]; > + > + if ((addr & (DATA_SIZE - 1)) != 0) { > + glue(helper_be_st_name, _do_unl_access)(env, val, addr, mmu_idx, > + oi, retaddr); > + } > + /* ??? Note that the io helpers always read data in the target > + byte ordering. We should push the LE/BE request down into io. */ > + val = TGT_BE(val); > + glue(io_write, SUFFIX)(env, iotlbentry, val, addr, retaddr); > +} > + As before I still thing there is millage in having a common helper between LE/BE which the compiler can sort out. Having said that there is less argument for this function as it is a bit smalled and you would need a bit more faffing about. Reviewed-by: Alex Bennée > void helper_be_st_name(CPUArchState *env, target_ulong addr, DATA_TYPE val, > TCGMemOpIdx oi, uintptr_t retaddr) > { > @@ -515,17 +546,8 @@ void helper_be_st_name(CPUArchState *env, target_ulong addr, DATA_TYPE val, > > /* Handle an IO access. */ > if (unlikely(tlb_addr & ~TARGET_PAGE_MASK)) { > - CPUIOTLBEntry *iotlbentry; > - if ((addr & (DATA_SIZE - 1)) != 0) { > - glue(helper_be_st_name, _do_unl_access)(env, val, addr, mmu_idx, > - oi, retaddr); > - } > - iotlbentry = &env->iotlb[mmu_idx][index]; > - > - /* ??? Note that the io helpers always read data in the target > - byte ordering. We should push the LE/BE request down into io. */ > - val = TGT_BE(val); > - glue(io_write, SUFFIX)(env, iotlbentry, val, addr, retaddr); > + glue(helper_be_st_name, _do_mmio_access)(env, val, addr, oi, > + mmu_idx, index, retaddr); > return; > } -- Alex Bennée