qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
From: John Snow <jsnow@redhat.com>
To: Markus Armbruster <armbru@redhat.com>
Cc: michael.roth@amd.com, qemu-devel@nongnu.org, marcandre.lureau@redhat.com
Subject: Re: [PATCH 13/28] qapi: Enforce event naming rules
Date: Thu, 25 Mar 2021 13:50:24 -0400	[thread overview]
Message-ID: <8e89a84f-8fc8-13e1-5840-fbba018f84e9@redhat.com> (raw)
In-Reply-To: <87blb7ah1t.fsf@dusky.pond.sub.org>

On 3/25/21 2:22 AM, Markus Armbruster wrote:
> John Snow <jsnow@redhat.com> writes:
> 
>> On 3/24/21 2:22 AM, Markus Armbruster wrote:
>>> John Snow <jsnow@redhat.com> writes:
>>>
>>>> On 3/23/21 5:40 AM, Markus Armbruster wrote:
>>>>> Event names should be ALL_CAPS with words separated by underscore.
>>>>> Enforce this.  The only offenders are in tests/.  Fix them.  Existing
>>>>> test event-case covers the new error.
>>>>> Signed-off-by: Markus Armbruster <armbru@redhat.com>
>>>>> ---
>>>>>     tests/unit/test-qmp-event.c               |  6 +++---
>>>>>     scripts/qapi/expr.py                      |  4 +++-
>>>>>     tests/qapi-schema/doc-good.json           |  4 ++--
>>>>>     tests/qapi-schema/doc-good.out            |  4 ++--
>>>>>     tests/qapi-schema/doc-good.txt            |  2 +-
>>>>>     tests/qapi-schema/doc-invalid-return.json |  4 ++--
>>>>>     tests/qapi-schema/event-case.err          |  2 ++
>>>>>     tests/qapi-schema/event-case.json         |  2 --
>>>>>     tests/qapi-schema/event-case.out          | 14 --------------
>>>>>     tests/qapi-schema/qapi-schema-test.json   |  6 +++---
>>>>>     tests/qapi-schema/qapi-schema-test.out    |  8 ++++----
>>>>>     11 files changed, 22 insertions(+), 34 deletions(-)
>>>>> diff --git a/tests/unit/test-qmp-event.c
>>>>> b/tests/unit/test-qmp-event.c
>>>>> index 047f44ff9a..d58c3b78f2 100644
>>>>> --- a/tests/unit/test-qmp-event.c
>>>>> +++ b/tests/unit/test-qmp-event.c
>>>>> @@ -143,7 +143,7 @@ static void test_event_d(TestEventData *data,
>>>>>       static void test_event_deprecated(TestEventData *data, const
>>>>> void *unused)
>>>>>     {
>>>>> -    data->expect = qdict_from_jsonf_nofail("{ 'event': 'TEST-EVENT-FEATURES1' }");
>>>>> +    data->expect = qdict_from_jsonf_nofail("{ 'event': 'TEST_EVENT_FEATURES1' }");
>>>>>           memset(&compat_policy, 0, sizeof(compat_policy));
>>>>>     @@ -163,7 +163,7 @@ static void
>>>>> test_event_deprecated_data(TestEventData *data, const void *unused)
>>>>>     {
>>>>>         memset(&compat_policy, 0, sizeof(compat_policy));
>>>>>     -    data->expect = qdict_from_jsonf_nofail("{ 'event':
>>>>> 'TEST-EVENT-FEATURES0',"
>>>>> +    data->expect = qdict_from_jsonf_nofail("{ 'event': 'TEST_EVENT_FEATURES0',"
>>>>>                                                " 'data': { 'foo': 42 } }");
>>>>>         qapi_event_send_test_event_features0(42);
>>>>>         g_assert(data->emitted);
>>>>> @@ -172,7 +172,7 @@ static void test_event_deprecated_data(TestEventData *data, const void *unused)
>>>>>           compat_policy.has_deprecated_output = true;
>>>>>         compat_policy.deprecated_output = COMPAT_POLICY_OUTPUT_HIDE;
>>>>> -    data->expect = qdict_from_jsonf_nofail("{ 'event': 'TEST-EVENT-FEATURES0' }");
>>>>> +    data->expect = qdict_from_jsonf_nofail("{ 'event': 'TEST_EVENT_FEATURES0' }");
>>>>>         qapi_event_send_test_event_features0(42);
>>>>>         g_assert(data->emitted);
>>>>>     diff --git a/scripts/qapi/expr.py b/scripts/qapi/expr.py
>>>>> index b5fb0be48b..c065505b27 100644
>>>>> --- a/scripts/qapi/expr.py
>>>>> +++ b/scripts/qapi/expr.py
>>>>> @@ -45,7 +45,9 @@ def check_name_str(name, info, source):
>>>>>       def check_name_upper(name, info, source):
>>>>>         stem = check_name_str(name, info, source)
>>>>> -    # TODO reject '[a-z-]' in @stem
>>>>> +    if re.search(r'[a-z-]', stem):
>>>>> +        raise QAPISemError(
>>>>> +            info, "name of %s must not use lowercase or '-'" % source)
>>>>>     
>>>>
>>>> Does a little bit more than check_name_upper. Is this only used for
>>>> event names? I guess so. Should it be inlined into check_defn_name_str
>>>> instead in this case, or nah?
>>>
>>> I'd prefer not to inline.  I'm open to better function names.
>>>
>>> We have three name styles.  qapi-code-gen.txt:
>>>
>>>       [Type] definitions should always use CamelCase for
>>>       user-defined type names, while built-in types are lowercase.
>>>
>>>       [...]
>>>
>>>       Command names, and member names within a type, should be all lower
>>>       case with words separated by a hyphen.  [...]
>>>
>>>       Event names should be ALL_CAPS with words separated by underscore.
>>>
>>> I define three functions for them: check_name_camel(),
>>> check_name_lower(), and check_name_upper().
>>>
>>> The functions factor out the naming rule aspect, and they let us keep
>>> the naming rule aspect together.  That's why I'd prefer not to inline.
>>>
>>> We could name them after their purpose instead:
>>> check_name_user_defined_type(), check_name_command_or_member(),
>>> check_name_event().  The first two are rather long.  Shorter:
>>> check_name_type(), check_name_other(), check_name_event().
>>>
>>> Thoughts?
>>>
>>
>> The long names are nice and descriptive.
> 
> Then I should give them a try to see whether the result feels neat or
> ugly.
> 

I tried my hand at documenting them in my respin; I am not entirely 
confident I got the names and purposes and semantics exactly right. I 
didn't try to rename them, but it would be easy to do. You'll have to 
let me know your preferences.

--js



  reply	other threads:[~2021-03-25 17:53 UTC|newest]

Thread overview: 93+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-03-23  9:39 [PATCH 00/28] qapi: Enforce naming rules Markus Armbruster
2021-03-23  9:39 ` [PATCH 01/28] qapi/pragma: Tidy up after removal of deprecated commands Markus Armbruster
2021-03-23 12:50   ` John Snow
2021-03-23  9:39 ` [PATCH 02/28] tests/qapi-schema: Drop redundant flat-union-inline test Markus Armbruster
2021-03-23 12:54   ` John Snow
2021-03-23  9:40 ` [PATCH 03/28] tests/qapi-schema: Rework comments on longhand member definitions Markus Armbruster
2021-03-23 13:00   ` John Snow
2021-03-23 13:58     ` Eric Blake
2021-03-23 14:25       ` John Snow
2021-03-23 13:59   ` Eric Blake
2021-03-23 14:27   ` John Snow
2021-03-23  9:40 ` [PATCH 04/28] tests/qapi-schema: Belatedly update comment on alternate clash Markus Armbruster
2021-03-23 13:12   ` John Snow
2021-03-23  9:40 ` [PATCH 05/28] tests/qapi-schema: Drop TODO comment on simple unions Markus Armbruster
2021-03-23 13:16   ` John Snow
2021-03-23  9:40 ` [PATCH 06/28] tests/qapi-schema: Tweak to demonstrate buggy member name check Markus Armbruster
2021-03-23 13:20   ` John Snow
2021-03-23 15:44     ` Markus Armbruster
2021-03-23 17:09       ` John Snow
2021-03-23 20:42         ` Markus Armbruster
2021-03-23  9:40 ` [PATCH 07/28] qapi: Fix to reject optional members with reserved names Markus Armbruster
2021-03-23 13:27   ` John Snow
2021-03-23 15:50     ` Markus Armbruster
2021-03-23  9:40 ` [PATCH 08/28] qapi: Support flat unions tag values with leading digit Markus Armbruster
2021-03-23 14:11   ` Eric Blake
2021-03-23 14:49   ` John Snow
2021-03-23 16:18     ` Markus Armbruster
2021-03-23 21:07       ` Markus Armbruster
2021-03-23  9:40 ` [PATCH 09/28] qapi: Lift enum-specific code out of check_name_str() Markus Armbruster
2021-03-23 14:13   ` Eric Blake
2021-03-23 21:44   ` John Snow
2021-03-23 22:11   ` John Snow
2021-03-24  5:55     ` Markus Armbruster
2021-03-23  9:40 ` [PATCH 10/28] qapi: Rework name checking in preparation of stricter checking Markus Armbruster
2021-03-23 14:20   ` Eric Blake
2021-03-23 14:30     ` John Snow
2021-03-23 14:40       ` Eric Blake
2021-03-23 16:25     ` Markus Armbruster
2021-03-23 21:14       ` Markus Armbruster
2021-03-23 22:15   ` John Snow
2021-03-24  5:57     ` Markus Armbruster
2021-03-24 20:11       ` John Snow
2021-03-25  6:18         ` Markus Armbruster
2021-03-25 17:48           ` John Snow
2021-03-26  5:25             ` Markus Armbruster
2021-03-23  9:40 ` [PATCH 11/28] qapi: Move uppercase rejection to check_name_lower() Markus Armbruster
2021-03-23 14:29   ` Eric Blake
2021-03-23 22:21   ` John Snow
2021-03-23  9:40 ` [PATCH 12/28] qapi: Consistently permit any case in downstream prefixes Markus Armbruster
2021-03-23 14:30   ` Eric Blake
2021-03-23 22:26   ` John Snow
2021-03-23  9:40 ` [PATCH 13/28] qapi: Enforce event naming rules Markus Armbruster
2021-03-23 14:32   ` Eric Blake
2021-03-23 22:31   ` John Snow
2021-03-24  6:22     ` Markus Armbruster
2021-03-24 20:07       ` John Snow
2021-03-25  6:22         ` Markus Armbruster
2021-03-25 17:50           ` John Snow [this message]
2021-03-23  9:40 ` [PATCH 14/28] qapi: Enforce type " Markus Armbruster
2021-03-23 14:50   ` Eric Blake
2021-03-23 16:27     ` Markus Armbruster
2021-03-23  9:40 ` [PATCH 15/28] tests/qapi-schema: Rename redefined-builtin to redefined-predefined Markus Armbruster
2021-03-23 14:55   ` Eric Blake
2021-03-23  9:40 ` [PATCH 16/28] qapi: Factor out QAPISchemaParser._check_pragma_list_of_str() Markus Armbruster
2021-03-23 15:01   ` Eric Blake
2021-03-23  9:40 ` [PATCH 17/28] tests/qapi-schema: Rename pragma-*-crap to pragma-value-not-* Markus Armbruster
2021-03-23 15:02   ` Eric Blake
2021-03-23  9:40 ` [PATCH 18/28] tests/qapi-schema: Rename returns-whitelist to returns-bad-type Markus Armbruster
2021-03-23 15:06   ` Eric Blake
2021-03-23  9:40 ` [PATCH 19/28] qapi: Rename pragma *-whitelist to *-exceptions Markus Armbruster
2021-03-23 15:09   ` Eric Blake
2021-03-23 16:35     ` Markus Armbruster
2021-03-23  9:40 ` [PATCH 20/28] qapi/pragma: Streamline comments on member-name-exceptions Markus Armbruster
2021-03-23 15:10   ` Eric Blake
2021-03-23  9:40 ` [PATCH 21/28] tests-qmp-cmds: Drop unused and incorrect qmp_TestIfCmd() Markus Armbruster
2021-03-23 15:11   ` Eric Blake
2021-03-23  9:40 ` [PATCH 22/28] qapi: Prepare for rejecting underscore in command and member names Markus Armbruster
2021-03-23 15:15   ` Eric Blake
2021-03-23  9:40 ` [PATCH 23/28] qapi: Enforce feature naming rules Markus Armbruster
2021-03-23 15:16   ` Eric Blake
2021-03-23  9:40 ` [PATCH 24/28] qapi: Enforce command " Markus Armbruster
2021-03-23 15:23   ` Eric Blake
2021-03-23 21:19     ` Markus Armbruster
2021-03-23  9:40 ` [PATCH 25/28] tests/qapi-schema: Switch member name clash test to struct Markus Armbruster
2021-03-23 15:42   ` Eric Blake
2021-03-23  9:40 ` [PATCH 26/28] qapi: Enforce struct member naming rules Markus Armbruster
2021-03-23 15:46   ` Eric Blake
2021-03-23 21:23     ` Markus Armbruster
2021-03-23  9:40 ` [PATCH 27/28] qapi: Enforce enum " Markus Armbruster
2021-03-23 15:47   ` Eric Blake
2021-03-23  9:40 ` [PATCH 28/28] qapi: Enforce union and alternate branch " Markus Armbruster
2021-03-23 16:05   ` Eric Blake
2021-03-23 21:24     ` Markus Armbruster

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8e89a84f-8fc8-13e1-5840-fbba018f84e9@redhat.com \
    --to=jsnow@redhat.com \
    --cc=armbru@redhat.com \
    --cc=marcandre.lureau@redhat.com \
    --cc=michael.roth@amd.com \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).