qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-07-05 18:30:59 to 2020-07-06 11:22:39 UTC [more...]

[PATCH 0/2] two atomic_cmpxchg() related fixes
 2020-07-06 11:19 UTC  (5+ messages)
` [PATCH 1/2] virtio-ccw: fix virtio_set_ind_atomic

[PATCH v9 0/5] linux-user: User support for AArch64 BTI
 2020-07-06 11:15 UTC  (7+ messages)
` [PATCH v9 1/5] linux-user/aarch64: Reset btype for signals
` [PATCH v9 2/5] linux-user: Set PAGE_TARGET_1 for TARGET_PROT_BTI
` [PATCH v9 5/5] tests/tcg/aarch64: Add bti smoke test

DMA region abruptly removed from PCI device
 2020-07-06 10:55 UTC 

[PATCH] virtio-pci: Changed vdev to proxy for VirtIO PCI BAR callbacks
 2020-07-06 11:21 UTC 

[PATCH v3 00/16] block/nvme: Various cleanups required to use multiple queues
 2020-07-06 10:32 UTC  (5+ messages)
` [PATCH v3 05/16] block/nvme: Improve error message when IO queue creation failed
` [PATCH v3 16/16] block/nvme: Use per-queuepair IRQ notifier and AIO context

[PULL 00/31] Block patches
 2020-07-06 10:31 UTC  (33+ messages)
` [PULL 01/31] block/block-copy: block_copy_dirty_clusters: fix failure check
` [PULL 02/31] qcow2: Fix preallocation on images with unaligned sizes
` [PULL 03/31] iotests: Make _filter_img_create more active
` [PULL 04/31] iotests: filter few more luks specific create options
` [PULL 05/31] iotests/common.rc: Add _require_working_luks
` [PULL 06/31] iotests.py: Add qemu_img_pipe_and_status()
` [PULL 07/31] iotests.py: Add (verify|has)_working_luks()
` [PULL 08/31] iotests: Check whether luks works
` [PULL 09/31] qcrypto/core: add generic infrastructure for crypto options amendment
` [PULL 10/31] qcrypto/luks: implement encryption key management
` [PULL 11/31] block/amend: add 'force' option
` [PULL 12/31] block/amend: separate amend and create options for qemu-img
` [PULL 13/31] block/amend: refactor qcow2 amend options
` [PULL 14/31] block/crypto: rename two functions
` [PULL 15/31] block/crypto: implement the encryption key management
` [PULL 16/31] block/qcow2: extend qemu-img amend interface with crypto options
` [PULL 17/31] iotests: qemu-img tests for luks key management
` [PULL 18/31] block/core: add generic infrastructure for x-blockdev-amend qmp command
` [PULL 19/31] block/crypto: implement blockdev-amend
` [PULL 20/31] block/qcow2: "
` [PULL 21/31] iotests: add tests for blockdev-amend
` [PULL 22/31] qemu-img: convert: don't use unallocated_blocks_are_zero
` [PULL 23/31] block: inline bdrv_unallocated_blocks_are_zero()
` [PULL 24/31] block/vdi: return ZERO block-status when appropriate
` [PULL 25/31] block/vpc: "
` [PULL 26/31] block/crypto: drop unallocated_blocks_are_zero
` [PULL 27/31] block/iscsi: "
` [PULL 28/31] block/file-posix: "
` [PULL 29/31] block/vhdx: "
` [PULL 30/31] block: "
` [PULL 31/31] qed: Simplify backing reads

[REPORT] [GSoC - TCG Continuous Benchmarking] [#3] QEMU 5.0 and 5.1-pre-soft-freeze Dissect Comparison
 2020-07-06 10:30 UTC 

[PATCH v2 0/7] virtio: enable VIRTIO_F_RING_PACKED for all devices
 2020-07-06 10:23 UTC  (7+ messages)
` [PATCH v2 3/7] docs: document non-net VHOST_USER_GET_FEATURES behavior
` [PATCH v2 4/7] vhost: involve device backends in feature negotiation

[PULL 00/37] qom-ify serial and remove QDEV_PROP_PTR
 2020-07-06 10:13 UTC  (5+ messages)
` [PULL 36/37] qdev: "

[PATCH] Fix MIPS add.s after 1ace099f2acb952eaaef0ba7725879949a7e4406
 2020-07-06 10:22 UTC  (3+ messages)

[PATCH v3 00/44] Less clumsy error checking
 2020-07-06 10:08 UTC  (47+ messages)
` [PATCH v3 01/44] error: Improve examples in error.h's big comment
` [PATCH v3 02/44] error: Document Error API usage rules
` [PATCH v3 03/44] qdev: Use returned bool to check for qdev_realize() etc. failure
` [PATCH v3 04/44] macio: Tidy up error handling in macio_newworld_realize()
` [PATCH v3 05/44] virtio-crypto-pci: Tidy up virtio_crypto_pci_realize()
` [PATCH v3 06/44] qemu-option: Check return value instead of @err where convenient
` [PATCH v3 07/44] qemu-option: Make uses of find_desc_by_name() more similar
` [PATCH v3 08/44] qemu-option: Factor out helper find_default_by_name()
` [PATCH v3 09/44] qemu-option: Simplify around find_default_by_name()
` [PATCH v3 10/44] qemu-option: Factor out helper opt_create()
` [PATCH v3 11/44] qemu-option: Replace opt_set() by cleaner opt_validate()
` [PATCH v3 12/44] qemu-option: Make functions taking Error ** return bool, not void
` [PATCH v3 13/44] qemu-option: Use returned bool to check for failure
` [PATCH v3 14/44] block: Avoid error accumulation in bdrv_img_create()
` [PATCH v3 15/44] hmp: Eliminate a variable in hmp_migrate_set_parameter()
` [PATCH v3 16/44] qapi: Make visitor functions taking Error ** return bool, not void
` [PATCH v3 17/44] qapi: Use returned bool to check for failure, Coccinelle part
` [PATCH v3 18/44] qapi: Use returned bool to check for failure, manual part
` [PATCH v3 19/44] s390x/pci: Fix harmless mistake in zpci's property fid's setter
` [PATCH v3 20/44] qom: Use error_reportf_err() instead of g_printerr() in examples
` [PATCH v3 21/44] qom: Rename qdev_get_type() to object_get_type()
` [PATCH v3 22/44] qom: Crash more nicely on object_property_get_link() failure
` [PATCH v3 23/44] qom: Don't handle impossible "
` [PATCH v3 24/44] qom: Use return values to check for error where that's simpler
` [PATCH v3 25/44] qom: Put name parameter before value / visitor parameter
` [PATCH v3 26/44] qom: Make functions taking Error ** return bool, not void
` [PATCH v3 27/44] qom: Use returned bool to check for failure, Coccinelle part
` [PATCH v3 28/44] qom: Use returned bool to check for failure, manual part
` [PATCH v3 29/44] qom: Make functions taking Error ** return bool, not 0/-1
` [PATCH v3 30/44] qdev: Make functions taking Error ** return bool, not void
` [PATCH v3 31/44] qdev: Use returned bool to check for failure, Coccinelle part
` [PATCH v3 32/44] error: Avoid unnecessary error_propagate() after error_setg()
` [PATCH v3 33/44] error: Eliminate error_propagate() with Coccinelle, part 1
` [PATCH v3 34/44] error: Eliminate error_propagate() with Coccinelle, part 2
` [PATCH v3 35/44] error: Eliminate error_propagate() manually
` [PATCH v3 36/44] error: Reduce unnecessary error propagation
` [PATCH v3 37/44] block/parallels: Simplify parallels_open() after previous commit
` [PATCH v3 38/44] qapi: Smooth another visitor error checking pattern
` [PATCH v3 39/44] qapi: Smooth visitor error checking in generated code
` [PATCH v3 40/44] qapi: Purge error_propagate() from QAPI core
` [PATCH v3 41/44] error: Avoid error_propagate() after migrate_add_blocker()
` [PATCH v3 42/44] qemu-img: Ignore Error objects where the return value suffices
` [PATCH v3 43/44] qdev: "
` [PATCH v3 44/44] hmp: "

[PATCH v3 00/18] hw/block/nvme: bump to v1.3
 2020-07-06  9:50 UTC  (23+ messages)
` [PATCH v3 01/18] hw/block/nvme: bump spec data structures "
` [PATCH v3 02/18] hw/block/nvme: fix missing endian conversion
` [PATCH v3 03/18] hw/block/nvme: additional tracing
` [PATCH v3 04/18] hw/block/nvme: add support for the abort command
` [PATCH v3 05/18] hw/block/nvme: add temperature threshold feature
` [PATCH v3 06/18] hw/block/nvme: mark fw slot 1 as read-only
` [PATCH v3 07/18] hw/block/nvme: add support for the get log page command
` [PATCH v3 08/18] hw/block/nvme: add support for the asynchronous event request command
` [PATCH v3 09/18] hw/block/nvme: move NvmeFeatureVal into hw/block/nvme.h
` [PATCH v3 10/18] hw/block/nvme: flush write cache when disabled
` [PATCH v3 11/18] hw/block/nvme: add remaining mandatory controller parameters
` [PATCH v3 12/18] hw/block/nvme: support the get/set features select and save fields
` [PATCH v3 13/18] hw/block/nvme: make sure ncqr and nsqr is valid
` [PATCH v3 14/18] hw/block/nvme: support identify namespace descriptor list
` [PATCH v3 15/18] hw/block/nvme: reject invalid nsid values in active namespace id list
` [PATCH v3 16/18] hw/block/nvme: enforce valid queue creation sequence
` [PATCH v3 17/18] hw/block/nvme: provide the mandatory subnqn field
` [PATCH v3 18/18] hw/block/nvme: bump supported version to v1.3

[PATCH v1] target/riscv: fix pmp implementation
 2020-07-06  8:45 UTC 

[PATCH 0/2] Add new features for intel processor
 2020-07-06  9:25 UTC  (4+ messages)
` [PATCH 1/2] target/i386: Add SERIALIZE cpu feature
` [PATCH 2/2] target/i386: Enable TSX Suspend Load Address Tracking feature

[PATCH v3 00/10] drop unallocated_blocks_are_zero
 2020-07-06  9:17 UTC  (4+ messages)
` [PATCH v3 04/10] block/vpc: return ZERO block-status when appropriate

[PATCH v3 0/2] VMD endpoint passthrough support
 2020-07-06  9:16 UTC  (3+ messages)
` [PATCH v3 2/2] PCI: vmd: Use Shadow MEMBAR registers for QEMU/KVM guests

[PATCH v7 00/17] hw/sd/sdcard: Fix CVE-2020-13253 & cleanups
 2020-07-06  9:15 UTC  (5+ messages)
` [PATCH v7 09/17] hw/sd/sdcard: Special case the -ENOMEDIUM error

[PATCH 1/3] target/nios2: add DISAS_NORETURN case for nothing more to generate
 2020-07-06  8:55 UTC  (10+ messages)
` [PATCH 3/3] target/nios2: Use gen_io_start around wrctl instruction

[PATCH v2] fcntl: Add 32bit filesystem mode
 2020-07-06  8:54 UTC  (3+ messages)

[PATCH v2] MAINTAINERS: Cover the firmware JSON schema
 2020-07-06  8:52 UTC  (2+ messages)

[PATCH v3 0/2] net: tap: check file descriptor can be used
 2020-07-06  8:47 UTC  (9+ messages)
` [PATCH v3 1/2] net: tap: check if the file descriptor is valid before using it
` [PATCH v3 2/2] net: detect errors from probing vnet hdr flag for TAP devices

[PATCH v2] hw/core/qdev: Increase qdev_realize() kindness
 2020-07-06  8:20 UTC  (3+ messages)

[PATCH v11 0/8] error: auto propagated local_err part I
 2020-07-06  7:55 UTC  (9+ messages)
` [PATCH v11 1/8] error: auto propagated local_err
` [PATCH v11 7/8] nbd: introduce ERRP_AUTO_PROPAGATE
` [PATCH v11 8/8] xen: "

[Bug 1886343] [NEW] configure has non-posix bash syntax
 2020-07-06  7:46 UTC  (2+ messages)
` [Bug 1886343] "

[PATCH v3] target/ppc: add vmsumudm vmsumcud instructions
 2020-07-06  7:53 UTC  (2+ messages)

[PULL 0/6] qtest and misc patches
 2020-07-06  7:36 UTC  (8+ messages)
` [PULL 1/6] fuzz: fix broken qtest check at rcu_disable_atfork
` [PULL 2/6] fuzz: do not use POSIX shm for coverage bitmap
` [PULL 3/6] tests/qtest: Unify the test for the xenfv and xenpv machines
` [PULL 4/6] configure / util: Auto-detect the availability of openpty()
` [PULL 5/6] hw/m68k/mcf5206: Replace remaining hw_error()s by qemu_log_mask()
` [PULL 6/6] tests/acceptance: Add a test for the sun4u sparc64 machine

[PATCH v4 00/11] Add several Power ISA 3.1 32/64-bit vector instructions
 2020-07-06  7:34 UTC  (3+ messages)

[PATCH v4] nvme: allow cmb and pmr emulation on same device
 2020-07-06  7:15 UTC  (8+ messages)
` [PATCH v4 2/2] nvme: allow cmb and pmr to be enabled "

[PATCH] hw/core/qdev: Increase qdev_realize() kindness
 2020-07-06  6:48 UTC  (5+ messages)

[PATCH] ram: add support for dirty page tracking
 2020-07-06  6:39 UTC 

[PATCH 00/13] Reverse debugging
 2020-07-06  6:02 UTC  (2+ messages)

[Bug 1885827] [NEW] building plugin failed on Windows with mingw
 2020-07-06  5:44 UTC  (2+ messages)
` [Bug 1885827] "

[PATCH] load_elf: Remove unused address variables from callers
 2020-07-06  3:54 UTC  (2+ messages)

[Bug 1886362] [NEW] Heap use-after-free in lduw_he_p through e1000e_write_to_rx_buffers
 2020-07-06  2:44 UTC 

[PATCH v2] ftgmac100: fix dblac write test
 2020-07-06  1:59 UTC  (2+ messages)

[PATCH] target/xtensa: implement NMI support
 2020-07-06  1:55 UTC 

[PATCH v2 0/5] hw/i2c: Rename method names for consistency and add documentation
 2020-07-06  1:39 UTC  (7+ messages)
` [PATCH v2 1/5] hw/i2c/aspeed_i2c: Simplify aspeed_i2c_get_bus()
` [PATCH v2 2/5] hw/i2c: Rename i2c_try_create_slave() as i2c_slave_new()
` [PATCH v2 3/5] hw/i2c: Rename i2c_realize_and_unref() as i2c_slave_realize_and_unref()
` [PATCH v2 4/5] hw/i2c: Rename i2c_create_slave() as i2c_slave_create_simple()
` [PATCH v2 5/5] hw/i2c: Document the I2C qdev helpers

[PATCH v2 0/1] Add Loongson 2F disassembler
 2020-07-06  0:57 UTC  (3+ messages)
` [PATCH v2 1/1] disas: mips: "

[RFC PATCH 0/2] hw/sd: Deprecate the SPI mode and the SPI to SD adapter
 2020-07-05 22:07 UTC  (3+ messages)
` [RFC PATCH 1/2] hw/sd/ssi-sd: Deprecate the SPI to SD card 'adapter'
` [RFC PATCH 2/2] hw/sd/sdcard: Deprecate the SPI mode

[PATCH 0/2] hw/sd/pxa2xx_mmci: Do not create SD card within the SDHCI controller
 2020-07-05 21:33 UTC  (3+ messages)
` [PATCH 1/2] "
` [PATCH 2/2] hw/sd/pxa2xx_mmci: Trivial simplification

[PATCH rc6 00/30] target/avr merger
 2020-07-05 21:30 UTC  (6+ messages)
` [PATCH rc6 26/30] target/avr: Update build system

[PATCH 0/4] hw/sd/milkymist: Do not create SD card within the SDHCI controller
 2020-07-05 21:10 UTC  (5+ messages)
` [PATCH 1/4] hw/lm32/milkymist: Un-inline milkymist_memcard_create()
` [PATCH 2/4] hw/lm32/milkymist: Comment to remember some IRQs lines are left unwired
` [PATCH 3/4] hw/sd/milkymist: Create the SDBus at init()
` [PATCH 4/4] hw/sd/milkymist: Do not create SD card within the SDHCI controller

[PATCH v4 00/10] hw/sd: convert legacy SDHCI devices to the SDBus API
 2020-07-05 20:46 UTC  (11+ messages)
` [PATCH v4 01/10] hw/sd/pl181: Replace fprintf(stderr, "*\n") with error_report()
` [PATCH v4 02/10] hw/sd/pl181: Rename pl181_send_command() as pl181_do_command()
` [PATCH v4 03/10] hw/sd/pl181: Add TODO to use Fifo32 API
` [PATCH v4 04/10] hw/arm/versatilepb: Comment to remember some IRQs lines are left unwired
` [PATCH v4 05/10] hw/sd/pl181: Use named GPIOs
` [PATCH v4 06/10] hw/sd/pl181: Expose a SDBus and connect the SDCard to it
` [PATCH v4 07/10] hw/sd/pl181: Do not create SD card within the SDHCI controller
` [PATCH v4 08/10] hw/sd/pl181: Replace disabled fprintf()s by trace events
` [PATCH v4 09/10] hw/sd/sdcard: make sd_data_ready() static
` [PATCH v4 10/10] hw/sd: move sdcard legacy API to 'hw/sd/sdcard_legacy.h'

[PATCH 00/26] hw/usb: Give it love, reduce 'hw/usb.h' inclusion out of hw/usb/
 2020-07-05 19:55 UTC  (3+ messages)
` [PATCH 22/26] hw/usb/usb-hcd: Use OHCI type definitions


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).