qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-11-04 12:22:38 to 2020-11-04 17:59:53 UTC [more...]

[PATCH RFC] memory: pause all vCPUs for the duration of memory transactions
 2020-11-04 17:58 UTC  (4+ messages)

[PATCH] hw/arm/Kconfig: ARM_V7M depends on PTIMER
 2020-11-04 17:57 UTC  (3+ messages)

[PATCH-for-5.2 v3 0/4] ci: Move --without-default-devices job from Travis to GitLab
 2020-11-04 17:54 UTC  (10+ messages)
` [PATCH-for-5.2 v3 1/4] s390x: fix build for --without-default-devices
` [PATCH-for-5.2 v3 2/4] hw/9pfs: Fix Kconfig dependency problem between 9pfs and Xen
` [PATCH-for-5.2 v3 3/4] gitlab-ci: Add a job to cover the --without-default-devices config
` [PATCH-for-5.2 v3 4/4] travis-ci: Remove the --without-default-devices job

[PATCH 0/5] SCSI: fix transfer limits for SCSI passthrough
 2020-11-04 17:48 UTC  (7+ messages)
` [PATCH 1/5] file-posix: split hdev_refresh_limits from raw_refresh_limits
` [PATCH 2/5] file-posix: add sg_get_max_segments that actually works with sg
` [PATCH 3/5] block: add max_ioctl_transfer to BlockLimits
` [PATCH 4/5] block: use blk_get_max_ioctl_transfer for SCSI passthrough
` [PATCH 5/5] block/scsi: correctly emulate the VPD block limits page

[PATCH v2 00/20] backup performance: block_status + async
 2020-11-04 17:45 UTC  (17+ messages)
` [PATCH v2 08/20] block/block-copy: add block_copy_cancel
` [PATCH v2 11/20] qapi: backup: add x-max-chunk and x-max-workers parameters
` [PATCH v2 13/20] iotests: 129: prepare for backup over block-copy
` [PATCH v2 17/20] backup: move to block-copy

[PULL 0/3] Ui 20201104 patches
 2020-11-04 17:41 UTC  (5+ messages)
` [PULL 1/3] coroutine: let CoQueue wake up outside a coroutine
` [PULL 2/3] console: modify ppm_save to take a pixman image ref
` [PULL 3/3] console: make QMP/HMP screendump run in coroutine

VFIO Migration
 2020-11-04 17:32 UTC  (14+ messages)

[PATCH v2] target/s390x: fix execution with icount
 2020-11-04 17:31 UTC  (2+ messages)

[PATCH v2 00/44] Make qdev static property API usable by any QOM type
 2020-11-04 17:28 UTC  (49+ messages)
` [PATCH v2 01/44] cs4231: Get rid of empty property array
` [PATCH v2 02/44] cpu: Move cpu_common_props to hw/core/cpu.c
` [PATCH v2 03/44] qdev: Move property code to qdev-properties.[ch]
` [PATCH v2 04/44] qdev: Check dev->realized at set_size()
` [PATCH v2 05/44] sparc: Check dev->realized at sparc_set_nwindows()
` [PATCH v2 06/44] qdev: Don't use dev->id on set_size32() error message
` [PATCH v2 07/44] qdev: Make PropertyInfo.print method get Object* argument
` [PATCH v2 08/44] qdev: Make bit_prop_set() "
` [PATCH v2 09/44] qdev: Make qdev_get_prop_ptr() get Object* arg
` [PATCH v2 10/44] qdev: Make qdev_find_global_prop() get Object* argument
` [PATCH v2 11/44] qdev: Make check_prop_still_unset() "
` [PATCH v2 12/44] qdev: Make error_set_from_qdev_prop_error() "
` [PATCH v2 13/44] qdev: Move UUID property to qdev-properties-system.c
` [PATCH v2 14/44] qdev: Move softmmu properties to qdev-properties-system.h
` [PATCH v2 15/44] qdev: Reuse DEFINE_PROP in all DEFINE_PROP_* macros
` [PATCH v2 16/44] sparc: Use DEFINE_PROP for nwindows property
` [PATCH v2 17/44] qdev: Get just property name at error_set_from_qdev_prop_error()
` [PATCH v2 18/44] qdev: Avoid using prop->name unnecessarily
` [PATCH v2 19/44] qdev: Add name parameter to qdev_class_add_property()
` [PATCH v2 20/44] qdev: Add name argument to PropertyInfo.create method
` [PATCH v2 21/44] qdev: Wrap getters and setters in separate helpers
` [PATCH v2 22/44] qdev: Move dev->realized check to qdev_property_set()
` [PATCH v2 23/44] qdev: Make PropertyInfo.create return ObjectProperty*
` [PATCH v2 24/44] qdev: Make qdev_class_add_property() more flexible
` [PATCH v2 25/44] qdev: Separate generic and device-specific property registration
` [PATCH v2 26/44] qdev: Rename Property.name to Property.qdev_prop_name
` [PATCH v2 27/44] qdev: Don't set qdev_prop_name for array elements
` [PATCH v2 28/44] qdev: Avoid unnecessary DeviceState* variable at set_prop_arraylen()
` [PATCH v2 29/44] qdev: Remove ArrayElementProperty.propname field
` [PATCH v2 30/44] qdev: Get rid of ArrayElementProperty struct
` [PATCH v2 31/44] qdev: Reuse object_property_add_field() when adding array elements
` [PATCH v2 32/44] qom: Add allow_set callback to ObjectProperty
` [PATCH v2 33/44] qdev: Make qdev_prop_allow_set() a ObjectProperty.allow_set callback
` [PATCH v2 34/44] qdev: Make qdev_propinfo_get_uint16() static
` [PATCH v2 35/44] qdev: Rename qdev_propinfo_* to field_prop_*
` [PATCH v2 36/44] qdev: Rename qdev_get_prop_ptr() to object_field_prop_ptr()
` [PATCH v2 37/44] qdev: Move qdev_prop_tpm declaration to tpm_prop.h
` [PATCH v2 38/44] qdev: Rename qdev_prop_* to prop_info_*
` [PATCH v2 39/44] qdev: PROP_* macros
` [PATCH v2 40/44] qdev: Move core field property code to QOM
` [PATCH v2 41/44] qdev: Move base property types to qom/property-types.c
` [PATCH v2 42/44] qom: Include static property API reference in documentation
` [PATCH v2 43/44] tests: Use field properties at check-qom-proplist test case
` [PATCH v2 44/44] machine: Register most properties as field properties

[PATCH 0/7] qom: Field properties type safety
 2020-11-04 17:25 UTC  (8+ messages)
` [PATCH 1/7] sparc: Fix property/field size mismatch for iu-version
` [PATCH 2/7] qom: Save size of struct field in Property struct
` [PATCH 3/7] qdev: Don't register unreadable legacy properties
` [PATCH 4/7] qom: Replace void* parameter with Property* on field getters/setters
` [PATCH 5/7] qom: Replace void* parameter with Property* on PropertyInfo.release
` [PATCH 6/7] qom: Add FIELD_PTR, a type-safe wrapper for object_field_prop_ptr()
` [PATCH 7/7] sparc: Use FIELD_PTR at nwindows getter/setter

Migrating to the gitlab issue tracker
 2020-11-04 17:19 UTC  (8+ messages)

executing user code to test qemu driver
 2020-11-04 17:05 UTC 

[PATCH v2] block: Remove unused BlockDeviceMapEntry
 2020-11-04 17:19 UTC  (2+ messages)

[PULL v2 00/20] Misc patches for QEMU 5.2-rc1
 2020-11-04 17:04 UTC  (2+ messages)
` [PULL v2 20/20] qapi, qemu-options: make all parsing visitors parse boolean options the same

[PATCH 0/2] block: Remove unused BlockDeviceMapEntry
 2020-11-04 16:55 UTC  (3+ messages)
` [PATCH 1/2] qapi/block-core: Improve MapEntry documentation
` [PATCH 2/2] block: Remove unused BlockDeviceMapEntry

[RFC PATCH] docs: add some notes on the sbsa-ref machine
 2020-11-04 16:54 UTC  (3+ messages)

Ramping up Continuous Fuzzing of Virtual Devices in QEMU
 2020-11-04 16:52 UTC  (7+ messages)

[PATCH v2] docs: add some notes on the sbsa-ref machine
 2020-11-04 16:52 UTC 

[PULL 0/8] Usb 20201104 patches
 2020-11-04 16:52 UTC  (3+ messages)
` [PULL 6/8] dev-serial: add always-plugged property to ensure USB device is always attached

locking option doesn't work as expected
 2020-11-04 16:48 UTC  (2+ messages)

[qemu-web PATCH v2] Add virtio-fs in OSv overview blog post
 2020-11-04 16:46 UTC 

[PATCH] ssi: Fix bad printf format specifiers
 2020-11-04 16:21 UTC  (2+ messages)

[PATCH v2] Prefer 'on' | 'off' over 'yes' | 'no' for bool options
 2020-11-04 16:39 UTC 

[qemu-web PATCH] Add virtio-fs in OSv overview blog post
 2020-11-04 16:35 UTC  (3+ messages)

[PATCH v4 0/5] Fix the Hypervisor access functions
 2020-11-04 16:30 UTC  (5+ messages)
` [PATCH v4 1/5] target/riscv: Add a virtualised MMU Mode
` [PATCH v4 4/5] target/riscv: Remove the hyp load and store functions

[PATCH v3] qom: code hardening - have bound checking while looping with integer value
 2020-11-04 15:59 UTC  (5+ messages)

[RFC PATCH 0/6] eBPF RSS support for virtio-net
 2020-11-04 15:51 UTC  (6+ messages)
` [RFC PATCH 5/6] virtio-net: Added eBPF RSS to virtio-net

[PULL 0/3] Fixes 20201104 patches
 2020-11-04 15:46 UTC  (4+ messages)
` [PULL 1/3] vnc: fix resource leak when websocket channel error
` [PULL 2/3] ati: check x y display parameter values
` [PULL 3/3] roms/Makefile: Add qboot to .PHONY list

[PULL 00/33] Block patches
 2020-11-04 15:18 UTC  (34+ messages)
` [PULL 01/33] accel/kvm: add PIO ioeventfds only in case kvm_eventfds_allowed is true
` [PULL 02/33] softmmu/memory: fix memory_region_ioeventfd_equal()
` [PULL 03/33] MAINTAINERS: Cover "block/nvme.h" file
` [PULL 04/33] block/nvme: Use hex format to display offset in trace events
` [PULL 05/33] block/nvme: Report warning with warn_report()
` [PULL 06/33] block/nvme: Trace controller capabilities
` [PULL 07/33] block/nvme: Trace nvme_poll_queue() per queue
` [PULL 08/33] block/nvme: Improve nvme_free_req_queue_wait() trace information
` [PULL 09/33] block/nvme: Trace queue pair creation/deletion
` [PULL 10/33] block/nvme: Move definitions before structure declarations
` [PULL 11/33] block/nvme: Use unsigned integer for queue counter/size
` [PULL 12/33] block/nvme: Make nvme_identify() return boolean indicating error
` [PULL 13/33] block/nvme: Make nvme_init_queue() "
` [PULL 14/33] block/nvme: Introduce Completion Queue definitions
` [PULL 15/33] block/nvme: Use definitions instead of magic values in add_io_queue()
` [PULL 16/33] block/nvme: Correctly initialize Admin Queue Attributes
` [PULL 17/33] block/nvme: Simplify ADMIN queue access
` [PULL 18/33] block/nvme: Simplify nvme_cmd_sync()
` [PULL 19/33] block/nvme: Set request_alignment at initialization
` [PULL 20/33] block/nvme: Correct minimum device page size
` [PULL 21/33] block/nvme: Change size and alignment of IDENTIFY response buffer
` [PULL 22/33] block/nvme: Change size and alignment of queue
` [PULL 23/33] block/nvme: Change size and alignment of prp_list_pages
` [PULL 24/33] block/nvme: Align iov's va and size on host page size
` [PULL 25/33] block/nvme: Fix use of write-only doorbells page on Aarch64 arch
` [PULL 26/33] block/nvme: Fix nvme_submit_command() on big-endian host
` [PULL 27/33] util/vfio-helpers: Improve reporting unsupported IOMMU type
` [PULL 28/33] util/vfio-helpers: Trace PCI I/O config accesses
` [PULL 29/33] util/vfio-helpers: Trace PCI BAR region info
` [PULL 30/33] util/vfio-helpers: Trace where BARs are mapped
` [PULL 31/33] util/vfio-helpers: Improve DMA trace events
` [PULL 32/33] util/vfio-helpers: Convert vfio_dump_mapping to "
` [PULL 33/33] util/vfio-helpers: Assert offset is aligned to page size

[PATCH] Prefer 'on' | 'off' over 'yes' | 'no' for bool options
 2020-11-04 15:39 UTC  (4+ messages)

[PULL 00/20] Misc patches for QEMU 5.2-rc1
 2020-11-04 15:01 UTC  (21+ messages)
` [PULL 01/20] cutils: replace strdup with g_strdup
` [PULL 02/20] docs: expand sourceset documentation
` [PULL 03/20] exec: Remove dead code (CID 1432876)
` [PULL 04/20] scripts/oss-fuzz: rename bin/qemu-fuzz-i386
` [PULL 05/20] hw/isa/lpc_ich9: Ignore reserved/invalid SCI IRQ
` [PULL 06/20] qtest: add a reproducer for LP#1878642
` [PULL 07/20] meson: use b_staticpic=false for meson >=0.56.0
` [PULL 08/20] meson: vhost-user-gpu/virtiofsd: use absolute path
` [PULL 09/20] tests/qtest/libqtest.c: Check for setsockopt() failure
` [PULL 10/20] tests/qtest/libqos/ahci.c: Avoid NULL dereference in ahci_exec()
` [PULL 11/20] meson: fix warning for bad sphinx-build
` [PULL 12/20] configure: fix gio_libs reference
` [PULL 13/20] tests/qtest: Fix potential NULL pointer dereference in qos_build_main_args()
` [PULL 14/20] fuzz: fix writing DMA patterns
` [PULL 15/20] fuzz: check the MR in the DMA callback
` [PULL 16/20] fuzz: fuzz offsets within pio/mmio regions
` [PULL 17/20] semihosting: fix order of initialization functions
` [PULL 18/20] qapi, qemu-options: make all parsing visitors parse boolean options the same
` [PULL 19/20] ivshmem-test: do not use short-form boolean option
` [PULL 20/20] qtest: escape device name in device-introspect-test

[PATCH v2 00/16] qapi: static typing conversion, pt3
 2020-11-04 14:53 UTC  (3+ messages)

[PATCH v2 0/6] QOM minor fixes
 2020-11-04 14:51 UTC  (6+ messages)
` [PATCH v2 5/6] macio: don't reference serial_hd() directly within the device

[Qemu-devel] [Bug 1797262] [NEW] qemu arm no longer able to boot RPI Kernels
 2020-11-04 13:59 UTC  (2+ messages)
` [Bug 1797262] "

[PATCH] As FreeBSD ports MAINTAINER add myself for FreeBSD Hosted CI
 2020-11-04  0:28 UTC 

[Bug 1901981] [NEW] assert issue locates in hw/usb/dev-storage.c:248: usb_msd_send_status
 2020-11-04 13:55 UTC  (2+ messages)
` [Bug 1901981] "

[PATCH 0/3] Some cleanups to build deps
 2020-11-04 13:47 UTC  (7+ messages)
` [PATCH 1/3] hw/usb/ccid: remove references to NSS
` [PATCH 2/3] tests: remove "bc" from package listing
` [PATCH 3/3] docker: remove libblockdev-mpath-devel package

[PATCH for-5.2 0/4] deprecate short-form boolean options
 2020-11-04 13:43 UTC  (8+ messages)
` [PATCH for-5.2 2/4] qemu-option: move help handling to get_opt_name_value
` [PATCH for-5.2 4/4] qemu-option: warn for short-form boolean options

[PATCH] hw/xen: Don't use '#' flag of printf format
 2020-11-04 13:37 UTC 

[PATCH v2] qapi, qemu-options: make all parsing visitors parse boolean options the same
 2020-11-04 13:28 UTC  (7+ messages)

[PATCH] qapi, qemu-options: make all parsing visitors parse boolean options the same
 2020-11-04 13:25 UTC  (2+ messages)

[PATCH v1] docs/devel: Add VFIO device migration documentation
 2020-11-04 12:45 UTC  (8+ messages)

[PATCH] s390-bios: Skip writing iplb location to low core for ccw ipl
 2020-11-04 12:22 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).